Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » IllegalArgumentException for ProjectScope.java:57 when trying to view git revisions of PHP files
icon4.gif  IllegalArgumentException for ProjectScope.java:57 when trying to view git revisions of PHP files [message #1723417] Mon, 15 February 2016 13:56
Sven Berg Ryen is currently offline Sven Berg RyenFriend
Messages: 1
Registered: February 2016
Junior Member
This happens with a fresh workspace.

Whenever I try to open a git revision of a PHP file in Eclipse, it fails, and throws a
java.lang.IllegalArgumentException at org.eclipse.core.resources.ProjectScope.<init>(ProjectScope.java:57)

I've attached a screenshot of the error message.

index.php/fa/24993/0/

It happens regardless of my project settings, and for all projects in any workspace.

Steps to reproduce:
1. Open History view
2. Navigate to a commit that has PHP files
3. Right click the PHP file in the lower right inspector of the history pane and choose either "Open This Version" or "Open Previous Version"

In the same project, I can successfully open any revision of CSS, JS and TXT files, so this bug seems specific to PHP files.

I checked for updates, no available. Running Eclipse Version: Mars.1 Release (4.5.1) with PDT 3.7.0.201512212054

Hope the team can look into this, or if there's a workaround, I'd appreciate if somebody can let me know. I googled and found nothing directly related to my situation, though I did see some old bugs in Eclipse that were filed against the same error message, in other Eclipse projects.
Previous Topic:False-positive Error on unclosed html-tag
Next Topic:Postgres and PDT
Goto Forum:
  


Current Time: Wed Jan 17 01:49:48 GMT 2018

Powered by FUDForum. Page generated in 0.02565 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software