Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Oomph » An error occurred during the org.eclipse.equinox.internal.p2.engine.phases.CheckTrust phase
An error occurred during the org.eclipse.equinox.internal.p2.engine.phases.CheckTrust phase [message #1722845] Tue, 09 February 2016 14:55 Go to next message
Alexander Koptelov is currently offline Alexander KoptelovFriend
Messages: 10
Registered: December 2015
Junior Member
Hi,

Recently I got this error while installing a product. It's quite impossible to trace which file caused this without debugging. Actual file contains html instead of jar content. So, there are two questions:
1. Has anybody any opinion on how it could get into my bundle pool?
2. Looking at the stack in debugger, I can see that the actual file information is lost in p2 code. I suppose I should file a bug against p2?

Some additional info. The file that causes this error is org.kohsuke.args4j_2.0.21.v201301150030.jar from egit 4.1.1. The html content is actually content of http://download.eclipse.org/egit/updates-4.1.1/ as seen in browser. Previously this error was caused by another egit plugin (see https://www.eclipse.org/forums/index.php?t=msg&th=882229&goto=1718247&#msg_1718247).

See the log file in attachment.

Best regards,
Alex
  • Attachment: setup.log
    (Size: 6.63KB, Downloaded 156 times)
Re: An error occurred during the org.eclipse.equinox.internal.p2.engine.phases.CheckTrust phase [message #1722860 is a reply to message #1722845] Tue, 09 February 2016 17:30 Go to previous messageGo to next message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6487
Registered: July 2009
Senior Member
Hi Alexander,

This looks similar to https://www.eclipse.org/forums/index.php/t/882229/ , which nobody has been able, yet, to explain.
I tried to install EGit from http://download.eclipse.org/egit/updates-4.1.1 and it worked perfectly for me. I wonder if
the Java version used for the installer could be related. What version are you using?

Cheers
/Eike

----
http://www.esc-net.de
http://thegordian.blogspot.com
http://twitter.com/eikestepper



Am 09.02.2016 um 15:55 schrieb Alexander Koptelov:
> Hi,
>
> Recently I got this error while installing a product. It's quite impossible to trace which file caused this without debugging. Actual file contains html instead of jar content. So, there are two questions:
> 1. Has anybody any opinion on how it could get into my bundle pool?
> 2. Looking at the stack in debugger, I can see that the actual file information is lost in p2 code. I suppose I should file a bug against p2?
>
> Some additional info. The file that causes this error is org.kohsuke.args4j_2.0.21.v201301150030.jar from egit 4.1.1. The html content is actually content of http://download.eclipse.org/egit/updates-4.1.1/ as seen in browser. Previously this error was caused by another egit plugin (see https://www.eclipse.org/forums/index.php?t=msg&th=882229&goto=1718247&#msg_1718247).
>
> See the log file in attachment.
>
> Best regards,
> Alex


Re: An error occurred during the org.eclipse.equinox.internal.p2.engine.phases.CheckTrust phase [message #1723100 is a reply to message #1722860] Thu, 11 February 2016 15:36 Go to previous message
Alexander Koptelov is currently offline Alexander KoptelovFriend
Messages: 10
Registered: December 2015
Junior Member
Hi Eike,

I'm using IBM Java 8.
Regarding your experience with EGit installation, lately I did it a lot of times, and only two times that error happened.

/Alex
Previous Topic:ERROR: org.eclipse.equinox.p2.touchpoint.natives code=0 The action chmod failed
Next Topic:Package and distribute installer + product/project model?
Goto Forum:
  


Current Time: Wed Apr 08 09:25:10 GMT 2020

Powered by FUDForum. Page generated in 0.07522 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top