Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Help: Eclipse won't install due to old JVM?
Help: Eclipse won't install due to old JVM? [message #1722015] Tue, 02 February 2016 09:13 Go to next message
Oren Horesh is currently offline Oren HoreshFriend
Messages: 3
Registered: February 2016
Junior Member
I have used eclipse in the past and have been able to install it very easily.

However, now I bought a new Macbook and the installer tells me that the JVM on my computer is too old (see attached photo).

I would like to either download an older version of eclipse (as I am not expecting to write any insanely complicated programs) or find out how I can update my JVM to 17.

I have OS X Yosemite 10.10.5


Thanks for the help!

Oren
Re: Help: Eclipse won't install due to old JVM? [message #1722122 is a reply to message #1722015] Tue, 02 February 2016 19:44 Go to previous messageGo to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 493
Registered: August 2014
Senior Member
Go to Oracle Java pages and download and install the newest JRE for OS X, and try again. It works like a charm on my OS X 10.9.5.

A good start is <https://java.com/en/download/faq/java_mac.xml>.


--

Tauno Voipio
Re: Help: Eclipse won't install due to old JVM? [message #1722620 is a reply to message #1722122] Sun, 07 February 2016 03:59 Go to previous messageGo to next message
Oren Horesh is currently offline Oren HoreshFriend
Messages: 3
Registered: February 2016
Junior Member
I already downloaded the latest JRE - did not work.

What about an older eclipse version?
Re: Help: Eclipse won't install due to old JVM? [message #1722623 is a reply to message #1722620] Sun, 07 February 2016 08:36 Go to previous messageGo to next message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 493
Registered: August 2014
Senior Member
Open Terminal and write:
java -version

What do you get as response?

Did you follow the instructions on the Java pages?


--

Tauno Voipio
Re: Help: Eclipse won't install due to old JVM? [message #1722741 is a reply to message #1722620] Mon, 08 February 2016 18:37 Go to previous message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
Install a JDK, not the JRE. See this message for more details.
Previous Topic:Best way to collaborate in real-time with Eclipse?
Next Topic:Strange behaviour code still working
Goto Forum:
  


Current Time: Sun Aug 25 04:33:26 GMT 2019

Powered by FUDForum. Page generated in 0.03982 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top