Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Rich Client Platform (RCP) » Missing SWT(Missing SWT in older project)
Missing SWT [message #1721486] Wed, 27 January 2016 18:35 Go to next message
Dennis Merritt is currently offline Dennis MerrittFriend
Messages: 10
Registered: March 2010
Junior Member
Around 2012 I was successfully building my RCP IDE, maybe with 3.7.1, but when I tried again recently I received errors about missing SWT files. Even though, I'm sure, nothing has changed. So I decided to move to a more current Eclipse and start from there, and am now using 4.5.1.

I get the same errors. There is one each for my three major sub-projects, all similar to this:
The project was not built since its build path is incomplete. Cannot find the class file for org.eclipse.swt.graphics.Image. Fix the build path then try building this project

The downloaded release claims to have SWT included, so does anyone know what I need to fix this?

Disclaimer, I'm not the person who developed this RCP project, so I'm a bit naive about what is necessary for it.

Thanks in advance,
--Dennis

[Updated on: Wed, 27 January 2016 18:35]

Report message to a moderator

Re: Missing SWT [message #1721522 is a reply to message #1721486] Wed, 27 January 2016 23:09 Go to previous messageGo to next message
Dennis Merritt is currently offline Dennis MerrittFriend
Messages: 10
Registered: March 2010
Junior Member
Digging further, the error is larger than SWT, it can't resolve org.eclipse. Looking at the plugin.xml files, I see the error and comment that I must either manually create an OSGi bundle manifest, or install the Eclipse 2.0 Style Plugin Support. Any recommendations? I'd like this project to have a life into the future.

--Dennis
Re: Missing SWT [message #1721630 is a reply to message #1721522] Thu, 28 January 2016 17:53 Go to previous message
Dennis Merritt is currently offline Dennis MerrittFriend
Messages: 10
Registered: March 2010
Junior Member
This is turning into a travelog. Further digging got me to the manifest issue, and after installing the compatibility software I was able to generate manifest files for the affect projects, and find myself almost back at the beginning again. It seems everything is building OK except for lines of code requiring SWT. For example in one of my Java modules:

MessageDialog.openError(...) is flagged with the error that org.eclipse.swt.widgets.Shell cannot be resolved. It is indirectly referenced for required .class file.

I'll continue to dig, but if anyone has words of wisdom for me...

[Updated on: Thu, 28 January 2016 17:54]

Report message to a moderator

Previous Topic:PNG Splash Screen
Next Topic:CDATA in Extension Point Schema (.exsd file)
Goto Forum:
  


Current Time: Wed Dec 02 13:57:21 GMT 2020

Powered by FUDForum. Page generated in 0.01690 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top