Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Californium (Cf) CoAP Framework » Exception at CoAP Server addEndpoint
Exception at CoAP Server addEndpoint [message #1720698] Wed, 20 January 2016 10:45 Go to next message
Ashok Athukuri is currently offline Ashok AthukuriFriend
Messages: 14
Registered: November 2015
Junior Member
am trying one of example CoAP server program from Californium Github source file

I have used library californium-core-1.0.1.jar file

When I run below code to addEndpoints, I get an exception:

private void addEndpoints() {
for (InetAddress addr : EndpointManager.getEndpointManager().getNetworkInterfaces()) {
// only binds to IPv4 addresses and localhost
if (addr instanceof Inet4Address || addr.isLoopbackAddress()) {
System.out.println("addr: "+addr.toString());
InetSocketAddress bindToAddress = new InetSocketAddress(addr, COAP_PORT);
System.out.println("bindToAddress: "+bindToAddress.toString());
addEndpoint(new CoapEndpoint(bindToAddress));
Here is the Exception:

Jan 20, 2016 3:24:58 PM createStandardWithFile INFO: Storing standard properties in file

addr: / bindToAddress: /

Exception in thread "main" java.lang.NoClassDefFoundError: org/eclipse/californium/elements/RawDataChannel
at HelloWorldServer.addEndpoints(
at HelloWorldServer.main(
Caused by: java.lang.ClassNotFoundException: org.eclipse.californium.elements.RawDataChannel
at Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
... 2 more

I tried to clean and rebuild the project still same issue. Created project again, don't work

I see no file in GitHub Source org/eclipse/californium/elements/ is that is the problem !?

Thanks in advance

[Updated on: Wed, 20 January 2016 11:23]

Report message to a moderator

Re: Exception at CoAP Server addEndpoint [message #1720991 is a reply to message #1720698] Fri, 22 January 2016 10:53 Go to previous message
Ashok Athukuri is currently offline Ashok AthukuriFriend
Messages: 14
Registered: November 2015
Junior Member
I tried with old CoAP framework library ch.ethz.inf.vs ยป californium, but having same issue.
Previous Topic:om2m and telosb with californium libraries
Next Topic:How to add extra options to CoAP request?
Goto Forum:

Current Time: Sun Mar 18 11:49:06 GMT 2018

Powered by FUDForum. Page generated in 0.02034 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software