Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » EGit / JGit » SSH algorithm negotiation failed(Connecting from Egit to Github)
SSH algorithm negotiation failed [message #1720625] Wed, 20 January 2016 01:37 Go to next message
Jonathan Gossage is currently offline Jonathan GossageFriend
Messages: 71
Registered: March 2010
Location: Ottawa, ON, Canada
Member
I am unable to push to Github from Eclipse 4.5.1 with an error of 'algorithm negotiation failed' and the server requesting the use of 'publickey'. I have verified that the URI is OK and that the correct public key has been installed on Github. I am at a loss to know what I should be looking at to try and resolve this problem
Re: SSH algorithm negotiation failed [message #1720665 is a reply to message #1720625] Wed, 20 January 2016 08:45 Go to previous messageGo to next message
Christian Halstrick is currently offline Christian HalstrickFriend
Messages: 271
Registered: July 2009
Senior Member
Which protocol are you using (how does the URI look like)?

Ciao
Chris
Re: SSH algorithm negotiation failed [message #1720666 is a reply to message #1720625] Wed, 20 January 2016 08:45 Go to previous messageGo to next message
Christian Halstrick is currently offline Christian HalstrickFriend
Messages: 271
Registered: July 2009
Senior Member
Which protocol are you using (in other words: how does your URI look like)

Ciao
Chris
Re: SSH algorithm negotiation failed [message #1720667 is a reply to message #1720665] Wed, 20 January 2016 08:47 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 1175
Registered: July 2009
Senior Member
Which JGit and EGit version are you using ?
Find that under Help > Installation Details

If it's not 4.1.1 please upgrade to the latest release by pointing Help > Install new software...
to http://download.eclipse.org/egit/updates
Re: SSH algorithm negotiation failed [message #1720761 is a reply to message #1720665] Wed, 20 January 2016 17:14 Go to previous messageGo to next message
Jonathan Gossage is currently offline Jonathan GossageFriend
Messages: 71
Registered: March 2010
Location: Ottawa, ON, Canada
Member
1. I am using Egit/Jgit version 4.1.1.
2. I am using the SSH protocol and my URI is ssh://github.com/jfgossage/Sabia
Re: SSH algorithm negotiation failed [message #1721773 is a reply to message #1720761] Sat, 30 January 2016 03:39 Go to previous messageGo to next message
Jonathan Gossage is currently offline Jonathan GossageFriend
Messages: 71
Registered: March 2010
Location: Ottawa, ON, Canada
Member
Further information. I am running on Windows 0 and my local Git config file is the following:

[core]
symlinks = false
repositoryformatversion = 0
filemode = false
logallrefupdates = true
[branch "master"]
remote = origin
merge = refs/heads/master
[remote "origin"]
url = ssh://git@github.com/jfgossage/Sabia.git

Any help would be greatly appreciated as this has dragged on too long. Incidentally I can connect with Git on the command line so this appear to be specifically a Egit/Jgit problem.
Re: SSH algorithm negotiation failed [message #1721788 is a reply to message #1721773] Sat, 30 January 2016 14:31 Go to previous messageGo to next message
Jonathan Gossage is currently offline Jonathan GossageFriend
Messages: 71
Registered: March 2010
Location: Ottawa, ON, Canada
Member
I have verified that this problem also exists on Ubuntu 15.10 with latest Eclipse so it would appear to probably be a configuration problem. I don't think it is a problem with the SSH keys as I can connect with other software.
Re: SSH algorithm negotiation failed [message #1721962 is a reply to message #1721788] Mon, 01 February 2016 21:34 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 1175
Registered: July 2009
Senior Member
Check which version of com.jcraft.jsch you have installed, JGit is using this as a ssh client. If it's not 0.1.53 then try to ugprade to that version.
Maybe your ssh keys are using an algorithm not yet supported in your version of jsch. Find the details in jsch's change log
http://www.jcraft.com/jsch/ChangeLog

You can install com.jcraft.jsch 0.1.53 from http://download.eclipse.org/tools/orbit/downloads/drops/R20151221205849/repository/
If EGit doesn't come up after the upgrade start Eclipse with the -clean option (see https://bugs.eclipse.org/bugs/show_bug.cgi?id=478695)
Re: SSH algorithm negotiation failed [message #1721963 is a reply to message #1721962] Mon, 01 February 2016 21:36 Go to previous messageGo to next message
Matthias Sohn is currently offline Matthias SohnFriend
Messages: 1175
Registered: July 2009
Senior Member
Try to load your private ssh key from Eclipse: click "Preferences > Network Connections > SSH2 > Key Management > Load Existing Key..."
and select the private key you use for Github, the corresponding public needs to be uploaded to your Github account.
Re: SSH algorithm negotiation failed [message #1721966 is a reply to message #1721963] Mon, 01 February 2016 22:13 Go to previous message
Jonathan Gossage is currently offline Jonathan GossageFriend
Messages: 71
Registered: March 2010
Location: Ottawa, ON, Canada
Member
I had already done this before starting this exercise. The keys seem to be OK as I can access Github using SSH on Windows using the git command line package.
Previous Topic:Resetting a specific file
Next Topic:EGIT/GIT Eclipse contribution : difficulties with setup for 4.2.0 importing egit-developer-tools.p2
Goto Forum:
  


Current Time: Wed Apr 21 18:47:46 GMT 2021

Powered by FUDForum. Page generated in 0.01890 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top