Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sirius » e4 tools error when exporting VSP
e4 tools error when exporting VSP [message #1720319] Sun, 17 January 2016 03:25
Shin-Yi Lin is currently offline Shin-Yi LinFriend
Messages: 34
Registered: June 2015
Member
Hi all,

I not sure if the question is fine to be posted here. If it is Not OK, please tell me and maybe you can suggest me a better place to post.

Here is the problem:
When I export VSP (Viewpoint Specification Project) to "Deployable plug-ins and fragments" and then select "Install into host. Repository", it shows the error message:
------------------------------------------------------------------------------------------------------------
Cannot complete the install because one or more required items could not be found.
Software currently installed: E4 Event Spy (Incubation) 0.15.0.v20141107-1620 (org.eclipse.e4.tools.event.spy.feature.feature.group 0.15.0.v20141107-1620)
Missing requirement: E4 Event Spy (Incubation) 0.15.0.v20141107-1620 (org.eclipse.e4.tools.event.spy.feature.feature.group 0.15.0.v20141107-1620) requires 'org.eclipse.e4.tools.event.spy [0.15.0.v20140808-1908]' but it could not be found
------------------------------------------------------------------------------------------------------------
I guess 'org.eclipse.e4.tools.event.spy [0.15.0.v20140808-1908]' is missing, so I tried 3 ways to solve:
(1) updated E4 tools through Help > Eclipse Marketplace > Find: http://marketplace.eclipse.org/marketplace-client-intro?mpc_install=1852634, but it wouldn't let me to do so because it said, "there is no update needed"
(2) uninstalled Eclipse 4 Tools: Event Spy 0.16.0, but it shows the same error message, " 'org.eclipse.e4.tools.event.spy [0.15.0.v20140808-1908]' could not be found."
(3) got "org.eclipse.e4.tools.event.spy_0.15.0.v20140808-1908.jar" through Github, and then Add External JARs. But it still displayed the same error message when I export the project.

[Updated on: Sun, 17 January 2016 03:27]

Report message to a moderator

Previous Topic:Using EMF validation with Sirius diagrams
Next Topic:How to rearrange elements in the representation graphical view
Goto Forum:
  


Current Time: Wed Jan 20 19:24:25 GMT 2021

Powered by FUDForum. Page generated in 0.02037 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top