Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Requirements Modeling Framework  » Widget has the wrong parent(error opening specification)
icon13.gif  Widget has the wrong parent [message #1719949] Wed, 13 January 2016 13:28 Go to next message
Max Russell is currently offline Max RussellFriend
Messages: 39
Registered: May 2015
Member
I have my reqif file checked in to SVN. Due to some issues I had with the project, I reverted my reqif to an earlier version.

Now when I open my reqif file and open any of my specifications, I get an error thrown:

"An error has occurred. See error log for more details.
Widget has the wrong parent"

I am a bit concerned at this, as I've spent a lot of time building up my project.
Re: Widget has the wrong parent [message #1719967 is a reply to message #1719949] Wed, 13 January 2016 13:54 Go to previous messageGo to next message
Michael Jastram is currently offline Michael JastramFriend
Messages: 229
Registered: April 2010
Location: Düsseldorf, Germany
Senior Member
Hi Max,

Not sure exactly what happened. If there is an incompatibility, it's may be due to the tool extension. To test this, you can export and (re-)import the model via File | Import | Formalmind Studio | ReqIFz Import Wizard. The Wizard provides a checkbox to strip the tool extensions.

If that does not work, you can send me the file, and I'll have a look at it.

Best,

- Michael

PS: I think I still owe you an answer to a question from last year that I never responded to - sorry!


Re: Widget has the wrong parent [message #1784488 is a reply to message #1719967] Wed, 28 March 2018 15:44 Go to previous messageGo to next message
Al Bert is currently offline Al BertFriend
Messages: 1
Registered: March 2018
Junior Member
index.php/fa/32485/0/Michael Jastram wrote on Wed, 13 January 2016 13:54
Hi Max,

Not sure exactly what happened. If there is an incompatibility, it's may be due to the tool extension. To test this, you can export and (re-)import the model via File | Import | Formalmind Studio | ReqIFz Import Wizard. The Wizard provides a checkbox to strip the tool extensions.

If that does not work, you can send me the file, and I'll have a look at it.

Best,

- Michael

PS: I think I still owe you an answer to a question from last year that I never responded to - sorry!


Michael,

Have you ever found a resolution to this? I am experiencing the same issue. See attachment screenshot.

Regards,
Al Bert.
Re: Widget has the wrong parent [message #1784709 is a reply to message #1784488] Tue, 03 April 2018 05:34 Go to previous message
Michael Jastram is currently offline Michael JastramFriend
Messages: 229
Registered: April 2010
Location: Düsseldorf, Germany
Senior Member
Hi Max,

Sorry, no progress. This issue appears sporadically and unpredictably, making it hard to debug. Let me know if you can reproduce this reliably, that would be the first step in fixing it.

Best,
- Michael


Previous Topic:XHTML rendering
Goto Forum:
  


Current Time: Tue Sep 25 23:44:48 GMT 2018

Powered by FUDForum. Page generated in 0.01441 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top