Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BPMN 2.0 Modeler » Schema Read Problem After Update(After updating plugin I get schema_reference.4: Failed to read schema document )
Schema Read Problem After Update [message #1719452] Fri, 08 January 2016 07:19 Go to next message
Willem Duminy is currently offline Willem DuminyFriend
Messages: 4
Registered: July 2009
Junior Member
After updating the mars plugin version 1.2.2 I opened a workflow in the new BPMN2 Diagram Editor moved one of the diagram nodes a bit and saved the changes. This particular diagram was lasted editor using exporterVersion="1.2.2.201511241736" and it worked fine. The new diagram editor is exporterVersion="1.2.2.201512032052".

When I load this diagram (after editing) in my execution environment I get an hundreds of warning when loading up the workflow in my execution environment (I have shown an example of one of them below). Apart from the fact that it clutters the log file, it also takes much longer to load.

*** Example of error ***
08:04:13.200 [main] WARN  o.d.core.xml.ExtensibleXmlParser - (null: 1,549, 100): schema_reference.4: Failed to read schema document 'http[nolink]://www.omg.org/spec/BPMN/20100524/DI-XMI', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsd:schema>.
Re: Schema Read Problem After Update [message #1720284 is a reply to message #1719452] Fri, 15 January 2016 22:15 Go to previous message
Ralph Soika is currently offline Ralph SoikaFriend
Messages: 146
Registered: July 2009
Senior Member
Hi,
maybe it is a problem with one of the configuration files in the .settings/ folder of your eclipse workspace.
Can you please check the following blog posting, if this solves your problem?

http://blog.imixs.org/bpmn-modeller-not-loading-correctly/
Previous Topic:Import existing Pool from other file to Collaboration diagram
Next Topic:NoClassDefFoundError DefaultBpmn2RuntimeExtension$RootElementParser - after update to 1.2.3
Goto Forum:
  


Current Time: Mon Oct 15 21:36:22 GMT 2018

Powered by FUDForum. Page generated in 0.01809 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top