Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Luna on RHEL 6: unable to read repository at ~/.eclipse
Luna on RHEL 6: unable to read repository at ~/.eclipse [message #1719056] Mon, 04 January 2016 18:27 Go to next message
Chef Hoobajoob is currently offline Chef HoobajoobFriend
Messages: 16
Registered: December 2015
Junior Member
I'm trying to use the Eclipse Marketplace to install a plugin (though I have the same problem whether I go through Marketplace or 'Install New Software...'), and while the IDE appears to successfully retrieve information describing which features the plugin includes, when I try to start the installation I get this error:

Unable to read repository at file:/home/hoobajoob/.eclipse/org.eclipse.platform_4.4.2_1473617060_linux_gtx_x86_64/p2/org.eclipse.equinox.p2.repository/cache/compositContent1862373669.jar
 invalid entry CRC (expected 0xf8fe8221 but got 0xd5b3b444)


I have installed this same plugin using the same version of Eclipse on Windows without any problems, so I don't believe there is anything at all wrong with the plugin (fwiw, it's the Gradle Buildship plugin you find when you search for 'buildship' on the Eclipse Marketplace within Eclipse).

Any ideas how to fix this?

[Updated on: Mon, 04 January 2016 18:27]

Report message to a moderator

Re: Luna on RHEL 6: unable to read repository at ~/.eclipse [message #1719058 is a reply to message #1719056] Mon, 04 January 2016 18:39 Go to previous messageGo to next message
Chef Hoobajoob is currently offline Chef HoobajoobFriend
Messages: 16
Registered: December 2015
Junior Member
Update: I am able to install other plugins from the eclipse marketplace without error, but I'm finding that, after installing these, they are not displayed in the "Installation Details" dialog, so I can't uninstall them.

WTH? Is my Eclipse install munged?
Re: Luna on RHEL 6: unable to read repository at ~/.eclipse [message #1719064 is a reply to message #1719058] Mon, 04 January 2016 20:20 Go to previous messageGo to next message
Chef Hoobajoob is currently offline Chef HoobajoobFriend
Messages: 16
Registered: December 2015
Junior Member
Update: I backed out my Luna install and installed Pivotal's STS, version 3.7.2, which is apparently based on Eclipse 4.5.1 (Mars).

I'm still getting the same errors on a variety of different update attempts:

An error occurred while collecting items to be installed
session context was:(profile=DefaultProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
Error closing the output stream for org.eclipse.update.feature,com.codeaffine.archive.feature,0.1.0.20141116-1215 on repository file:/opt/sts-bundle/sts-3.7.2.RELEASE/.
Error unzipping /tmp/com.codeaffine.archive.feature_0.1.0.20141116-12158623875766870760387.jar: invalid entry CRC (expected 0xfe5f739d but got 0x12f55862)


Has anyone else seen this same problem?
Re: Luna on RHEL 6: unable to read repository at ~/.eclipse [message #1719074 is a reply to message #1719064] Mon, 04 January 2016 23:22 Go to previous messageGo to next message
Chef Hoobajoob is currently offline Chef HoobajoobFriend
Messages: 16
Registered: December 2015
Junior Member
I really don't know what the heck is going on, but I'm finding that if I delete ~/.eclipse/org.springsource.sts_3.7.2.RELEASE_826783593_linux_gtk_x86_64/p2/org.eclipse.equinox.p2.repository/cache after every failure and then just try again, eventually, these updates succeed.

I don't see this behavior on my windows Eclipse installs, but this RHEL install is surprisingly brittle.
Re: Luna on RHEL 6: unable to read repository at ~/.eclipse [message #1719097 is a reply to message #1719074] Tue, 05 January 2016 08:54 Go to previous message
Tauno Voipio is currently offline Tauno VoipioFriend
Messages: 484
Registered: August 2014
Senior Member
Have you ruled out bad hardware?

Linux uses your RAM more heavily than Windows, and errors like this could be caused by some bad RAM. Most Linux distributions install memtest86 together with the operating system. If I were you, I'd run the RAM test for some nights.


--

Tauno Voipio
Previous Topic:iTextEditor position coordinates on the screen
Next Topic:Eclipse 4.5 update sites: Page not found
Goto Forum:
  


Current Time: Tue Jun 18 08:50:16 GMT 2019

Powered by FUDForum. Page generated in 0.03911 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top