Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » RCP Testing Tool » AUT connection is failing , Unable to launch AUT(RCPTT is giving error while launching AUT with msg "AUT connection is failing for 590.0seconds")
AUT connection is failing , Unable to launch AUT [message #1718892] Fri, 01 January 2016 10:33 Go to next message
Madhavi T is currently offline Madhavi TFriend
Messages: 4
Registered: January 2016
Junior Member
when AUT is lauunched from eclipse RCPTT perspective , AUT is getting launched with dialog message .."operation in progress .." and after some time getting message "AUT connection is failing for 590.0seconds" and launched AUT is getting closed.
log file shows ...


!SESSION 2016-01-01 11:12:16.636 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.8.0_51
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_US
Framework arguments: -product ***-eclipse.keyring D:\Workspaces\Myproject\.metadata\.plugins\org.eclipse.pde.core\***secure_storage
Command-line arguments: -product *** -data D:\Workspaces\Myproject/../aut-*** -dev file:D:/Workspaces/Myproject/.metadata/.plugins/org.eclipse.pde.core/***/dev.properties -os win32 -ws win32 -arch x86_64 -consoleLog -eclipse.keyring D:\Workspaces\ Myproject\.metadata\.plugins\org.eclipse.pde.core\***/secure_storage

!ENTRY org.eclipse.emf 4 0 2016-01-01 11:12:22.000
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.emf [346]
Another singleton bundle selected: osgi.identity; osgi.identity="org.eclipse.emf"; type="osgi.bundle"; version:Version="2.6.0.v20150123-0452"; singleton:="true"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.emf.ant 4 0 2016-01-01 11:12:22.002
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.emf.ant [348]
Another singleton bundle selected: osgi.identity; osgi.identity="org.eclipse.emf.ant"; type="osgi.bundle"; version:Version="2.8.0.v20150123-0452"; singleton:="true"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1561)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
.
.
.
.
.
!ENTRY org.eclipse.rcptt.runtime.ui 1 0 2016-01-01 15:34:54.797
!MESSAGE Tesla server started on port 7002
java.lang.Exception: Bad call to getCoolBarManager()
at org.eclipse.ui.internal.WorkbenchWindow.getCoolBarManager(WorkbenchWindow.java:2979)
at org.eclipse.rcptt.tesla.ui.Q7KeyFormatter.installQ7Formatter(Q7KeyFormatter.java:66)
at org.eclipse.rcptt.tesla.ui.SWTTeslaStartup.earlyStartup(SWTTeslaStartup.java:18)
at org.eclipse.ui.internal.EarlyStartupRunnable.runEarlyStartup(EarlyStartupRunnable.java:89)
at org.eclipse.ui.internal.EarlyStartupRunnable.run(EarlyStartupRunnable.java:67)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
at org.eclipse.ui.internal.Workbench$56.run(Workbench.java:2755)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)

!ENTRY org.eclipse.rcptt.tesla.core.am 4 700 2016-01-01 15:34:54.893
!MESSAGE RCPTT aspects plugin "org.eclipse.rcptt.tesla.swt.aspects" is not initialized. Could not continue...

!ENTRY org.eclipse.rcptt.tesla.core.am 4 700 2016-01-01 15:34:55.905
!MESSAGE RCPTT aspects plugin "org.eclipse.rcptt.tesla.swt.aspects" is not initialized. Could not continue...

!ENTRY org.eclipse.rcptt.tesla.core.am 4 700 2016-01-01 15:34:56.949
!MESSAGE RCPTT aspects plugin "org.eclipse.rcptt.tesla.swt.aspects" is not initialized. Could not continue...
.
.




I am using eclipse Version: Luna Service Release 2 (4.4.2).
.



As AUT is not getting launched correctly from RCPTT, Please suggest solutions to solve this problem ?


Thanks
Madhavi

[Updated on: Wed, 06 January 2016 08:53]

Report message to a moderator

Re: AUT connection is failing , Unable to launch AUT [message #1719661 is a reply to message #1718892] Mon, 11 January 2016 08:33 Go to previous messageGo to next message
Madhavi T is currently offline Madhavi TFriend
Messages: 4
Registered: January 2016
Junior Member
Any solution for above mentioned problem..
Re: AUT connection is failing , Unable to launch AUT [message #1719943 is a reply to message #1719661] Wed, 13 January 2016 11:43 Go to previous messageGo to next message
Ines El Euch is currently offline Ines El EuchFriend
Messages: 35
Registered: March 2015
Member
Hello,

I don't know if this will solve your issue or not, but you may want to check this post https://www.eclipse.org/forums/index.php/m/1719942/#msg_1719942 and try the solution. It may solve your problem like it did for mine. You can give it a try Wink


Best regards,
Inès E.

[Updated on: Wed, 13 January 2016 11:44]

Report message to a moderator

Re: AUT connection is failing , Unable to launch AUT [message #1720348 is a reply to message #1719943] Mon, 18 January 2016 04:15 Go to previous messageGo to next message
Madhavi T is currently offline Madhavi TFriend
Messages: 4
Registered: January 2016
Junior Member
Its not working... I am still facing the same problem..
Thanks & Regards,
Madhavi
Re: AUT connection is failing , Unable to launch AUT [message #1720371 is a reply to message #1720348] Mon, 18 January 2016 09:19 Go to previous messageGo to next message
Krzysztof Jozefowicz is currently offline Krzysztof JozefowiczFriend
Messages: 19
Registered: May 2015
Junior Member
We had similar error on Linux env (I assume that you are running on Windows node) in CI. Graphical window manager (metacity) was not started before that properly ( in CI job it was started in separate batch job than rcptt execution ) but this is not the case here.
What about bit-wise , do you use the same bitwise RCPTT and product (32 or 64 bits)? Try to execute it with Rcptt runner.

Re: AUT connection is failing , Unable to launch AUT [message #1720476 is a reply to message #1720371] Mon, 18 January 2016 20:30 Go to previous messageGo to next message
Victor Dolirio is currently offline Victor DolirioFriend
Messages: 1
Registered: January 2016
Junior Member
I'm having the same problem. Looking forward for a solution. I've tried the above mentioned solution but no success.

Have someone tried another API for functional tests on eclipse/swt?
Re: AUT connection is failing , Unable to launch AUT [message #1720557 is a reply to message #1720476] Tue, 19 January 2016 10:08 Go to previous messageGo to next message
Ines El Euch is currently offline Ines El EuchFriend
Messages: 35
Registered: March 2015
Member
You can try this, in the launch configuration make sure that :

1) there is only the test case that you want to replay
2) the name of the test case is the same as the name given to it in the launch configuration (the Name filed on top), also if you use this character in the name of your test case "/" avoid it
3) in the common tab uncheck "Launch in Background"

I am not sure it is going to work for you but sometimes when it gets stuck I do that and it works. I believe it is worth the shot. Oh and I switched for the nightly build version of RCPTT.

Hope this helps

Inès

[Updated on: Tue, 19 January 2016 10:10]

Report message to a moderator

Re: AUT connection is failing , Unable to launch AUT [message #1720562 is a reply to message #1720557] Tue, 19 January 2016 10:27 Go to previous messageGo to next message
Ines El Euch is currently offline Ines El EuchFriend
Messages: 35
Registered: March 2015
Member
You can also try to run it from debug configuration
Re: AUT connection is failing , Unable to launch AUT [message #1841356 is a reply to message #1718892] Thu, 13 May 2021 03:00 Go to previous message
继亮 房 is currently offline 继亮 房Friend
Messages: 1
Registered: May 2021
Junior Member
Hello, I encountered the same problem during use, do you have a solution now?
Thanks very much
Previous Topic:Eclipse problems
Next Topic:get-cell doesn't work correclty in Virtual tables
Goto Forum:
  


Current Time: Wed Feb 21 12:41:34 GMT 2024

Powered by FUDForum. Page generated in 0.02053 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top