Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » ATL » ATL metamodel registration
ATL metamodel registration [message #1717632] Tue, 15 December 2015 12:29 Go to next message
Denis Nikiforov is currently offline Denis NikiforovFriend
Messages: 170
Registered: August 2013
Senior Member
Hi

Why the following packages aren't registered in Eclipse?
http://www.eclipse.org/gmt/2005/ATL
http://www.eclipse.org/gmt/2005/OCL
http://www.eclipse.org/gmt/2005/ATL-PrimitiveTypes

I want to write higher-order ATL transformation...

There is a simillar transformation here: https://www.eclipse.org/atl/atlTransformations/#KM32ATLCopier

But I can't understand how to run it because http://www.eclipse.org/gmt/2005/ATL isn't registred...
Re: ATL metamodel registration [message #1717708 is a reply to message #1717632] Wed, 16 December 2015 07:57 Go to previous messageGo to next message
Denis Nikiforov is currently offline Denis NikiforovFriend
Messages: 170
Registered: August 2013
Senior Member
I'm using the following hacked ANT-script (with explicit path to ATL.ecore) to execute my transformation. But I don't think it's a good solution...

<?xml version="1.0"?>
<project name="HelloWorldATL">
    <target name="GenerateHelloWorld">
        <!-- Loading metamodels -->
        <atl.loadModel name="Ecore" metamodel="MOF" nsURI="http://www.eclipse.org/emf/2002/Ecore" />
        <atl.loadModel name="ATL" metamodel="MOF" nsURI="platform:/plugin/org.eclipse.m2m.atl.common/org/eclipse/m2m/atl/common/resources/ATL.ecore" />
        <!-- Loading models -->
        <atl.loadModel name="IN" metamodel="Ecore" path="output/MyModel.xmi" />
        <!-- Transformation -->
        <atl.launch path="GenerateHelloWorld.atl">
            <inmodel name="IN" model="IN" />
            <outmodel name="OUT" model="OUT" metamodel="ATL" />
        </atl.launch>
        <!-- Saving models -->
        <atl.saveModel model="OUT" path="output/HelloWorld.atl">
        	<extractor name="ATL" />
    	</atl.saveModel>
    </target>
</project>


Re: ATL metamodel registration [message #1726268 is a reply to message #1717708] Thu, 10 March 2016 20:33 Go to previous message
Dennis Wagelaar is currently offline Dennis WagelaarFriend
Messages: 351
Registered: September 2012
Location: Belgium
Senior Member

The packages are registered since http://git.eclipse.org/c/mmt/org.eclipse.atl.git/commit/?id=9496f0f2e889dd77a3497674624543b74a11122c
This fix will be included in ATL 3.7. You can already use a 3.7 pre-release by installing ATL/EMFTVM from Eclipse Marketplace.


Cheers,
Dennis
Previous Topic:Re: local variables: self=IN!&lt;unnamed&gt;
Next Topic:Problem Papyrus and stereotype applied
Goto Forum:
  


Current Time: Tue Nov 21 23:23:30 GMT 2017

Powered by FUDForum. Page generated in 0.02143 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software