Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Proposals » OSGi Enterprise Tools » Restricting Plug-in Dependency to fixed version(Restricting Plug-in Dependency to fixed version)
Restricting Plug-in Dependency to fixed version [message #1717123] Thu, 10 December 2015 06:59
kirankumar B S is currently offline kirankumar B SFriend
Messages: 36
Registered: July 2015
Member
Hello,

I am working on product developed using plugins(Osgi framework).

Logging is implemented in Product using org.slf4j.api_1.6.1 and it is working fine.
We have used buildship plug-in for my product to get Gradle functionality, problem is it is alos using org.slf4j.api_1.7.2(minimum).

Now my plug-ins are not working as two slf4j plug-ins are there in target-paltform.

How can i restrict my plug-in's to use slf4j 1.6.1 version though highr version is available.

Thanks,
Kiran.
Previous Topic:Help to recovery files
Next Topic:OSGI ExtensionPoints
Goto Forum:
  


Current Time: Fri Nov 16 22:28:49 GMT 2018

Powered by FUDForum. Page generated in 0.01943 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top