Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Unable to install Spring IDE using Marketplace
Unable to install Spring IDE using Marketplace [message #1715865] Thu, 26 November 2015 18:37 Go to next message
Sarath S Nair is currently offline Sarath S NairFriend
Messages: 1
Registered: November 2015
Junior Member
I have downloaded Eclipse EE Indigo and installed Maven Integration for Eclipse plugin. Whenever I tried to install Spring IDE using Marketplace, I am getting the below error..
Cannot complete the install because one or more required items could not be found.
  Software being installed: Spring IDE Roo Support 3.6.4.201503051146-RELEASE (org.springframework.ide.eclipse.roo.feature.feature.group 3.6.4.201503051146-RELEASE)
  Missing requirement: Java Development Tools Launching Support 3.7.50.v20140317-1921 (org.eclipse.jdt.launching 3.7.50.v20140317-1921) requires 'bundle org.eclipse.debug.core [3.8.0,4.0.0)' but it could not be found
  Cannot satisfy dependency:
    From: AspectJ Development Tools 2.2.4.e43yJ8-20140523-1400 (org.eclipse.ajdt.feature.group 2.2.4.e43yJ8-20140523-1400)
    To: org.eclipse.ajdt.ui [2.2.4.e43yJ8-20140523-1400]
  Cannot satisfy dependency:
    From: AspectJ Development Tools UI 2.2.4.e43yJ8-20140523-1400 (org.eclipse.ajdt.ui 2.2.4.e43yJ8-20140523-1400)
    To: bundle org.eclipse.jdt.ui [3.8.0,4.9.0)
  Cannot satisfy dependency:
    From: Java Development Tools UI 3.9.50.v20140317-1811 (org.eclipse.jdt.ui 3.9.50.v20140317-1811)
    To: bundle org.eclipse.jdt.launching [3.6.100,4.0.0)
  Cannot satisfy dependency:
    From: Spring IDE Roo Support 3.6.4.201503051146-RELEASE (org.springframework.ide.eclipse.roo.feature.feature.group 3.6.4.201503051146-RELEASE)
    To: org.eclipse.ajdt.feature.group 2.0.1


Can someone help me. I downloaded the latest versions for the eclipse and maven.
Re: Unable to install Spring IDE using Marketplace [message #1715873 is a reply to message #1715865] Thu, 26 November 2015 20:53 Go to previous message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3421
Registered: July 2009
Senior Member

Indigo is not the latest version. That would be Mars.1, the default version you'll find by going to http://download.eclipse.org .

Nitin Dahyabhai
Eclipse Web Tools Platform
Previous Topic:Applet -> NoClassDefFoundError ?
Next Topic:hey I am a new member
Goto Forum:
  


Current Time: Mon Jun 24 14:11:36 GMT 2019

Powered by FUDForum. Page generated in 0.02864 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top