Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Cannot get Eclipse for C/C++ to debug(Problems debugging)
icon5.gif  Cannot get Eclipse for C/C++ to debug [message #1715635] Tue, 24 November 2015 20:32 Go to next message
JUAN DENT is currently offline JUAN DENTFriend
Messages: 4
Registered: November 2015
Junior Member
Hi,

I just downloaded :

Eclipse IDE for C/C++ Developers
Version: Mars.1 Release (4.5.1)
Build id: 20150924-1200


and was unable to debug (message about gdb version) so I downloaded latest version of gdb (7.10) and built it in the gdb-7.10 directory by running:

./configure
make

Then copied gdb into /usr/local/bin/gdb

But when I try to run the debugger (after setting the gdb to where I put it) I get:

Python Exception <type 'exceptions.ImportError'> No module named gdb:
/usr/local/bin/gdb/gdb: warning:
Could not load the Python gdb module from `/usr/local/share/gdb/python'.
Limited Python support is available from the _gdb module.
Suggest passing --data-directory=/path/to/gdb/data-directory.

-----

What could be going on?

Thanks!!
Juan
Re: Cannot get Eclipse for C/C++ to debug [message #1715655 is a reply to message #1715635] Wed, 25 November 2015 06:06 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30442
Registered: July 2009
Senior Member
Please ask about CDT on the CDT forum.
http://eclipse.org/forums/eclipse.tools.cdt


On 24/11/2015 11:18 PM, JUAN DENT wrote:
> Hi,
>
> I just downloaded :
>
> Eclipse IDE for C/C++ Developers
> Version: Mars.1 Release (4.5.1)
> Build id: 20150924-1200
>
>
> and was unable to debug (message about gdb version) so I downloaded
> latest version of gdb (7.10) and built it in the gdb-7.10 directory by
> running:
>
> /configure
> make
>
> Then copied gdb into /usr/local/bin/gdb
>
> But when I try to run the debugger (after setting the gdb to where I
> put it) I get:
>
> Python Exception <type 'exceptions.ImportError'> No module named gdb:
> /usr/local/bin/gdb/gdb: warning: Could not load the Python gdb module
> from `/usr/local/share/gdb/python'.
> Limited Python support is available from the _gdb module.
> Suggest passing --data-directory=/path/to/gdb/data-directory.
>
> -----
>
> What could be going on?
>
> Thanks!!
> Juan
Previous Topic:creating a php project using existing folder
Next Topic:Xtext Semantic Coloring
Goto Forum:
  


Current Time: Mon Sep 16 12:36:24 GMT 2019

Powered by FUDForum. Page generated in 0.03421 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top