Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Hudson » Hudson slave on Windows use a bad path for maven
Hudson slave on Windows use a bad path for maven [message #1715121] Thu, 19 November 2015 11:55 Go to next message
Elko Kinlechner is currently offline Elko KinlechnerFriend
Messages: 4
Registered: August 2015
Junior Member
Hello,

We have a Hudson-master (3.3.2) on Linux, with Maven3-plugin (3.0.5).
Furthermore we use a Hudson-slave of this master on Windows.
In the master configuration there I defined the Linux-path to Maven (3.0.5).
In the node configuartion for this slave there I defined the path to Maven (3.0.5) for the Windows-slave. (d:\...\apache-maven-3.0.5).
We use a jdk 1.7.0.

In jobs I use the Maven3 plugin with a reference to apache-maven-3.0.5.
Jobs on the master havn´t problems.
But jobs on the slave fail because the plugin use the Linux-Path (/home/.../apache-maven-3.0.5) to apache-maven-3.0.5 and not the Windows-path from the configuraton for the slave node.

Has anyone an idea?

Thanks
Elko


[Updated on: Thu, 19 November 2015 11:57]

Report message to a moderator

Re: Hudson slave on Windows use a bad path for maven [message #1715167 is a reply to message #1715121] Thu, 19 November 2015 18:14 Go to previous messageGo to next message
Winston Prakash is currently offline Winston PrakashFriend
Messages: 534
Registered: August 2011
Location: Fremont, CA USA
Senior Member
Hmm.. that is strange. The plugin is supposed to use the exact path defined in the tools section of the slave configuration. Can you please file a bug at https://bugs.eclipse.org/bugs/enter_bug.cgi?product=Hudson (Use components Plugins). We will try to reproduce and fix.



Winston Prakash
Eclipse Hudson team
Re: Hudson slave on Windows use a bad path for maven [message #1717133 is a reply to message #1715167] Thu, 10 December 2015 08:19 Go to previous message
Elko Kinlechner is currently offline Elko KinlechnerFriend
Messages: 4
Registered: August 2015
Junior Member
Okay. Thanks.
Elko

[Updated on: Thu, 10 December 2015 08:20]

Report message to a moderator

Previous Topic:Missing Jobs after Downgrade
Next Topic:Hudson problem after interuption on slave
Goto Forum:
  


Current Time: Tue Jun 27 19:25:04 GMT 2017

Powered by FUDForum. Page generated in 0.21151 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software