Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » P2 » ConfiguratorManipulator not getting called(ConfiguratorManipulator not getting called during the execution of dropins capability)
ConfiguratorManipulator not getting called [message #1715077] Thu, 19 November 2015 02:34
Chiranga Alwis is currently offline Chiranga AlwisFriend
Messages: 5
Registered: November 2015
Junior Member
Hi,

I am currently working on integrating the dropins capability to the WSO2 Carbon kernel using Equinox P2. Currently, I have added all the required bundles to startup the org.eclipse.equinox.p2.reconciler.dropins_(version).jar, added the startup details to bundles.info and all the required P2 bundles are getting started.

But yet I find that the bundles added to the dropins capability are not started up. When debugging the code I find that the usual functionality of the org.eclipse.equinox.p2.reconciler.dropins is carried out but the org.eclipse.equinox.simpleconfigurator.manipulator which starts up using the bundles.info details as in Eclipse IDE does not get called.

I checked the latest Eclipse IDE's corresponding files for any missing configurations but it seems both configurations are almost similar. Is there a particular procedure to follow when configuring the manipulator?

Any help with regards to this is highly appreciated.
  • Attachment: config.ini
    (Size: 0.70KB, Downloaded 72 times)
  • Attachment: bundles.info
    (Size: 6.30KB, Downloaded 60 times)

[Updated on: Thu, 19 November 2015 04:32]

Report message to a moderator

Previous Topic:org.eclipse.equinox.p2.reconciler.dropins maven repository bundle not available
Next Topic:Can't uninstall RCP feature patch
Goto Forum:
  


Current Time: Mon Sep 24 01:23:12 GMT 2018

Powered by FUDForum. Page generated in 0.01907 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top