Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Error code 143(Solved!)
Error code 143 [message #1714619] Sat, 14 November 2015 03:39 Go to next message
michael mayer is currently offline michael mayerFriend
Messages: 4
Registered: November 2015
Junior Member
I have been using eclipse for a couple months now, I am a student taking java classes. Everything was running fine until a recent system update back in the middle of October.

I am able to open eclipse, and that is about it. When I click on run nothing happens, and when I click on runas eclipse freezes, this is when i get error 143. The only way I am able to close it is with killall. Another thing I noticed is when I try to start a new java project, it also freezes after I click on next or finish. When i go to the preferences menu, not matter what I click on it stays on the first tab.

I am running 32bit archlinux
my default jre is openjdk7

I have attached the error log, although there is nothing in it, and the log from when I try to install with the new installer. It will go to a certain point and then undo everything and install fails.

I'm sure there is more info you need, just let me know.
  • Attachment: Eclipse.log
    (Size: 0.14KB, Downloaded 90 times)
  • Attachment: setup.log
    (Size: 126.62KB, Downloaded 104 times)

[Updated on: Wed, 18 November 2015 02:46]

Report message to a moderator

Re: Error code 143 [message #1714963 is a reply to message #1714619] Wed, 18 November 2015 02:45 Go to previous message
michael mayer is currently offline michael mayerFriend
Messages: 4
Registered: November 2015
Junior Member
Ok, so the problem is fixed now! I am putting this here in case anyone is having a similar problem. It seems there is a problem with GTK3 and I don't know if it's just an Archlinux problem or not. I am submitting a report on it and see if it can be fixed.

I attached a link to the thread I found the answer from. All I needed to do was insert these two lines in "eclipse.ini"

--launcher.GTK_version
2

https://www.eclipse.org/forums/index.php?t=msg&th=1072144&goto=1714643&#msg_1714643
Previous Topic:All Eclipse Mars Dialogs Hang
Next Topic:SQL error #1:Invalid object name 'T_TRIRIGATABLE.
Goto Forum:
  


Current Time: Fri Aug 23 00:50:00 GMT 2019

Powered by FUDForum. Page generated in 0.02523 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top