Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sirius » Difficulty of the Java Service Usage
Difficulty of the Java Service Usage [message #1713460] Wed, 04 November 2015 09:36 Go to next message
eunjung park is currently offline eunjung parkFriend
Messages: 72
Registered: April 2015
Member
Hi all,
I had another problem while using the Java Service.
I followed the advanced tutorial [1], but my program doesn't work.
I attach my screen shots.
Could someone help me to find something wrong?

Thank you in advance.

Best Regards,
Grace Eunjung

[1] https://wiki.eclipse.org/Sirius/Tutorials/AdvancedTutorial

index.php/fa/23827/0/
index.php/fa/23828/0/

[Updated on: Wed, 04 November 2015 09:46]

Report message to a moderator

Re: Problem of the Java Service Usage [message #1713570 is a reply to message #1713460] Thu, 05 November 2015 09:00 Go to previous messageGo to next message
Esteban Dugueperoux is currently offline Esteban DugueperouxFriend
Messages: 472
Registered: July 2009
Senior Member
Hi,

Do you have validation errors on your odesign? Have you exception in
error log when using the diagram editor? It seems that your label
expression is not correctly evaluated, perhaps because your java service
is not found. You could try by changing the type of the parameter in
your java service, try with EObject instead of NFRSoftgoal and set a
breakpoint in debug in your java service to see the real type of argument.

Best Regards.

Le 04/11/2015 10:36, eunjung park a écrit :
> Hi all,
> I had another problem while using the Java Service.
> I followed the advanced tutorial [1], but my program doesn't work.
> I attach my screen shots.
> Could someone help me to find something wrong?
>
> Thank you in advance.
>
> Best Regards,
> Grace Eunjung
>
> [1] https://wiki.eclipse.org/Sirius/Tutorials/AdvancedTutorial
>
>
>



--
Esteban Dugueperoux - Obeo

Need training or professional services for Sirius?
http://www.obeodesigner.com/sirius
Re: Problem of the Java Service Usage [message #1714113 is a reply to message #1713570] Tue, 10 November 2015 00:05 Go to previous message
eunjung park is currently offline eunjung parkFriend
Messages: 72
Registered: April 2015
Member
Hi Esteban,

Thank you for your comments.
I changed the parameter , but it still the odesign file cannot recognize the Java Service that I defined. It showed error message before I executed it. Could you take a look at it once more?
I don't know why this happen. I tried to several ways, but it doesn't work.
Thank you so much.

Best Regards,
Grace

index.php/fa/23887/0/
Previous Topic:Sequence Diagrams troubles
Next Topic:How to forbid two views with same name in the same project ?
Goto Forum:
  


Current Time: Mon Jan 25 08:34:22 GMT 2021

Powered by FUDForum. Page generated in 0.02219 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top