Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » xdebug - dont let me handle user interaction(xdebug - php - remote debugging)
xdebug - dont let me handle user interaction [message #1709138] Thu, 24 September 2015 12:25 Go to next message
Frank Weinberg is currently offline Frank WeinbergFriend
Messages: 5
Registered: September 2015
Junior Member
i have the following problem:

i'd like to debug user-interaction. therefor i made two simple test-scripts. the first one contains a little form. the second one is getting the data via GET and displays the data.

when i start the debugging-session as php-web-application - a browser window opens - but the browser-window and the url-line is empty (but there is the right url in the browser -tab).

if i ,for example, debug some function - everything works fine.

maybe someone can help me....
Re: xdebug - dont let me handle user interaction [message #1709151 is a reply to message #1709138] Thu, 24 September 2015 13:27 Go to previous messageGo to next message
Dawid Pakula is currently offline Dawid PakulaFriend
Messages: 243
Registered: March 2013
Senior Member
I'm not sure what is your problem?

1. Additional empty tab?
2. Not working web debugging?


Re: xdebug - dont let me handle user interaction [message #1709165 is a reply to message #1709151] Thu, 24 September 2015 14:49 Go to previous messageGo to next message
Frank Weinberg is currently offline Frank WeinbergFriend
Messages: 5
Registered: September 2015
Junior Member
thx for answer!

the problem is that the web-debugging is not working.

when i start the debugging-session -> the browser-window looks like this (jpeg 1).

when i end the session manually or reach the breakpoint - the browser shows the followig (jpeg 2)

i hope this will make my problem more tangible
  • Attachment: debug.JPG
    (Size: 81.24KB, Downloaded 165 times)
  • Attachment: debug_.JPG
    (Size: 62.28KB, Downloaded 277 times)
Re: xdebug - dont let me handle user interaction [message #1709172 is a reply to message #1709165] Thu, 24 September 2015 15:09 Go to previous messageGo to next message
Mark Dexter is currently offline Mark DexterFriend
Messages: 324
Registered: July 2009
Senior Member
It looks like it is working. Have you tried stepping through the code or simply pressing the Run button?
Re: xdebug - dont let me handle user interaction [message #1709173 is a reply to message #1709172] Thu, 24 September 2015 15:11 Go to previous messageGo to next message
Dawid Pakula is currently offline Dawid PakulaFriend
Messages: 243
Registered: March 2013
Senior Member
You probably have checked "break at first line" at debug launch configuration.

Re: xdebug - dont let me handle user interaction [message #1709179 is a reply to message #1709173] Thu, 24 September 2015 16:04 Go to previous messageGo to next message
Frank Weinberg is currently offline Frank WeinbergFriend
Messages: 5
Registered: September 2015
Junior Member
thx for any suggestions ....

yes indeed - i have checked "break at first line". now i have changed this setting - but the problem still occurs

and yes, i can step through code. but this is not very effective, because the variables ($_GET , $_POST ...) are empty.

in my opinion it should work like this: when i start the debugging-session -> the browser window displaying the form -> i type in the values and klick on send.....

but in my case, the browser window ist empty - so it's not possible to set this variables


Re: xdebug - dont let me handle user interaction [message #1709180 is a reply to message #1709179] Thu, 24 September 2015 16:09 Go to previous messageGo to next message
Dawid Pakula is currently offline Dawid PakulaFriend
Messages: 243
Registered: March 2013
Senior Member
$_GET and $_POST aren't empty if you send something and you are during debug.

If internal browser cannot render your website ('m not sure why, maybe have you something in logs?). As an workaround can you try with external browser? : Preferences / General / Use external web browser


Re: xdebug - dont let me handle user interaction [message #1709181 is a reply to message #1709180] Thu, 24 September 2015 16:16 Go to previous messageGo to next message
Dawid Pakula is currently offline Dawid PakulaFriend
Messages: 243
Registered: March 2013
Senior Member
Next:
1. Run debug (browser will be opened).
2. Add breakpoint.
3. Submit form in browser


Re: xdebug - dont let me handle user interaction [message #1709190 is a reply to message #1709181] Thu, 24 September 2015 17:30 Go to previous messageGo to next message
Frank Weinberg is currently offline Frank WeinbergFriend
Messages: 5
Registered: September 2015
Junior Member
thank u for supporting me!

i followed your instructions - now, i think i'm one step further

1. run the debug -> the browser (firefox) starts -> with the correct url (i think) - //localhost/test/index.php?XDEBUG_SESSION_START=ECLIPSE_DBGP&KEY=14431153524257
(the site is loading, but nothing happens in the browser window - "waiting for localhost"

2. when i end the debug-session - the browser shows this link: //localhost/test/index.php?XDEBUG_SESSION_STOP_NO_EXEC=ECLIPSE_DBGP&KEY=14431153524257

if i just run the application (without debugging) -> the browser shows the site as expected!

any idea what's wrong? i'd really like to see the form in the browser window...






  • Attachment: php_ini.JPG
    (Size: 41.08KB, Downloaded 289 times)

[Updated on: Thu, 24 September 2015 19:13]

Report message to a moderator

Re: xdebug - dont let me handle user interaction [message #1709200 is a reply to message #1709190] Thu, 24 September 2015 20:13 Go to previous messageGo to next message
Dawid Pakula is currently offline Dawid PakulaFriend
Messages: 243
Registered: March 2013
Senior Member
Based on your description, debugging already running.

You have "break on first line" enabled so debugger stuck on first line after each request. Disable it in launch configuration or remember about F8 (resume button in debug perspective) on each request.

You can also in debugger settings (php / debugger /debuggers /xdebug), enable JIT (accept remote session) for localhost + optionally multisession. Later use browser extension for stop/start debugger (for example firefox the easiest xdebug: https://addons.mozilla.org/en-us/firefox/addon/the-easiest-xdebug/)


Re: xdebug - dont let me handle user interaction [message #1709236 is a reply to message #1709200] Fri, 25 September 2015 07:46 Go to previous message
Frank Weinberg is currently offline Frank WeinbergFriend
Messages: 5
Registered: September 2015
Junior Member
HEUREKA, it work's !!!

Thank you very much for your efforts
Previous Topic:MasterCard integration Using Php language ?
Next Topic:Generation of getter and setter
Goto Forum:
  


Current Time: Sun Sep 23 00:14:18 GMT 2018

Powered by FUDForum. Page generated in 0.02253 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top