Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » ECP 1.7 and EMFStore 1.6(ECP 1.7 and EMFStore 1.6)
ECP 1.7 and EMFStore 1.6 [message #1708739] Sat, 19 September 2015 18:29 Go to next message
Neil Mackenzie is currently offline Neil MackenzieFriend
Messages: 123
Registered: December 2013
Senior Member
Hello is there a time estimate or milestone estimate of when ECP will support EMFstore 1.6? Is it planned for the next release? Currently the 1.7 ECP target is linked to EMFStore 1.5. Thanks, Neil
Re: ECP 1.7 and EMFStore 1.6 [message #1708989 is a reply to message #1708739] Wed, 23 September 2015 07:35 Go to previous messageGo to next message
Jonas Helming is currently offline Jonas HelmingFriend
Messages: 699
Registered: July 2009
Senior Member
Hi,

we updated the target, when we merged back the 1.7.0 release branch. So
1.7.0 already works with 1.6.0

Best regards

Jonas

Am 19.09.2015 um 20:29 schrieb Neil Mackenzie:
> Hello is there a time estimate or milestone estimate of when ECP will
> support EMFstore 1.6? Is it planned for the next release? Currently
> the 1.7 ECP target is linked to EMFStore 1.5. Thanks, Neil


--
--

Jonas Helming

Get professional Eclipse developer support:

http://eclipsesource.com/en/services/developer-support/
Re: ECP 1.7 and EMFStore 1.6 [message #1709397 is a reply to message #1708989] Mon, 28 September 2015 08:45 Go to previous messageGo to next message
Neil Mackenzie is currently offline Neil MackenzieFriend
Messages: 123
Registered: December 2013
Senior Member
Hi Jonas,
Thanks for your reply.
When I look at the code , ECP release 1.7 apears to be linked to EMFStore 1.5, not EMFStore 1.6.
When I look at EMFstore git repository I dont think EMFStore 1.6 is released yet (unless I have some config error with git). The latest version seems to be 1.6RC2.
When I compile ECP against EMFstore 1.6RC2 I have one compile time error because a method "projectSpace.getOperationManager().addOperationObserver(new OperationObserver()" referenced in ECP class EMFStoreProvider no longer exists in EMFstore (it was removed in a recent commit 5 weeks ago to fix bug Bug 475601 - "Operation manageroperation observer became global in 1.5.0 ") .
However simply removing this method call seems to have no negative impact on the behaviour and allows compilation and execution of ECP 1.7 with EMFStore 1.6.
Re: ECP 1.7 and EMFStore 1.6 [message #1709446 is a reply to message #1709397] Mon, 28 September 2015 13:03 Go to previous message
Neil Mackenzie is currently offline Neil MackenzieFriend
Messages: 123
Registered: December 2013
Senior Member
My mistake, I had not not fully updated my workspace for ecp release 1.7.
Thanks,
Neil
Previous Topic:[EMF Forms] Redraw custom control
Next Topic:[EMFForms] Tree Master Detail
Goto Forum:
  


Current Time: Sun Feb 23 15:00:09 GMT 2020

Powered by FUDForum. Page generated in 0.02276 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top