Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Proposals » OSGi Enterprise Tools » OSGI Services- java.util.ServiceLoader problem(OSGI Services- java.util.ServiceLoader problem)
OSGI Services- java.util.ServiceLoader problem [message #1708448] Wed, 16 September 2015 15:05 Go to next message
cenk Mising name is currently offline cenk Mising nameFriend
Messages: 157
Registered: July 2009
Senior Member
Hi,

You know Hibernate 4 event system is based on services. The Event class is defined in META-INF/services/org.hibernate.integrator.spi.Integrator.
We created OSGI project on Eclipse Mars. And created org.hibernate.integrator.spi.Integrator in META-INF/services. But I see OSGI cannot see services folder. java.util.ServiceLoader not loaded service in services folder.

What is the OSGI solution for this issue.

Thank You
Cenk
Re: OSGI Services- java.util.ServiceLoader problem [message #1708567 is a reply to message #1708448] Thu, 17 September 2015 13:58 Go to previous message
cenk Mising name is currently offline cenk Mising nameFriend
Messages: 157
Registered: July 2009
Senior Member
Hi,
We solved the problem. The problem solved by Hibernate. we upgraded Hibernate 5.0.1 and we used hibenate.osgi 5.0.1
Previous Topic: Install New Software shows error dialog when clicked
Next Topic:Apache Felix - Spring DM server - Eclipse IDE
Goto Forum:
  


Current Time: Fri Sep 21 02:33:58 GMT 2018

Powered by FUDForum. Page generated in 0.01520 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top