Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Memory Analyzer » error when opening a heap dump in eclipse MAT (1.5)(I created a dump using below command jmap -heap:format=b <process id> and getting the below error when I open it from Eclipse memory analyzer. java.io.EOFException at org.eclipse.mat.parser.io.)
error when opening a heap dump in eclipse MAT (1.5) [message #1707068] Wed, 02 September 2015 04:38 Go to next message
Thrishala Ediriweera is currently offline Thrishala EdiriweeraFriend
Messages: 1
Registered: September 2015
Junior Member
I have uploaded the dump file which I can't open from MAT .
java.io.EOFException
at org.eclipse.mat.parser.io.PositionInputStream.readFully(PositionInputStream.java:108)
at org.eclipse.mat.parser.io.PositionInputStream.readLong(PositionInputStream.java:157)
at org.eclipse.mat.hprof.AbstractParser.readID(AbstractParser.java:153)
at org.eclipse.mat.hprof.Pass1Parser.readLoadClass(Pass1Parser.java:275)
at org.eclipse.mat.hprof.Pass1Parser.read(Pass1Parser.java:157)
at org.eclipse.mat.hprof.HprofIndexBuilder.fill(HprofIndexBuilder.java:80)
at org.eclipse.mat.parser.internal.SnapshotFactoryImpl.parse(SnapshotFactoryImpl.java:222)
at org.eclipse.mat.parser.internal.SnapshotFactoryImpl.openSnapshot(SnapshotFactoryImpl.java:126)
at org.eclipse.mat.snapshot.SnapshotFactory.openSnapshot(SnapshotFactory.java:145)
at org.eclipse.mat.ui.snapshot.ParseHeapDumpJob.run(ParseHeapDumpJob.java:83)
at org.eclipse.core.internal.jobs.Worker.run(Worker.java:53)
Re: error when opening a heap dump in eclipse MAT (1.5) [message #1708572 is a reply to message #1707068] Thu, 17 September 2015 15:04 Go to previous message
Krum Tsvetkov is currently offline Krum TsvetkovFriend
Messages: 161
Registered: July 2009
Senior Member
I had a look. It seems that the file is corrupt. MAT fails to read a few bytes (the ID of some class record), as it reaches the end of the file.
Tried opening the dump with the tools coming with the JDK -> same result.
Previous Topic:Heap dump instances count differs for Visualvm and Eclipse Memory Analyzer
Next Topic:gc_roots count correct?
Goto Forum:
  


Current Time: Sat Nov 17 17:20:52 GMT 2018

Powered by FUDForum. Page generated in 0.02869 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top