Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » PyDev 4.3.0 debugging failure(PyDev debugger won't start after upgrading to 4.3.0)
PyDev 4.3.0 debugging failure [message #1706287] Tue, 25 August 2015 13:23 Go to next message
Conrad Mising name is currently offline Conrad Mising nameFriend
Messages: 4
Registered: March 2011
Junior Member
[Using Eclipse Mars (4.5.0) on OS X 10.10.5, with PyDev 4.3.0]

I recently updated by PyDev plugin from 4.2(?) to 4.3.0 and now when I attempt to debug any of my modules, I get the following error in the Console:

pydev debugger: starting (pid: 9237)
Could not connect to 127.0.0.1: 63574
Traceback (most recent call last):
  File "/Applications/Eclipse.app/Contents/Eclipse/plugins/org.python.pydev_4.3.0.201508182223/pysrc/pydevd.py", line 2275, in <module>
    debugger.connect(host, port)
  File "/Applications/Eclipse.app/Contents/Eclipse/plugins/org.python.pydev_4.3.0.201508182223/pysrc/pydevd.py", line 431, in connect
    self.initializeNetwork(s)
  File "/Applications/Eclipse.app/Contents/Eclipse/plugins/org.python.pydev_4.3.0.201508182223/pysrc/pydevd.py", line 418, in initializeNetwork
    self.writer = WriterThread(sock)
  File "/Applications/Eclipse.app/Contents/Eclipse/plugins/org.python.pydev_4.3.0.201508182223/pysrc/pydevd_comm.py", line 379, in __init__
    self.cmdQueue = _queue.Queue()
TypeError: __init__() missing 1 required positional argument: 'params'

Did I miss something on the PyDev update that I'm not doing right? This is only a problem with the Debug configuration - the Run config for my modules work correctly. I also uninstalled and then reinstalled PyDev, but that did not fix the problem. Thanks for any input here.
Re: PyDev 4.3.0 debugging failure [message #1706310 is a reply to message #1706287] Tue, 25 August 2015 14:59 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3798
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 08/25/2015 07:23 AM, Conrad Mising name wrote:
> [Using Eclipse Mars (4.5.0) on OS X 10.10.5, with PyDev 4.3.0]
>
> I recently updated by PyDev plugin from 4.2(?) to 4.3.0 and now when I
> attempt to debug any of my modules, I get the following error in the
> Console:
>
> pydev debugger: starting (pid: 9237)
> Could not connect to 127.0.0.1: 63574
> Traceback (most recent call last):
> File
> "/Applications/Eclipse.app/Contents/Eclipse/plugins/org.python.pydev_4.3.0.201508182223/pysrc/pydevd.py",
> line 2275, in <module>
> debugger.connect(host, port)
> File
> "/Applications/Eclipse.app/Contents/Eclipse/plugins/org.python.pydev_4.3.0.201508182223/pysrc/pydevd.py",
> line 431, in connect
> self.initializeNetwork(s)
> File
> "/Applications/Eclipse.app/Contents/Eclipse/plugins/org.python.pydev_4.3.0.201508182223/pysrc/pydevd.py",
> line 418, in initializeNetwork
> self.writer = WriterThread(sock)
> File
> "/Applications/Eclipse.app/Contents/Eclipse/plugins/org.python.pydev_4.3.0.201508182223/pysrc/pydevd_comm.py",
> line 379, in __init__
> self.cmdQueue = _queue.Queue()
> TypeError: __init__() missing 1 required positional argument: 'params'
>
> Did I miss something on the PyDev update that I'm not doing right? This
> is only a problem with the Debug configuration - the Run config for my
> modules work correctly. I also uninstalled and then reinstalled PyDev,
> but that did not fix the problem. Thanks for any input here.
>

Conrad,

PyDev isn't created by Eclipse, but by a third party using Eclipse.
You'll need to look to the PyDev community for support as your question
isn't about the Eclipse workbench, but about PyDev functionality itself.

Hope this helps.
Re: PyDev 4.3.0 debugging failure [message #1706311 is a reply to message #1706310] Tue, 25 August 2015 15:03 Go to previous messageGo to next message
Conrad Mising name is currently offline Conrad Mising nameFriend
Messages: 4
Registered: March 2011
Junior Member
I am aware PyDev is a third party plugin. I've posted to other forums, but haven't gotten any response yet, so I'm looking for help anywhere I can get it!
Re: PyDev 4.3.0 debugging failure [message #1706313 is a reply to message #1706311] Tue, 25 August 2015 15:14 Go to previous message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3798
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 08/25/2015 09:03 AM, Conrad Mising name wrote:
> I am aware PyDev is a third party plugin. I've posted to other forums,
> but haven't gotten any response yet, so I'm looking for help anywhere I
> can get it!

I see that now.

It strikes me as an issue PyDev's author should attend to, but I don't
know how to gain his attention. As I no longer use PyDev for
development, and therefore haven't updated, I don't have this issue
myself. (I did contribute to its author, but that didn't give me any
route into him personally.)

I assume that this very same code work previously, so this is indeed a
PyDev issue.

From my experience though, there is no answer to expect in this or any
Eclipse forum (for reasons first stated).

Best of luck.
Previous Topic:eclipse SCADA installation
Next Topic:Eclipse will not start with JDK 7 and JDK 8 installed
Goto Forum:
  


Current Time: Sun Oct 25 06:19:33 GMT 2020

Powered by FUDForum. Page generated in 0.02899 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top