Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Requirements Modeling Framework  » Highlighting problems
Highlighting problems [message #1705112] Wed, 12 August 2015 07:58 Go to next message
Tomas Sandkvist is currently offline Tomas SandkvistFriend
Messages: 149
Registered: October 2013
Senior Member
I have two glossary spec objects set up for have different colors according to the formalMind studio manual. However, I cant get the second one to be recognized. Any term using the second spec object turns red when putting it in paranthesis, no auto recognition is possible.

Can't wrap my head around this, everything is set up identically...

Are there any know issues?

Regards,
Tomas Sandkvist
Re: Highlighting problems [message #1705201 is a reply to message #1705112] Wed, 12 August 2015 18:58 Go to previous messageGo to next message
Michael Jastram is currently offline Michael JastramFriend
Messages: 229
Registered: April 2010
Location: Düsseldorf, Germany
Senior Member
Hi Tomas,

This should actually work. Without having checked: i recall there was an issue with respect to the order of the Presentations for the color highlighting. Be sure to save and reopen after reordering. Good luck!

- Michael


Re: Highlighting problems [message #1705258 is a reply to message #1705201] Thu, 13 August 2015 10:58 Go to previous messageGo to next message
Tomas Sandkvist is currently offline Tomas SandkvistFriend
Messages: 149
Registered: October 2013
Senior Member
Hi Michael!

I switched the position of the two presentations, and now the one that was first (and worked) previously no longer works...

So, it appears I can't use more than one color for the moment.

Shall I report a bug?

Regards,
Tomas
Re: Highlighting problems [message #1705356 is a reply to message #1705258] Fri, 14 August 2015 06:41 Go to previous messageGo to next message
Michael Jastram is currently offline Michael JastramFriend
Messages: 229
Registered: April 2010
Location: Düsseldorf, Germany
Senior Member
Hi Tomas,

> So, it appears I can't use more than one color for the moment.

I am fairly sure that was possible, but did not implement this myself (that was done by Lukas Ladenberger). I'll send him a message.

> Shall I report a bug?

Yes, but this is actually an external contribution. You can get this into our bug tracker by sending a message to support@formalmind.com.

Best,

- Michael



Re: Highlighting problems [message #1705619 is a reply to message #1705356] Mon, 17 August 2015 20:50 Go to previous message
Lukas Ladenberger is currently offline Lukas LadenbergerFriend
Messages: 9
Registered: January 2012
Junior Member
Hi Thomas,

as Michael already mentioned, two colors should work without problems. I will check that asap. Anyway, please fill a bug.

Best regards,
Lukas
Previous Topic:How to add an specHierarchy programmatically?
Next Topic:CREATING REQIF SPECHIERARCHY AND SPECIFICATIONS PROGRAMMATICALLY
Goto Forum:
  


Current Time: Wed Sep 26 02:25:18 GMT 2018

Powered by FUDForum. Page generated in 0.01777 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top