Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » EMF Form(when render or preview the Form View , the cross reference between elements in different ecore are not recognized )
EMF Form [message #1703976] Thu, 06 August 2015 10:09 Go to next message
Salwa Alzahmi is currently offline Salwa AlzahmiFriend
Messages: 37
Registered: June 2013
Member
Hi ,

I am new to EMF Form ,

I would like to integrate the form with my EMF Model Editor. However, when I generate the view out of my ecore file , I noticed that :
1) for any EClass (A) that inherits another EClass (B) , The attribute of A do not rendered by emf form.

2) the reference relations between EClasses across multiple ECore models are not recognized as well by the EMF Form.

I get this message once i try to run my RCP Editor :

MESSAGE Not resolved: org.eclipse.emf.ecp.view.spi.model.impl.VFeaturePathDomainModelReferenceImpl@470cfc1f (changeListener: null) on control org.eclipse.emf.ecp.view.spi.model.impl.VControlImpl@457a0993 (name: Control dependentOn, visible: true, enabled: true, readonly: false) (labelAlignment: Left)

Can you please help me with this .




[Updated on: Thu, 06 August 2015 10:48]

Report message to a moderator

Re: EMF Form [message #1704088 is a reply to message #1703976] Fri, 07 August 2015 09:12 Go to previous messageGo to next message
Jonas Helming is currently offline Jonas HelmingFriend
Messages: 699
Registered: July 2009
Senior Member
Hi Salwa,

did you create an explciti view model? Can you add the missing controls
using the action "generate controls" in the view model editor?

Best regards

Jonas

Am 06.08.2015 um 12:09 schrieb Salwa Alzahmi:
> Hi ,
> I am new to EMF Form ,
> I would like to integrate the form with my EMF Model Editor. However,
> when I generate the view out of my ecore file , I noticed that :
> 1) for any EClass (A) that inherits another EClass (B) , The attribute
> of A do not rendered by emf form.
>
> 2) the reference relations between EClasses across multiple ECore models
> are not recognized as well by the EMF Form.
>
> Can you please help me with this .
>
>
>
>
>


--
--

Jonas Helming

Get professional Eclipse developer support:

http://eclipsesource.com/en/services/developer-support/
Re: EMF Form [message #1704886 is a reply to message #1704088] Mon, 10 August 2015 12:30 Go to previous messageGo to next message
Salwa Alzahmi is currently offline Salwa AlzahmiFriend
Messages: 37
Registered: June 2013
Member
Hi
Thankx for your reply.

I actually try to use generate cntrol, but that EAttribute (dependOn) and others of my EClass and showing in the wizard ! ..



Re: EMF Form [message #1705006 is a reply to message #1704886] Tue, 11 August 2015 11:41 Go to previous message
Jonas Helming is currently offline Jonas HelmingFriend
Messages: 699
Registered: July 2009
Senior Member
Hi,

I am not sure, if I understand your last post. Do you mean ".. of my
EClass are not showing ..."?
Can you post a sample model explaining the issue more in detail?

Best regards

Jonas

Am 10.08.2015 um 14:30 schrieb Salwa Alzahmi:
> Hi Thankx for your reply.
>
> I actually try to use generate cntrol, but that EAttribute (dependOn)
> and others of my EClass and showing in the wizard ! ..
>
>
>
>


--
--

Jonas Helming

Get professional Eclipse developer support:

http://eclipsesource.com/en/services/developer-support/
Previous Topic:[Texo] NPE in TexoGeneratorApplication
Next Topic:[EMF Forms] order of getter/setter calls
Goto Forum:
  


Current Time: Wed Jul 08 23:54:38 GMT 2020

Powered by FUDForum. Page generated in 0.02055 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top