Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » [Teneo Auditing] TENEO_CONTAINER_FEATURE_ID maintenance after model changing
[Teneo Auditing] TENEO_CONTAINER_FEATURE_ID maintenance after model changing [message #1703838] Wed, 05 August 2015 09:34 Go to next message
Doris Schuenemann is currently offline Doris SchuenemannFriend
Messages: 2
Registered: August 2015
Junior Member
Hello newsgroup,

We have the problem that in the auditing DB Tables the TENEO_CONTAINER_FEATURE_ID will be saved for containing model classes. This causes the problem that if we add a new feature to the model class, which have this containing class, and the feature will be inserted in the model before the contained feature, than the feature id for all subsequent features in the model will be shift by 1.

This will cause that in old data sets in the auditing DB tables the TENEO_CONTAINER_FEATURE_ID is wrong.

So the question is: Can it be changed like in the forum post http://www.eclipse.org/forums/index.php?t=msg&th=135941/ instead of the feature id to the feature name?

Many thanks in advance,
Doris
Re: [Teneo Auditing] TENEO_CONTAINER_FEATURE_ID maintenance after model changing [message #1703937 is a reply to message #1703838] Wed, 05 August 2015 23:24 Go to previous messageGo to next message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi Doris,
Yes this can be changed, can you enter a feature request/bugzilla for it?

Which teneo version are you using?

I prefer to do this in the latest version of Teneo which is 2.1.0.

gr. Martin

On 05-08-15 20:44, Doris Schuenemann wrote:
> Hello newsgroup,
>
> We have the problem that in the auditing DB Tables the TENEO_CONTAINER_FEATURE_ID will be saved for containing model
> classes. This causes the problem that if we add a new feature to the model class, which have this containing class, and
> the feature will be inserted in the model before the contained feature, than the feature id for all subsequent features
> in the model will be shift by 1.
> This will cause that in old data sets in the auditing DB tables the TENEO_CONTAINER_FEATURE_ID is wrong.
>
> So the question is: Can it be changed like in the forum post http://www.eclipse.org/forums/index.php?t=msg&th=135941/
> instead of the feature id to the feature name?
>
> Many thanks in advance,
> Doris


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Cell: +31 (0)6 288 48 943
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@xxxxxxxx - mtaal@xxxxxxxx
Web: www.springsite.com - www.elver.org
Re: [Teneo Auditing] TENEO_CONTAINER_FEATURE_ID maintenance after model changing [message #1703952 is a reply to message #1703937] Thu, 06 August 2015 06:37 Go to previous messageGo to next message
Doris Schuenemann is currently offline Doris SchuenemannFriend
Messages: 2
Registered: August 2015
Junior Member
Hello Martin,

thank you for your quick response.
We have reported a bugzilla:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=474379

We need the update in version 2.0.1 of teneo, because our application can't be updated to Eclipse 4.

Thanks in advance
Doris
Re: [Teneo Auditing] TENEO_CONTAINER_FEATURE_ID maintenance after model changing [message #1703997 is a reply to message #1703952] Thu, 06 August 2015 13:46 Go to previous message
Martin Taal is currently offline Martin TaalFriend
Messages: 5468
Registered: July 2009
Senior Member
Hi Doris,
Okay I will change it in the 2.0.1 also, this part of the code is the same for both versions, so I can probably create
one diff for both.

gr. Martin

On 06-08-15 08:37, Doris Schuenemann wrote:
> Hello Martin,
>
> thank you for your quick response.
> We have reported a bugzilla:
> https://bugs.eclipse.org/bugs/show_bug.cgi?id=474379
>
> We need the update in version 2.0.1 of teneo, because our application can't be updated to Eclipse 4.
>
> Thanks in advance
> Doris


--

With Regards, Martin Taal

Springsite/Elver.org
Office: Hardwareweg 4, 3821 BV Amersfoort
Postal: Nassaulaan 7, 3941 EC Doorn
The Netherlands
Cell: +31 (0)6 288 48 943
Tel: +31 (0)84 420 2397
Fax: +31 (0)84 225 9307
Mail: mtaal@xxxxxxxx - mtaal@xxxxxxxx
Web: www.springsite.com - www.elver.org
Previous Topic:[Texo] Annotation of EReference with no cascades
Next Topic:[EMF Forms] NPE on display reference model dialog
Goto Forum:
  


Current Time: Thu Dec 03 23:54:32 GMT 2020

Powered by FUDForum. Page generated in 0.01262 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top