Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Gyrex » what's the correct eclipse version shall I use for gyrex 1.3.2?
icon5.gif  what's the correct eclipse version shall I use for gyrex 1.3.2? [message #1701367] Mon, 13 July 2015 04:00 Go to next message
Sean Zhang is currently offline Sean ZhangFriend
Messages: 20
Registered: July 2015
Location: China
Junior Member

Hi,

I am a new one for Gyrex. And I have followed the wiki page to setup the Gyrex develop environment, but I failed. Some bundles cannot be resolved due to the imcomplete dependencies. Such as:

org.eclipse.equinox.registry
Missing Constraint: Import-Package: javax.xml.parsers;version="0.0.0"
Missing Constraint: Import-Package: org.xml.sax;version="0.0.0"
Missing Constraint: Import-Package: org.xml.sax.helpers;version="0.0.0"

org.apache.solr.client.solrj and org.apache.solr.core
Missing Constraint:Import-Package:org.apache.commons.httpclient;version="3.1.0"
Missing Constraint:Import-Package:org.apache.commons.httpclient.methods;version="3.1.0"
Missing Constraint:Import-Package:org.apache.commons.httpclient.methods.multipart;version="3.1.0"

The eclipse platform I used is Mars Release (4.5.0).

Can anyone guide me to setup the target platform?


Study every day, and love every day!
Re: what's the correct eclipse version shall I use for gyrex 1.3.2? [message #1701483 is a reply to message #1701367] Mon, 13 July 2015 15:34 Go to previous messageGo to next message
Andreas Mihm is currently offline Andreas MihmFriend
Messages: 3
Registered: May 2012
Junior Member
Hi Sean,
sorry, the turoial is not correctly working,
I'll attach a target platform file , which should work. It's quite independend from the eclipse version you use,

Andreas
Re: what's the correct eclipse version shall I use for gyrex 1.3.2? [message #1701557 is a reply to message #1701483] Tue, 14 July 2015 07:34 Go to previous messageGo to next message
Sean Zhang is currently offline Sean ZhangFriend
Messages: 20
Registered: July 2015
Location: China
Junior Member

Hi, Andreas

Thanks for your help. I'll try and update the result later.


Study every day, and love every day!
Re: what's the correct eclipse version shall I use for gyrex 1.3.2? [message #1701601 is a reply to message #1701557] Tue, 14 July 2015 11:26 Go to previous messageGo to next message
Gunnar Wagenknecht is currently offline Gunnar WagenknechtFriend
Messages: 486
Registered: July 2009
Location: San Francisco ✈ Germany
Senior Member

Hi,

On 2015-07-14 07:34:01 +0000, Sean Zhang said:
> Thanks for your help. I'll try and update the result later.

As part of Mars we released version 1.5. It's based on (includes)
Equinox OSGi from Eclipse Mars.

The update site is at:
http://download.eclipse.org/gyrex/1.5/

There is an item that you should be consuming in your target definition
files which also includes all dependencies.

-Gunnar

--
Gunnar Wagenknecht
gunnar@xxxxxxxx
Re: what's the correct eclipse version shall I use for gyrex 1.3.2? [message #1701697 is a reply to message #1701483] Wed, 15 July 2015 06:21 Go to previous messageGo to next message
Sean Zhang is currently offline Sean ZhangFriend
Messages: 20
Registered: July 2015
Location: China
Junior Member

Still cannot work according to your target file. And I got following error while starting the target:

!SESSION 2015-07-15 14:17:26.273 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.7.0_79
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=zh_CN
Command-line arguments: -dev file:C:/Users/sean-desktop/workspace/.metadata/.plugins/org.eclipse.pde.core/OSGi Framework/dev.properties -os win32 -ws win32 -arch x86_64 -consoleLog -console

!ENTRY org.apache.solr.client.solrj 4 0 2015-07-15 14:17:27.124
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.apache.solr.client.solrj [61]
Unresolved requirement: Import-Package: org.apache.commons.httpclient; version="3.1.0"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.apache.solr.core 4 0 2015-07-15 14:17:27.126
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.apache.solr.core [62]
Unresolved requirement: Import-Package: org.apache.commons.csv; version="[1.0.0,2.0.0)"; resolution:="optional"
Unresolved requirement: Import-Package: org.apache.commons.httpclient; version="[3.1.0,4.0.0)"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
osgi> 14:17:27,661 |-INFO in ch.qos.logback.classic.LoggerContext[default] - Could NOT find resource [logback.groovy]
14:17:27,661 |-INFO in ch.qos.logback.classic.LoggerContext[default] - Could NOT find resource [logback-test.xml]
14:17:27,661 |-INFO in ch.qos.logback.classic.LoggerContext[default] - Could NOT find resource [logback.xml]
14:17:27,662 |-INFO in ch.qos.logback.classic.LoggerContext[default] - Setting up default configuration.
14:17:27,701 |-INFO in class org.eclipse.gyrex.boot.internal.logback.LogbackConfigurator - Setting up Gyrex log configuration.
14:17:27,701 |-INFO in class org.eclipse.gyrex.boot.internal.logback.LogbackConfigurator - Using built-in default configuration. Enhancements and suggestions welcome.
14:17:27,702 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@5d643630 - Propagating DEBUG level on Logger[ROOT] onto the JUL framework
14:17:27,707 |-INFO in ch.qos.logback.core.rolling.RollingFileAppender[error-log] - Active log file name: D:\Tools\eclipse\workspace\logs\error.log
14:17:27,707 |-INFO in ch.qos.logback.core.rolling.RollingFileAppender[error-log] - File property is set to [D:\Tools\eclipse\workspace\logs\error.log]
14:17:27,709 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@5d643630 - Propagating WARN level on Logger[org.apache.commons] onto the JUL framework
14:17:27,709 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@5d643630 - Propagating WARN level on Logger[httpclient.wire] onto the JUL framework
14:17:27,709 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@5d643630 - Propagating WARN level on Logger[org.apache.http] onto the JUL framework
14:17:27,709 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@5d643630 - Propagating WARN level on Logger[org.apache.zookeeper] onto the JUL framework
14:17:27,709 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@5d643630 - Propagating WARN level on Logger[org.apache.solr] onto the JUL framework
14:17:27,709 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@5d643630 - Propagating WARN level on Logger[org.apache.sshd] onto the JUL framework
14:17:27,709 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@5d643630 - Propagating WARN level on Logger[org.apache.mina] onto the JUL framework
14:17:27,709 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@5d643630 - Propagating WARN level on Logger[org.mortbay.log] onto the JUL framework
14:17:27,709 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@5d643630 - Propagating INFO level on Logger[org.eclipse.jetty] onto the JUL framework
14:17:27,709 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@5d643630 - Propagating INFO level on Logger[org.quartz] onto the JUL framework
14:17:27,709 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@5d643630 - Propagating INFO level on Logger[sun] onto the JUL framework
14:17:27,709 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@5d643630 - Propagating INFO level on Logger[com.google.inject] onto the JUL framework
14:17:27,710 |-INFO in org.eclipse.gyrex.boot.internal.logback.LogbackLevelDebugOptionsBridge@63e66ad5 - Initializing log level overrides.
14:17:27.713 [Start Level: Equinox Container: 60db152a-b92a-0015-1da9-e612a23bc8e9] DEBUG o.e.g.server.settings.SystemSetting - No value set for gyrex_portOffset/gyrex.portOffset, using default value null
14:17:27.776 [Worker-0] INFO org.eclipse.jetty.util.log - Logging initialized @1608ms
14:17:27.783 [Worker-0] DEBUG o.e.g.server.settings.SystemSetting - No value set for gyrex_admin_secure/gyrex.admin.secure, using default value false
14:17:27.796 [Worker-0] DEBUG o.e.g.server.settings.SystemSetting - No value set for gyrex_admin_http_port/gyrex.admin.http.port, using default value 3110
14:17:28.707 [Component Resolve Thread] INFO o.e.g.cloud.internal.CloudActivator - Node id: sean-desktop-pc_53ca934f
14:17:28.761 [Worker-0] DEBUG o.e.g.server.settings.SystemSetting - No value set for gyrex_admin_auth/gyrex.admin.auth, using default value null
14:17:28.761 [Worker-0] DEBUG o.e.g.server.settings.SystemSetting - No value set for gyrex_admin_secure/gyrex.admin.secure, using default value false
14:17:28.823 [Worker-0] INFO org.eclipse.jetty.server.Server - jetty-9.2.9.v20150224
14:17:28.861 [Worker-0] INFO o.e.j.server.handler.ContextHandler - Started o.e.j.s.ServletContextHandler@dccc9b5{/,file:/D:/Tools/eclipse/workspace/.metadata/.plugins/org.eclipse.gyrex.admin.ui/context/,AVAILABLE}
14:17:28.885 [Component Resolve Thread] INFO o.e.g.e.w.i.WebsocketEventTransport - Activating WebsocketEventTransport.
14:17:28.885 [Component Resolve Thread] DEBUG o.e.g.server.settings.SystemSetting - No value set for gyrex_event_websocket_port/gyrex.event.websocket.port, using default value 3111
14:17:28.896 [Worker-0] INFO o.e.jetty.server.ServerConnector - Started ServerConnector@5d938a38{HTTP/1.1}{0.0.0.0:3110}
14:17:28.896 [Worker-0] INFO org.eclipse.jetty.server.Server - Started @2728ms
14:17:29.663 [Component Resolve Thread] INFO org.eclipse.jetty.server.Server - jetty-9.2.9.v20150224
14:17:29.669 [Component Resolve Thread] INFO o.e.j.server.handler.ContextHandler - Started o.e.j.s.h.ContextHandler@16e3f7a2{/eventbus,null,AVAILABLE}
14:17:29.676 [Component Resolve Thread] INFO o.e.jetty.server.ServerConnector - Started ServerConnector@5725a222{HTTP/1.1}{0.0.0.0:3111}
14:17:29.676 [Component Resolve Thread] INFO org.eclipse.jetty.server.Server - Started @3508ms
14:17:29.679 [Worker-1] DEBUG o.e.g.e.w.i.WebsocketEventTransport - Connecting online nodes for the event transport.
14:17:29.693 [Worker-1] WARN o.e.g.e.w.i.WebsocketEventTransport - An error occured while connecting online nodes for the event transport. Operation will be retried.

!ENTRY org.eclipse.gyrex.http.jersey 4 0 2015-07-15 14:17:29.742
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.gyrex.http.jersey [159]
Unresolved requirement: Import-Package: org.eclipse.persistence.jaxb.rs; version="[2.4.0,3.0.0)"; resolution:="optional"
Unresolved requirement: Import-Package: org.objectweb.asm; version="[3.1.0,4.0.0)"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
14:17:29.742 [Start Level: Equinox Container: 60db152a-b92a-0015-1da9-e612a23bc8e9] INFO o.e.g.h.l.internal.HttpLogActivator - Adding Wildfire Appender...

!ENTRY org.eclipse.gyrex.persistence.solr 4 0 2015-07-15 14:17:30.101
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.gyrex.persistence.solr [174]
Unresolved requirement: Import-Package: org.apache.solr.client.solrj; version="1.4.0"
-> Export-Package: org.apache.solr.client.solrj; bundle-version="3.5.0.v20150506-0844"; bundle-symbolic-name="org.apache.solr.client.solrj"; version="3.5.0"; uses:="org.apache.solr.client.solrj.response, org.apache.solr.client.solrj.beans, org.apache.solr.common.params, org.apache.solr.common, org.apache.solr.common.util"
org.apache.solr.client.solrj [61]
Unresolved requirement: Import-Package: org.apache.commons.httpclient; version="3.1.0"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.gyrex.search 4 0 2015-07-15 14:17:30.112
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.gyrex.search [177]
Unresolved requirement: Import-Package: org.apache.solr.client.solrj; version="1.4.0"
-> Export-Package: org.apache.solr.client.solrj; bundle-version="3.5.0.v20150506-0844"; bundle-symbolic-name="org.apache.solr.client.solrj"; version="3.5.0"; uses:="org.apache.solr.client.solrj.response, org.apache.solr.client.solrj.beans, org.apache.solr.common.params, org.apache.solr.common, org.apache.solr.common.util"
org.apache.solr.client.solrj [61]
Unresolved requirement: Import-Package: org.apache.commons.httpclient; version="3.1.0"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.jetty.annotations 4 0 2015-07-15 14:17:30.117
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jetty.annotations [180]
Unresolved requirement: Import-Package: org.objectweb.asm; version="4.0.0"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)
14:17:30.125 [Start Level: Equinox Container: 60db152a-b92a-0015-1da9-e612a23bc8e9] WARN o.e.j.o.b.i.s.DefaultJettyAtJettyHomeHelper - No default jetty created.

!ENTRY org.eclipse.jetty.websocket.javax.websocket.server 4 0 2015-07-15 14:17:30.253
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: Could not resolve module: org.eclipse.jetty.websocket.javax.websocket.server [235]
Unresolved requirement: Require-Capability: osgi.extender; filter:="(osgi.extender=osgi.serviceloader.registrar)"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

Andreas Mihm wrote on Mon, 13 July 2015 15:34
Hi Sean,
sorry, the turoial is not correctly working,
I'll attach a target platform file , which should work. It's quite independend from the eclipse version you use,

Andreas



Study every day, and love every day!
Re: what's the correct eclipse version shall I use for gyrex 1.3.2? [message #1701706 is a reply to message #1701601] Wed, 15 July 2015 07:46 Go to previous messageGo to next message
Sean Zhang is currently offline Sean ZhangFriend
Messages: 20
Registered: July 2015
Location: China
Junior Member

Hi Gunna,

I think there might be an dependency config error in the 1.5 target definition, and I got following error after I starting a simple plugin base on the targe definition:

org.osgi.framework.BundleException: Could not resolve module: org.eclipse.gyrex.server.tests [156]
Unresolved requirement: Import-Package: org.eclipse.gyrex.boot.tests
-> Export-Package: org.eclipse.gyrex.boot.tests; bundle-version="1.3.0.v20140923-0852"; bundle-symbolic-name="org.eclipse.gyrex.boot.tests"; version="0.0.0"; x-friends:="org.eclipse.gyrex.server.tests"
org.eclipse.gyrex.boot.tests [118]
Unresolved requirement: Fragment-Host: org.eclipse.gyrex.boot; bundle-version="1.3.0.qualifier"

at org.eclipse.osgi.container.Module.start(Module.java:434)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1582)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.incStartLevel(ModuleContainer.java:1562)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.doContainerStartLevel(ModuleContainer.java:1533)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1476)
at org.eclipse.osgi.container.ModuleContainer$ContainerStartLevel.dispatchEvent(ModuleContainer.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

And My target definitiion content is as below:

<?xml version="1.0" encoding="UTF-8" standalone="no"?>
<?pde version="3.8"?><target name="com.octech.mamalianmeng" sequenceNumber="14">
<locations>
<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
<unit id="org.eclipse.gyrex.features.master.feature.group" version="1.5.0.v20150605-1321"/>
<repository location="http://download.eclipse.org/gyrex/1.5/"/>
</location>
<location includeAllPlatforms="true" includeConfigurePhase="false" includeMode="slicer" includeSource="true" type="InstallableUnit">
<unit id="org.hamcrest" version="1.1.0.v20090501071000"/>
<unit id="org.hamcrest.core" version="1.3.0.v201303031735"/>
<unit id="org.hamcrest.generator.source" version="1.3.0.v201305210900"/>
<unit id="org.hamcrest.text.source" version="1.1.0.v20090501071000"/>
<unit id="org.hamcrest.library.source" version="1.3.0.v201505072020"/>
<unit id="org.apache.commons.httpclient.source" version="3.1.0.v201012070820"/>
<unit id="javax.xml" version="1.3.4.v201005080400"/>
<unit id="org.mockito" version="1.9.5.v201311280930"/>
<unit id="javax.transaction" version="1.1.1.v201105210645"/>
<unit id="org.hamcrest.generator" version="1.3.0.v201305210900"/>
<unit id="org.apache.commons.httpclient" version="3.1.0.v201012070820"/>
<unit id="org.objenesis.source" version="1.0.0.v201505121915"/>
<unit id="org.hamcrest.library" version="1.3.0.v201505072020"/>
<unit id="org.junit" version="4.12.0.v201504281640"/>
<unit id="org.hamcrest.integration.source" version="1.3.0.v201305210900"/>
<unit id="org.hamcrest.integration" version="1.3.0.v201305210900"/>
<unit id="org.junit.source" version="4.12.0.v201504281640"/>
<unit id="org.hamcrest.text" version="1.1.0.v20090501071000"/>
<unit id="javax.transaction.source" version="1.1.1.v201105210645"/>
<unit id="org.objenesis" version="1.0.0.v201505121915"/>
<unit id="org.hamcrest.core.source" version="1.3.0.v201303031735"/>
<repository location="http://download.eclipse.org/tools/orbit/downloads/drops/R20150519210750/repository/"/>
</location>
</locations>
</target>


Gunnar Wagenknecht wrote on Tue, 14 July 2015 11:26
Hi,

On 2015-07-14 07:34:01 +0000, Sean Zhang said:
> Thanks for your help. I'll try and update the result later.

As part of Mars we released version 1.5. It's based on (includes)
Equinox OSGi from Eclipse Mars.

The update site is at:
http://download.eclipse.org/gyrex/1.5/

There is an item that you should be consuming in your target definition
files which also includes all dependencies.

-Gunnar

--
Gunnar Wagenknecht
gunnar@xxxxxxxx



Study every day, and love every day!
Re: what's the correct eclipse version shall I use for gyrex 1.3.2? [message #1701711 is a reply to message #1701706] Wed, 15 July 2015 08:15 Go to previous messageGo to next message
Gunnar Wagenknecht is currently offline Gunnar WagenknechtFriend
Messages: 486
Registered: July 2009
Location: San Francisco ✈ Germany
Senior Member

Hi,

On 2015-07-15 07:46:19 +0000, Sean Zhang said:
> I think there might be an dependency config error in the 1.5 target
> definition, and I got following error after I starting a simple plugin
> base on the targe definition:
>
> org.osgi.framework.BundleException: Could not resolve module:
> org.eclipse.gyrex.server.tests [156]
> Unresolved requirement: Import-Package: org.eclipse.gyrex.boot.tests
> -> Export-Package: org.eclipse.gyrex.boot.tests;
> bundle-version="1.3.0.v20140923-0852";
> bundle-symbolic-name="org.eclipse.gyrex.boot.tests"; version="0.0.0";
> x-friends:="org.eclipse.gyrex.server.tests"
> org.eclipse.gyrex.boot.tests [118]
> Unresolved requirement: Fragment-Host: org.eclipse.gyrex.boot;
> bundle-version="1.3.0.qualifier"

The target definition includes really everthing, i.e. also the bundles
we use for testing. At runtime, those bundle should not be deployed.
They will cause errors like this. In theory, this error can be ignored.
But in reality it's confusing.

There are two possible solutions:
(1) exclude the bundles in the launch configuration
(2) exclude the bundles in the target configuration


Can you try using the following target definition:
https://raw.githubusercontent.com/runolarity/p2-server/master/releng/targetplatform/p2server-target-platform.target


I've updated that one to 1.5. There are a few differences.

- It uses "org.eclipse.gyrex.features.sdk.feature.group" instead of the
master.feature.group, which excludes the *.tests bundles
- It uses includeMode="slicer" instead of "planner", which allows to
build/export products for all platforms (not just the current one)


-Gunnar

--
Gunnar Wagenknecht
gunnar@xxxxxxxx
Re: what's the correct eclipse version shall I use for gyrex 1.3.2? [message #1701754 is a reply to message #1701711] Wed, 15 July 2015 12:06 Go to previous messageGo to next message
Sean Zhang is currently offline Sean ZhangFriend
Messages: 20
Registered: July 2015
Location: China
Junior Member

Hi Gunnar,

Many thanks for your help.
Now I can started the dev environment now. While, I got an error when I try to access the cluster management page in the web console (http://localhost:3110).

The screenshot for the error is attached. And the detail log while starting the environment is as below:

osgi> 19:58:24,679 |-INFO in ch.qos.logback.classic.LoggerContext[default] - Could NOT find resource [logback.groovy]
19:58:24,679 |-INFO in ch.qos.logback.classic.LoggerContext[default] - Could NOT find resource [logback-test.xml]
19:58:24,679 |-INFO in ch.qos.logback.classic.LoggerContext[default] - Could NOT find resource [logback.xml]
19:58:24,680 |-INFO in ch.qos.logback.classic.LoggerContext[default] - Setting up default configuration.
19:58:24,719 |-INFO in class org.eclipse.gyrex.boot.internal.logback.LogbackConfigurator - Setting up Gyrex log configuration.
19:58:24,720 |-INFO in class org.eclipse.gyrex.boot.internal.logback.LogbackConfigurator - Using built-in default configuration. Enhancements and suggestions welcome.
19:58:24,721 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@516f5228 - Propagating DEBUG level on Logger[ROOT] onto the JUL framework
19:58:24,725 |-INFO in ch.qos.logback.core.rolling.RollingFileAppender[error-log] - Active log file name: D:\Tools\eclipse\workspace\logs\error.log
19:58:24,725 |-INFO in ch.qos.logback.core.rolling.RollingFileAppender[error-log] - File property is set to [D:\Tools\eclipse\workspace\logs\error.log]
19:58:24,726 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@516f5228 - Propagating WARN level on Logger[org.apache.commons] onto the JUL framework
19:58:24,726 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@516f5228 - Propagating WARN level on Logger[httpclient.wire] onto the JUL framework
19:58:24,726 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@516f5228 - Propagating WARN level on Logger[org.apache.http] onto the JUL framework
19:58:24,726 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@516f5228 - Propagating WARN level on Logger[org.apache.zookeeper] onto the JUL framework
19:58:24,726 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@516f5228 - Propagating WARN level on Logger[org.apache.solr] onto the JUL framework
19:58:24,726 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@516f5228 - Propagating WARN level on Logger[org.apache.sshd] onto the JUL framework
19:58:24,726 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@516f5228 - Propagating WARN level on Logger[org.apache.mina] onto the JUL framework
19:58:24,726 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@516f5228 - Propagating WARN level on Logger[org.mortbay.log] onto the JUL framework
19:58:24,726 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@516f5228 - Propagating INFO level on Logger[org.eclipse.jetty] onto the JUL framework
19:58:24,726 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@516f5228 - Propagating INFO level on Logger[org.quartz] onto the JUL framework
19:58:24,726 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@516f5228 - Propagating INFO level on Logger[sun] onto the JUL framework
19:58:24,726 |-INFO in ch.qos.logback.classic.jul.LevelChangePropagator@516f5228 - Propagating INFO level on Logger[com.google.inject] onto the JUL framework
19:58:24,727 |-INFO in org.eclipse.gyrex.boot.internal.logback.LogbackLevelDebugOptionsBridge@4c6bcaef - Initializing log level overrides.
19:58:24.729 [Start Level: Equinox Container: e0ee93ca-e82a-0015-12a1-8f2f63b87f29] DEBUG o.e.g.server.settings.SystemSetting - No value set for gyrex_portOffset/gyrex.portOffset, using default value null
19:58:24.852 [Worker-0] INFO  org.eclipse.jetty.util.log - Logging initialized @3177ms
19:58:24.860 [Worker-0] DEBUG o.e.g.server.settings.SystemSetting - No value set for gyrex_admin_secure/gyrex.admin.secure, using default value false
19:58:24.879 [Worker-0] DEBUG o.e.g.server.settings.SystemSetting - No value set for gyrex_admin_http_port/gyrex.admin.http.port, using default value 3110
19:58:25.807 [Worker-0] DEBUG o.e.g.server.settings.SystemSetting - No value set for gyrex_admin_auth/gyrex.admin.auth, using default value null
19:58:25.807 [Worker-0] DEBUG o.e.g.server.settings.SystemSetting - No value set for gyrex_admin_secure/gyrex.admin.secure, using default value false
19:58:25.809 [Worker-0] INFO  org.eclipse.jetty.server.Server - jetty-9.2.9.v20150224
19:58:25.836 [Worker-0] INFO  o.e.j.server.handler.ContextHandler - Started o.e.j.s.ServletContextHandler@7c3aa90a{/,file:/D:/Tools/eclipse/workspace/.metadata/.plugins/org.eclipse.gyrex.admin.ui/context/,AVAILABLE}
19:58:25.854 [Worker-0] INFO  o.e.jetty.server.ServerConnector - Started ServerConnector@2e89630{HTTP/1.1}{0.0.0.0:3110}
19:58:25.854 [Worker-0] INFO  org.eclipse.jetty.server.Server - Started @4179ms
19:58:25.926 [Component Resolve Thread] INFO  o.e.g.cloud.internal.CloudActivator - Node id: sean-desktop-pc_53ca934f
19:58:25.992 [Component Resolve Thread] INFO  o.e.g.e.w.i.WebsocketEventTransport - Activating WebsocketEventTransport.
19:58:25.992 [Component Resolve Thread] DEBUG o.e.g.server.settings.SystemSetting - No value set for gyrex_event_websocket_port/gyrex.event.websocket.port, using default value 3111
19:58:26.663 [Component Resolve Thread] INFO  org.eclipse.jetty.server.Server - jetty-9.2.9.v20150224
19:58:26.666 [Component Resolve Thread] INFO  o.e.j.server.handler.ContextHandler - Started o.e.j.s.h.ContextHandler@55989874{/eventbus,null,AVAILABLE}
19:58:26.669 [Component Resolve Thread] INFO  o.e.jetty.server.ServerConnector - Started ServerConnector@5060706b{HTTP/1.1}{0.0.0.0:3111}
19:58:26.670 [Component Resolve Thread] INFO  org.eclipse.jetty.server.Server - Started @4995ms
19:58:26.673 [Worker-1] DEBUG o.e.g.e.w.i.WebsocketEventTransport - Connecting online nodes for the event transport.
19:58:26.681 [Worker-1] WARN  o.e.g.e.w.i.WebsocketEventTransport - An error occured while connecting online nodes for the event transport. Operation will be retried.
19:58:26.702 [Start Level: Equinox Container: e0ee93ca-e82a-0015-12a1-8f2f63b87f29] INFO  o.e.g.h.l.internal.HttpLogActivator - Adding Wildfire Appender...
19:58:52.747 [qtp1611116091-61] ERROR org.eclipse.gyrex.rap.JFaceLog - Unable to open page 'Cluster (id cluster)'. Please check the server logs.
java.lang.RuntimeException: Error reading list of nodes. GateDownException: ZooKeeper Gate is DOWN. (null)
	at org.eclipse.gyrex.cloud.internal.admin.CloudManagerImpl.getOnlineNodes(CloudManagerImpl.java:164) ~[na:na]
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method) ~[na:1.7.0_79]
	at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source) ~[na:1.7.0_79]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source) ~[na:1.7.0_79]
	at java.lang.reflect.Method.invoke(Unknown Source) ~[na:1.7.0_79]
	at org.eclipse.gyrex.common.internal.services.ServiceProxy.invoke(ServiceProxy.java:303) ~[org.eclipse.gyrex.common_1.3.0.v20140923-0741.jar:na]
	at com.sun.proxy.$Proxy2.getOnlineNodes(Unknown Source) ~[na:na]
	at org.eclipse.gyrex.admin.ui.cloud.internal.NodeBrowserContentProvider.getElements(NodeBrowserContentProvider.java:108) ~[na:na]
	at org.eclipse.jface.viewers.StructuredViewer.getRawChildren(StructuredViewer.java:992) ~[org.eclipse.rap.jface_3.0.0.20150520-1729.jar:na]
	at org.eclipse.jface.viewers.ColumnViewer.getRawChildren(ColumnViewer.java:699) ~[org.eclipse.rap.jface_3.0.0.20150520-1729.jar:na]
	at org.eclipse.jface.viewers.AbstractTreeViewer.getRawChildren(AbstractTreeViewer.java:1333) ~[org.eclipse.rap.jface_3.0.0.20150520-1729.jar:na]
	at org.eclipse.jface.viewers.TreeViewer.getRawChildren(TreeViewer.java:391) ~[org.eclipse.rap.jface_3.0.0.20150520-1729.jar:na]
	at org.eclipse.jface.viewers.StructuredViewer.getFilteredChildren(StructuredViewer.java:900) ~[org.eclipse.rap.jface_3.0.0.20150520-1729.jar:na]
	at org.eclipse.jface.viewers.AbstractTreeViewer.getSortedChildren(AbstractTreeViewer.java:602) ~[org.eclipse.rap.jface_3.0.0.20150520-1729.jar:na]
	at org.eclipse.jface.viewers.AbstractTreeViewer$1.run(AbstractTreeViewer.java:802) ~[org.eclipse.rap.jface_3.0.0.20150520-1729.jar:na]
	at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:66) ~[org.eclipse.rap.rwt_3.0.0.20150601-1556.jar:na]
	at org.eclipse.jface.viewers.AbstractTreeViewer.createChildren(AbstractTreeViewer.java:779) ~[org.eclipse.rap.jface_3.0.0.20150520-1729.jar:na]
	at org.eclipse.jface.viewers.TreeViewer.createChildren(TreeViewer.java:644) ~[org.eclipse.rap.jface_3.0.0.20150520-1729.jar:na]
	at org.eclipse.jface.viewers.AbstractTreeViewer.createChildren(AbstractTreeViewer.java:750) ~[org.eclipse.rap.jface_3.0.0.20150520-1729.jar:na]
	at org.eclipse.jface.viewers.AbstractTreeViewer.internalInitializeTree(AbstractTreeViewer.java:1495) ~[org.eclipse.rap.jface_3.0.0.20150520-1729.jar:na]
	at org.eclipse.jface.viewers.TreeViewer.internalInitializeTree(TreeViewer.java:833) ~[org.eclipse.rap.jface_3.0.0.20150520-1729.jar:na]
	at org.eclipse.jface.viewers.AbstractTreeViewer$5.run(AbstractTreeViewer.java:1479) ~[org.eclipse.rap.jface_3.0.0.20150520-1729.jar:na]
	at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1427) ~[org.eclipse.rap.jface_3.0.0.20150520-1729.jar:na]
	at org.eclipse.jface.viewers.TreeViewer.preservingSelection(TreeViewer.java:403) ~[org.eclipse.rap.jface_3.0.0.20150520-1729.jar:na]
	at org.eclipse.jface.viewers.StructuredViewer.preservingSelection(StructuredViewer.java:1388) ~[org.eclipse.rap.jface_3.0.0.20150520-1729.jar:na]
	at org.eclipse.jface.viewers.AbstractTreeViewer.inputChanged(AbstractTreeViewer.java:1472) ~[org.eclipse.rap.jface_3.0.0.20150520-1729.jar:na]
	at org.eclipse.gyrex.admin.ui.internal.widgets.FilteredTree$NotifyingTreeViewer.inputChanged(FilteredTree.java:105) ~[na:na]
	at org.eclipse.jface.viewers.ContentViewer.setInput(ContentViewer.java:280) ~[org.eclipse.rap.jface_3.0.0.20150520-1729.jar:na]
	at org.eclipse.jface.viewers.StructuredViewer.setInput(StructuredViewer.java:1674) ~[org.eclipse.rap.jface_3.0.0.20150520-1729.jar:na]
	at org.eclipse.gyrex.admin.ui.internal.widgets.AdminPageWithTree.activate(AdminPageWithTree.java:141) ~[na:na]
	at org.eclipse.gyrex.admin.ui.cloud.internal.ZooKeeperBasedAdminPage.activate(ZooKeeperBasedAdminPage.java:69) ~[na:na]
	at org.eclipse.gyrex.rap.application.RapApplicationEntryPoint.activate(RapApplicationEntryPoint.java:170) [org.eclipse.gyrex.rap_1.0.0.v20150604-1242.jar:na]
	at org.eclipse.gyrex.rap.application.RapApplicationEntryPoint.open(RapApplicationEntryPoint.java:528) [org.eclipse.gyrex.rap_1.0.0.v20150604-1242.jar:na]
	at org.eclipse.gyrex.rap.application.RapApplicationEntryPoint.access$0(RapApplicationEntryPoint.java:513) [org.eclipse.gyrex.rap_1.0.0.v20150604-1242.jar:na]
	at org.eclipse.gyrex.rap.application.RapApplicationEntryPoint$4.openPage(RapApplicationEntryPoint.java:401) [org.eclipse.gyrex.rap_1.0.0.v20150604-1242.jar:na]
	at org.eclipse.gyrex.rap.application.NavigationBar$1.openPage(NavigationBar.java:61) [org.eclipse.gyrex.rap_1.0.0.v20150604-1242.jar:na]
	at org.eclipse.gyrex.rap.application.DropDownNavigation$1.widgetSelected(DropDownNavigation.java:67) [org.eclipse.gyrex.rap_1.0.0.v20150604-1242.jar:na]
	at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:262) [org.eclipse.rap.rwt_3.0.0.20150601-1556.jar:na]
	at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:86) [org.eclipse.rap.rwt_3.0.0.20150601-1556.jar:na]
	at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:708) [org.eclipse.rap.rwt_3.0.0.20150601-1556.jar:na]
	at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:610) [org.eclipse.rap.rwt_3.0.0.20150601-1556.jar:na]
	at org.eclipse.swt.widgets.Display.executeNextEvent(Display.java:1216) [org.eclipse.rap.rwt_3.0.0.20150601-1556.jar:na]
	at org.eclipse.swt.widgets.Display.runPendingMessages(Display.java:1197) [org.eclipse.rap.rwt_3.0.0.20150601-1556.jar:na]
	at org.eclipse.swt.widgets.Display.safeReadAndDispatch(Display.java:1180) [org.eclipse.rap.rwt_3.0.0.20150601-1556.jar:na]
	at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:1172) [org.eclipse.rap.rwt_3.0.0.20150601-1556.jar:na]
	at org.eclipse.rap.rwt.internal.lifecycle.ProcessAction.execute(ProcessAction.java:27) [org.eclipse.rap.rwt_3.0.0.20150601-1556.jar:na]
	at org.eclipse.rap.rwt.internal.lifecycle.PhaseExecutor.execute(PhaseExecutor.java:38) [org.eclipse.rap.rwt_3.0.0.20150601-1556.jar:na]
	at org.eclipse.rap.rwt.internal.lifecycle.SimpleLifeCycle.execute(SimpleLifeCycle.java:46) [org.eclipse.rap.rwt_3.0.0.20150601-1556.jar:na]
	at org.eclipse.rap.rwt.internal.service.RWTMessageHandler.executeLifeCycle(RWTMessageHandler.java:56) [org.eclipse.rap.rwt_3.0.0.20150601-1556.jar:na]
	at org.eclipse.rap.rwt.internal.service.RWTMessageHandler.handleMessage(RWTMessageHandler.java:40) [org.eclipse.rap.rwt_3.0.0.20150601-1556.jar:na]
	at org.eclipse.rap.rwt.internal.remote.MessageChainElement.handleMessage(MessageChainElement.java:28) [org.eclipse.rap.rwt_3.0.0.20150601-1556.jar:na]
	at org.eclipse.rap.rwt.internal.service.LifeCycleServiceHandler.processMessage(LifeCycleServiceHandler.java:140) [org.eclipse.rap.rwt_3.0.0.20150601-1556.jar:na]
	at org.eclipse.rap.rwt.internal.service.LifeCycleServiceHandler.processUIRequest(LifeCycleServiceHandler.java:111) [org.eclipse.rap.rwt_3.0.0.20150601-1556.jar:na]
	at org.eclipse.rap.rwt.internal.service.LifeCycleServiceHandler.synchronizedService(LifeCycleServiceHandler.java:81) [org.eclipse.rap.rwt_3.0.0.20150601-1556.jar:na]
	at org.eclipse.rap.rwt.internal.service.LifeCycleServiceHandler.service(LifeCycleServiceHandler.java:72) [org.eclipse.rap.rwt_3.0.0.20150601-1556.jar:na]
	at org.eclipse.rap.rwt.engine.RWTServlet.handleValidRequest(RWTServlet.java:135) [org.eclipse.rap.rwt_3.0.0.20150601-1556.jar:na]
	at org.eclipse.rap.rwt.engine.RWTServlet.handleRequest(RWTServlet.java:117) [org.eclipse.rap.rwt_3.0.0.20150601-1556.jar:na]
	at org.eclipse.rap.rwt.engine.RWTServlet.doPost(RWTServlet.java:107) [org.eclipse.rap.rwt_3.0.0.20150601-1556.jar:na]
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:707) [javax.servlet_3.1.0.v201410161800.jar:3.1.0]
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:790) [javax.servlet_3.1.0.v201410161800.jar:3.1.0]
	at org.eclipse.jetty.servlet.ServletHolder.handle(ServletHolder.java:808) [org.eclipse.jetty.servlet_9.2.9.v20150224.jar:9.2.9.v20150224]
	at org.eclipse.jetty.servlet.ServletHandler.doHandle(ServletHandler.java:587) [org.eclipse.jetty.servlet_9.2.9.v20150224.jar:9.2.9.v20150224]
	at org.eclipse.jetty.server.session.SessionHandler.doHandle(SessionHandler.java:221) [org.eclipse.jetty.server_9.2.9.v20150224.jar:9.2.9.v20150224]
	at org.eclipse.jetty.server.handler.ContextHandler.doHandle(ContextHandler.java:1127) [org.eclipse.jetty.server_9.2.9.v20150224.jar:9.2.9.v20150224]
	at org.eclipse.jetty.servlet.ServletHandler.doScope(ServletHandler.java:515) [org.eclipse.jetty.servlet_9.2.9.v20150224.jar:9.2.9.v20150224]
	at org.eclipse.jetty.server.session.SessionHandler.doScope(SessionHandler.java:185) [org.eclipse.jetty.server_9.2.9.v20150224.jar:9.2.9.v20150224]
	at org.eclipse.jetty.server.handler.ContextHandler.doScope(ContextHandler.java:1061) [org.eclipse.jetty.server_9.2.9.v20150224.jar:9.2.9.v20150224]
	at org.eclipse.jetty.server.handler.ScopedHandler.handle(ScopedHandler.java:141) [org.eclipse.jetty.server_9.2.9.v20150224.jar:9.2.9.v20150224]
	at org.eclipse.jetty.server.handler.HandlerWrapper.handle(HandlerWrapper.java:97) [org.eclipse.jetty.server_9.2.9.v20150224.jar:9.2.9.v20150224]
	at org.eclipse.jetty.server.Server.handle(Server.java:497) [org.eclipse.jetty.server_9.2.9.v20150224.jar:9.2.9.v20150224]
	at org.eclipse.jetty.server.HttpChannel.handle(HttpChannel.java:310) [org.eclipse.jetty.server_9.2.9.v20150224.jar:9.2.9.v20150224]
	at org.eclipse.jetty.server.HttpConnection.onFillable(HttpConnection.java:257) [org.eclipse.jetty.server_9.2.9.v20150224.jar:9.2.9.v20150224]
	at org.eclipse.jetty.io.AbstractConnection$2.run(AbstractConnection.java:540) [org.eclipse.jetty.io_9.2.9.v20150224.jar:9.2.9.v20150224]
	at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:635) [org.eclipse.jetty.util_9.2.9.v20150224.jar:9.2.9.v20150224]
	at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:555) [org.eclipse.jetty.util_9.2.9.v20150224.jar:9.2.9.v20150224]
	at java.lang.Thread.run(Unknown Source) [na:1.7.0_79]
Caused by: org.eclipse.gyrex.cloud.internal.zk.GateDownException: ZooKeeper Gate is DOWN. (null)
	at org.eclipse.gyrex.cloud.internal.zk.ZooKeeperGate.get(ZooKeeperGate.java:137) ~[na:na]
	at org.eclipse.gyrex.cloud.internal.admin.CloudManagerImpl.getOnlineNodes(CloudManagerImpl.java:156) ~[na:na]
	... 75 common frames omitted
20:00:26.683 [Worker-1] DEBUG o.e.g.e.w.i.WebsocketEventTransport - Connecting online nodes for the event transport.
20:00:26.685 [Worker-1] WARN  o.e.g.e.w.i.WebsocketEventTransport - An error occured while connecting online nodes for the event transport. Operation will be retried.
20:02:26.735 [Worker-0] DEBUG o.e.g.e.w.i.WebsocketEventTransport - Connecting online nodes for the event transport.
20:02:26.736 [Worker-0] WARN  o.e.g.e.w.i.WebsocketEventTransport - An error occured while connecting online nodes for the event transport. Operation will be retried.
20:04:26.786 [Worker-0] DEBUG o.e.g.e.w.i.WebsocketEventTransport - Connecting online nodes for the event transport.
20:04:26.788 [Worker-0] WARN  o.e.g.e.w.i.WebsocketEventTransport - An error occured while connecting online nodes for the event transport. Operation will be retried.


Study every day, and love every day!
Re: what's the correct eclipse version shall I use for gyrex 1.3.2? [message #1701759 is a reply to message #1701754] Wed, 15 July 2015 12:53 Go to previous messageGo to next message
Sean Zhang is currently offline Sean ZhangFriend
Messages: 20
Registered: July 2015
Location: China
Junior Member

Hi Gunnar,

I have resolved the problem according to the guide described in https://wiki.eclipse.org/Gyrex/Learning_Material/Develop_OSGi_DS

Thanks a lot.
And sorry for my mistake.


Study every day, and love every day!
Re: what's the correct eclipse version shall I use for gyrex 1.3.2? [message #1701772 is a reply to message #1701754] Wed, 15 July 2015 13:55 Go to previous messageGo to next message
Gunnar Wagenknecht is currently offline Gunnar WagenknechtFriend
Messages: 486
Registered: July 2009
Location: San Francisco ✈ Germany
Senior Member

Hi,

On 2015-07-15 12:06:08 +0000, Sean Zhang said:
> Caused by: org.eclipse.gyrex.cloud.internal.zk.GateDownException:
> ZooKeeper Gate is DOWN. (null)
> at
> org.eclipse.gyrex.cloud.internal.zk.ZooKeeperGate.get(ZooKeeperGate.java:137)
> ~[na:na]
> at
> org.eclipse.gyrex.cloud.internal.admin.CloudManagerImpl.getOnlineNodes(CloudManagerImpl.java:156)
> ~[na:na]
> ... 75 common frames omitted
> 20:00:26.683 [Worker-1] DEBUG o.e.g.e.w.i.WebsocketEventTransport -
> Connecting online nodes for the event transport.
> 20:00:26.685 [Worker-1] WARN o.e.g.e.w.i.WebsocketEventTransport - An
> error occured while connecting online nodes for the event transport.
> Operation will be retried.


Is there some firewall active which could block connections?

-Gunnar


--
Gunnar Wagenknecht
gunnar@xxxxxxxx
Re: what's the correct eclipse version shall I use for gyrex 1.3.2? [message #1702297 is a reply to message #1701697] Tue, 21 July 2015 12:34 Go to previous messageGo to next message
Gunnar Wagenknecht is currently offline Gunnar WagenknechtFriend
Messages: 486
Registered: July 2009
Location: San Francisco ✈ Germany
Senior Member

Hi,

On 2015-07-15 06:21:32 +0000, Sean Zhang said:
> org.osgi.framework.BundleException: Could not resolve module:
> org.apache.solr.client.solrj [61]
> Unresolved requirement: Import-Package:
> org.apache.commons.httpclient; version="3.1.0"

If you do plan to use the Solr add-on please add
org.apache.commons.httpclient to your target file. It's available in
Orbit.

> org.osgi.framework.BundleException: Could not resolve module:
> org.eclipse.gyrex.http.jersey [159]
> Unresolved requirement: Import-Package:
> org.eclipse.persistence.jaxb.rs; version="[2.4.0,3.0.0)";
> resolution:="optional"
> Unresolved requirement: Import-Package: org.objectweb.asm;
> version="[3.1.0,4.0.0)"

Can you add org.objectweb.asm to your target definition? It's available
in Orbit.


> org.osgi.framework.BundleException: Could not resolve module:
> org.eclipse.jetty.websocket.javax.websocket.server [235]
> Unresolved requirement: Require-Capability: osgi.extender;
> filter:="(osgi.extender=osgi.serviceloader.registrar)"

That looks like a new requirement in Jetty for WebSockets. I'm not
aware that this is being provided by Equinox. Looks like it needs a
component from Apache Aries.

-Gunnar


--
Gunnar Wagenknecht
gunnar@xxxxxxxx
Re: what's the correct eclipse version shall I use for gyrex 1.3.2? [message #1702299 is a reply to message #1702297] Tue, 21 July 2015 12:40 Go to previous message
Gunnar Wagenknecht is currently offline Gunnar WagenknechtFriend
Messages: 486
Registered: July 2009
Location: San Francisco ✈ Germany
Senior Member

On 2015-07-21 12:34:25 +0000, Gunnar Wagenknecht said:
>
>> org.osgi.framework.BundleException: Could not resolve module:
>> org.eclipse.jetty.websocket.javax.websocket.server [235]
>> Unresolved requirement: Require-Capability: osgi.extender;
>> filter:="(osgi.extender=osgi.serviceloader.registrar)"

I just realized ... this is javax.websocket.server bundle. It can be
ignored and is not required by Gyrex.

Can you post a setup of your launch configuration? For some reason it
looks like it's trying to start all bundles. That shouldn't be
necessary.

-Gunnar

--
Gunnar Wagenknecht
gunnar@xxxxxxxx
Previous Topic:Blueprint/Hibernate/ECF Support
Next Topic:About the mounts of the JAX-RS demo
Goto Forum:
  


Current Time: Sun Sep 23 13:48:48 GMT 2018

Powered by FUDForum. Page generated in 0.02779 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top