Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » BPMN 2.0 Modeler » Mars, Luna and the Graphiti dependencies....
Mars, Luna and the Graphiti dependencies.... [message #1699811] Fri, 26 June 2015 19:15 Go to next message
Ralph Soika is currently offline Ralph SoikaFriend
Messages: 137
Registered: July 2009
Senior Member
Hi Bob,

I recognized that the plugin dependencies for graphiti between luna (1.1.4) and current master (1.2.0) have changed in the MANIFEST.MF file

Luna releaese 1.1.4:
...
org.eclipse.graphiti;bundle-version="[0.11.0,0.12.0]",
org.eclipse.graphiti.ui;bundle-version="[0.11.0,0.12.0]",
...

Mars release 1.2.0 :
...
org.eclipse.graphiti;bundle-version="0.12.0",
org.eclipse.graphiti.ui;bundle-version="0.12.0",
....

I have added the same dependency bundle-version rule to my runtime extenstion as in the luna release branch. This works for Eclipse Luna. But for the same reason it is not possible to install the plugin in Eclipse Mars. I need to change the rule to "0.12.0".

So at the end it looks like I need two different builds - one for luna and one for mars - even if my code did not change. Just the dependencys of graphiti.

Why is this necessary? And why is the rule so important?
I tried to add the dependendcy without a rule in my runtime extension

...
org.eclipse.graphiti,
org.eclipse.graphiti.ui,
...

but this seems not to work.....


===
Ralph
Re: Mars, Luna and the Graphiti dependencies.... [message #1700054 is a reply to message #1699811] Mon, 29 June 2015 21:22 Go to previous messageGo to next message
Robert Brodt is currently offline Robert BrodtFriend
Messages: 811
Registered: August 2010
Location: Colorado Springs, CO
Senior Member

Hmm, try using this instead:

[0.11.0,0.13.0)

I don't know completely understand why, but this seems to clear up the dependency problems for me...

I forgot to mention: there was an API change in Graphiti 0.12.0 which required the new dependency rule.

[Updated on: Mon, 29 June 2015 21:23]

Report message to a moderator

Re: Mars, Luna and the Graphiti dependencies.... [message #1700595 is a reply to message #1700054] Sat, 04 July 2015 09:58 Go to previous message
Ralph Soika is currently offline Ralph SoikaFriend
Messages: 137
Registered: July 2009
Senior Member
Ok this was a dependency problem in my own plugin extension which I have now solved

After all I figured out that the BPMN2 Plugin version 1.2.0 can also be installed on Eclipse Luna when the graphiti plugin 0.12.0 was installed before. There for you can use the following update site to install graphiti 0.12.0 manually:
http://download.eclipse.org/graphiti/updates/0.12.0/

Thanks for the help!

===
Ralph
Previous Topic:The referenced BPMN element does not exist.
Next Topic:Eclipse Mars on Debian Jessie with Gnome 3
Goto Forum:
  


Current Time: Mon May 21 18:25:50 GMT 2018

Powered by FUDForum. Page generated in 0.02385 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top