Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Error initializing storage when launching Eclipse
Error initializing storage when launching Eclipse [message #1699087] Sat, 20 June 2015 16:52 Go to next message
Olivier Trebosc is currently offline Olivier TreboscFriend
Messages: 2
Registered: June 2015
Junior Member
Hallo!

If I just click on the icon to launch Eclipse, then it fails directly, if I start Eclipse from the command line I have an pop-window that says 'an error has occured. See the log file null.', when I try to lauch Eclipse with the command line, I have the following exception:

$ ./eclipse
Java HotSpot(TM) 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0
java.lang.RuntimeException: Error initializing storage.
at org.eclipse.osgi.internal.framework.EquinoxContainer.<init>(EquinoxContainer.java:77)
at org.eclipse.osgi.launch.Equinox.<init>(Equinox.java:31)
at org.eclipse.core.runtime.adaptor.EclipseStarter.startup(EclipseStarter.java:297)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:232)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:483)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:648)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:603)
at org.eclipse.equinox.launcher.Main.run(Main.java:1465)
at org.eclipse.equinox.launcher.Main.main(Main.java:1438)
Caused by: java.io.EOFException
at java.io.DataInputStream.readInt(DataInputStream.java:392)
at org.eclipse.osgi.container.ModuleDatabase$Persistence.readWire(ModuleDatabase.java:1168)
at org.eclipse.osgi.container.ModuleDatabase$Persistence.load(ModuleDatabase.java:1028)
at org.eclipse.osgi.container.ModuleDatabase.load(ModuleDatabase.java:879)
at org.eclipse.osgi.storage.Storage.<init>(Storage.java:143)
at org.eclipse.osgi.storage.Storage.createStorage(Storage.java:84)
at org.eclipse.osgi.internal.framework.EquinoxContainer.<init>(EquinoxContainer.java:75)
... 11 more


I tried several vm but the result is the same. I downloaded a newer version and it is a little bit better, Eclipse starts but if I want to create a project it crashes and I cannot find any log files.

Any help would be highly helpful!!

[Resolved] Error initializing storage when launching Eclipse [message #1699101 is a reply to message #1699087] Sun, 21 June 2015 08:38 Go to previous message
Olivier Trebosc is currently offline Olivier TreboscFriend
Messages: 2
Registered: June 2015
Junior Member
ok, I solved the problem and I can now start and play with eclipse. As I explained, I have a 'old' luna version that was working and which now broken. I downloaded a newer version that started but crash when trying to create a Project. I though I should solve the problem on my old version, but it was an error, I also made the error not to mention that I am working on kubuntu trusty. My new version failed with a message concerning "!_button._widget", I found here https://bugs.eclipse.org/bugs/show_bug.cgi?id=440660#c20 the solution. I opened the file "/usr/share/themes/oxygen-gtk/gtk-2.0/gtkrc" and change GtkComboBox::appears-as-list = 1 into GtkComboBox::appears-as-list = 0, as the link above said, now the newer version works

[Updated on: Sun, 21 June 2015 08:38]

Report message to a moderator

Previous Topic:Errors in Problems view does not get cleared after deleting error line in XML editor
Next Topic:New user encounters troubles with Eclipse
Goto Forum:
  


Current Time: Sun Oct 20 17:14:55 GMT 2019

Powered by FUDForum. Page generated in 0.02535 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top