Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Papyrus » for Stereotypes missing "Owned attribute" in properties.(followup to https://www.eclipse.org/forums/index.php/t/1067464/)
for Stereotypes missing "Owned attribute" in properties. [message #1698808] Thu, 18 June 2015 04:09 Go to next message
Rolf Schumacher is currently offline Rolf SchumacherFriend
Messages: 60
Registered: January 2014
Member
I thought I did it before: in defining a profile adding an attribute to a stereotype in order to become a tag in a model using that stereorype.

But looking at the properties window of a stereotype, I was expecting "Owned attribute" field, like with classes. It's not there, at least in my Luna installation 4.4.2 with Papyrus 1.0.2.

For illustration I attached two screenshots as they appear on my screen. One with the profile diagram selecting a stereotype showing its properties window, the other for a class. The first is missing the "Owned attribute" field as is exposed on the second one.

What did I miss?

[Updated on: Thu, 18 June 2015 04:34]

Report message to a moderator

Re: for Stereotypes missing "Owned attribute" in properties. [message #1698819 is a reply to message #1698808] Thu, 18 June 2015 07:30 Go to previous messageGo to next message
Johan Van Noten is currently offline Johan Van NotenFriend
Messages: 87
Registered: July 2009
Member
You need to look in the "Profile" tab, apply the desired stereotype there (if not done yet) and expand the stereotype you've applied.
There you will find all tagged values.
Re: for Stereotypes missing "Owned attribute" in properties. [message #1698840 is a reply to message #1698819] Thu, 18 June 2015 10:53 Go to previous messageGo to next message
Camille Letavernier is currently offline Camille LetavernierFriend
Messages: 932
Registered: February 2011
Senior Member
Hi,

Owned Attributes are not displayed in the properites view for Stereotypes. You can see the owned attributes either in the Model Explorer, or in the Diagram directly (In the "Attributes" compartment of the Stereotype)

Camille


Camille Letavernier

[Updated on: Thu, 18 June 2015 10:53]

Report message to a moderator

Re: for Stereotypes missing "Owned attribute" in properties. [message #1698922 is a reply to message #1698819] Thu, 18 June 2015 21:14 Go to previous messageGo to next message
Rolf Schumacher is currently offline Rolf SchumacherFriend
Messages: 60
Registered: January 2014
Member
Thank you, Johan

what I like to do is creating a profile that defines tags. I need to add an attribute that will become a tag ones my created profile is applied to some model.

It is not about using a profile an looking at tags.

Regards


Rolf
Re: for Stereotypes missing "Owned attribute" in properties. [message #1698926 is a reply to message #1698840] Thu, 18 June 2015 21:45 Go to previous message
Rolf Schumacher is currently offline Rolf SchumacherFriend
Messages: 60
Registered: January 2014
Member
Yes, thank you Camille

that worked (first time I used the browser to add an element).
This way I could reach my aim to have project specific tag/values at some elements.

Regards


Rolf
Previous Topic:EAST-ADL tutorial
Next Topic:Hide weight and guard through CSS
Goto Forum:
  


Current Time: Sun Nov 29 23:47:38 GMT 2020

Powered by FUDForum. Page generated in 0.02109 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top