Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sirius » Node Creation Problem
Node Creation Problem [message #1698202] Fri, 12 June 2015 07:05 Go to next message
Shin-Yi Lin is currently offline Shin-Yi LinFriend
Messages: 34
Registered: June 2015
Member
Hi all,

I have a problem of Node Creation in Section Tool. I can't drag and drop a new Node from Palette Tool into Representation diagram. I've followed the Sirius Get Started Video (https://youtu.be/08XIW8hZOyQ), 4 minutes tutorial (https://wiki.eclipse.org/Sirius/Tutorials/4MinTutorial), and Youtube Video (https://youtu.be/y2v7NB6K8aE), but still can't solve it.

The right-hand side SoftGoal in the Palette is what I want to add into the left diagram.
index.php/fa/22152/0/

The steps of Node Creation in Specification Editor:
index.php/fa/22153/0/
index.php/fa/22154/0/
index.php/fa/22155/0/
index.php/fa/22156/0/

  • Attachment: 1.jpg
    (Size: 65.92KB, Downloaded 230 times)
  • Attachment: 2.jpg
    (Size: 54.82KB, Downloaded 220 times)
  • Attachment: 3.jpg
    (Size: 33.10KB, Downloaded 224 times)
  • Attachment: 4.jpg
    (Size: 36.38KB, Downloaded 220 times)
  • Attachment: 5.jpg
    (Size: 29.47KB, Downloaded 235 times)
Re: Node Creation Problem [message #1698203 is a reply to message #1698202] Fri, 12 June 2015 07:06 Go to previous messageGo to next message
Shin-Yi Lin is currently offline Shin-Yi LinFriend
Messages: 34
Registered: June 2015
Member
Here is my metamodel Ecore diagram:
index.php/fa/22159/0/

  • Attachment: test.jpg
    (Size: 19.06KB, Downloaded 197 times)

[Updated on: Fri, 12 June 2015 16:10]

Report message to a moderator

Re: Node Creation Problem [message #1698205 is a reply to message #1698202] Fri, 12 June 2015 07:20 Go to previous messageGo to next message
Maxime Porhel is currently offline Maxime PorhelFriend
Messages: 500
Registered: July 2009
Location: Nantes, France
Senior Member
Le 12/06/2015 09:05, Shin-Yi Lin a écrit :
> Hi all,
>
> I have a problem of Node Creation in Section Tool. I can't drag and drop a new Node from Palette Tool into Representation diagram. I've followed the Sirius Get Started Video (https://youtu.be/08XIW8hZOyQ), 4 minutes tutorial (https://wiki.eclipse.org/Sirius/Tutorials/4MinTutorial), and Youtube Video (https://youtu.be/y2v7NB6K8aE), but still can't solve it.
>
> The right-hand side SoftGoal in the Palette is what I want to add into the left diagram.
>
>
> The steps of Node Creation in Specification Editor:
>
>
>
>
>
>

From your metamodel screenshot, it seems that the containment reference
able to store your NFRSoftGoal is softgoalMemebers and not
softgoalMembers as you wrote in your VSM. It seems a correction of a
typo is needed in your metamodel

Regards

--
Maxime - Obeo

Need professional services for Sirius?
http://www.obeodesigner.com/sirius


Maxime Porhel - Obeo

Need training or professional services for Sirius?
http://www.obeodesigner.com/sirius
Re: Node Creation Problem [message #1698255 is a reply to message #1698205] Fri, 12 June 2015 15:03 Go to previous message
Shin-Yi Lin is currently offline Shin-Yi LinFriend
Messages: 34
Registered: June 2015
Member
Hi Maxime,

Oh! I guess my eyes were not paying attention then.
Thank you for notice me that, It's solved.

Regards,

Shin-Yi
Previous Topic:Precondition Expression and Conditional Type of Relation Based Edge
Next Topic:Diagram Editor not showing dirty state!
Goto Forum:
  


Current Time: Thu Jan 21 12:45:35 GMT 2021

Powered by FUDForum. Page generated in 0.02004 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top