Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » UML2 » XMI serialization
XMI serialization [message #1697728] Sun, 07 June 2015 12:10 Go to next message
Ray Edah is currently offline Ray EdahFriend
Messages: 1
Registered: June 2015
Junior Member
Is it possible to get UML2 to serialize to a specific XMI version? I'm working with UML2 5.0, and as per the documentation at https://wiki.eclipse.org/MDT/UML2/UML2_5.0_Migration_Guide, the version number is set to 20131001 (XMI 2.5). I would like to serialize to XMI 2.1 (to allow the XMI file be loaded by UML packages that can only accept earlier versions).

Is this possible or should I be using an earlier version of UML2?

Thanks
Ray
Re: XMI serialization [message #1697805 is a reply to message #1697728] Mon, 08 June 2015 14:36 Go to previous message
Ed Willink is currently offline Ed WillinkFriend
Messages: 5585
Registered: July 2009
Senior Member
Hi

You can currently only serialize to the latest version.

So yes you could try using an earlier version, but then you may hit a
cannot load 'future' load problem.

There is an open Bugzilla to support multi-version saves, but I doubt it
will be done unless someone funds it explicitly.

Regards

Ed Willink

On 08/06/2015 15:05, Ray Edah wrote:
> Is it possible to get UML2 to serialize to a specific XMI version? I'm
> working with UML2 5.0, and as per the documentation at
> https://wiki.eclipse.org/MDT/UML2/UML2_5.0_Migration_Guide, the
> version number is set to 20131001 (XMI 2.5). I would like to serialize
> to XMI 2.1 (to allow the XMI file be loaded by UML packages that can
> only accept earlier versions).
>
> Is this possible or should I be using an earlier version of UML2?
>
> Thanks
> Ray
Previous Topic:Listen for (re)application of a profile
Next Topic:Question about the EMF implementation of the UML metamodel
Goto Forum:
  


Current Time: Tue Jan 23 08:24:05 GMT 2018

Powered by FUDForum. Page generated in 0.02300 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software