Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Buckminster dev » [buckminster-dev] Fwd: Build XText with ant
[buckminster-dev] Fwd: Build XText with ant [message #1697408] Wed, 03 June 2015 17:01 Go to next message
Siva Gaddam is currently offline Siva GaddamFriend
Messages: 22
Registered: June 2015
Junior Member
<div dir="ltr"><br><div class="gmail_quote"><div dir="ltr"><div><div><div><div><div><div><div><div>Hi,<br><br></div>I have been struggling to build my XText project with buckminister generated build file(build.ant). This is what I have done.<br></div>   Env :  Eclipse Luna, Java 1.8<br><br></div>   --&gt; Create new Xtext project, and created some grammar<br></div><div>  ---&gt; Ran mwe workflows and xtext artifacts<br></div>   --&gt; Create buckminister project<br></div>   ---&gt; ant -f build.ant<br><br>Errors:<br><br>[java] Error: file /home/vagrant/workspace/com.visa.ovn.rules.ui/src-gen/com/visa/ovn/ui/contentassist/antlr/PartialRulesContentAssistParser.java, line 33: Syntax error, parameterized types are only available if source level is 1.5 or greater<br> [java] Warning: file /home/vagrant/workspace/com.visa.ovn.rules.ui/META-INF/MANIFEST.MF, line 20: &#39;JavaSE-1.8&#39; is not a valid Execution Environment<br><br></div>Sorry if it is a basic question. Appreciate any help.<br><br></div>Thanks.<br><br></div>-Siva.<br><div><div><div><br><br><div><br></div></div></div></div></div>
</div><br></div>
Re: [buckminster-dev] Fwd: Build XText with ant [message #1697411 is a reply to message #1697408] Wed, 03 June 2015 17:10 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6037
Registered: July 2009
Senior Member
Hi

line 20: 'JavaSE-1.8' is not a valid Execution Environment

You are not using Java 8, either because it is not available, not
configured or your version of Buckminster does not support it.

Regards

Ed Willink


On 03/06/2015 18:01, sivanarayana ganesh wrote:
>
> Hi,
>
> I have been struggling to build my XText project with buckminister
> generated build file(build.ant). This is what I have done.
> Env : Eclipse Luna, Java 1.8
>
> --> Create new Xtext project, and created some grammar
> ---> Ran mwe workflows and xtext artifacts
> --> Create buckminister project
> ---> ant -f build.ant
>
> Errors:
>
> [java] Error: file
> /home/vagrant/workspace/com.visa.ovn.rules.ui/src-gen/com/visa/ovn/ui/contentassist/antlr/PartialRulesContentAssistParser.java,
> line 33: Syntax error, parameterized types are only available if
> source level is 1.5 or greater
> [java] Warning: file
> /home/vagrant/workspace/com.visa.ovn.rules.ui/META-INF/MANIFEST.MF,
> line 20: 'JavaSE-1.8' is not a valid Execution Environment
>
> Sorry if it is a basic question. Appreciate any help.
>
> Thanks.
>
> -Siva.
>
>
>
>
Re: [buckminster-dev] Fwd: Build XText with ant [message #1697414 is a reply to message #1697411] Wed, 03 June 2015 17:30 Go to previous messageGo to next message
Siva Gaddam is currently offline Siva GaddamFriend
Messages: 22
Registered: June 2015
Junior Member
<div dir="ltr"><div><div>Hi Ed,<br><br></div>Not sure what wrong with my setup . Here is my configuration.<br><br></div><div>IDE: Eclipse LUNA 4.4.2<br><br></div><div><b>Buckminister:</b><br><br>org.eclipse.buckminster.ant (1.2.360.v20130317-0829) &quot;Buckminster Ant Plug-in&quot; [Starting]<br>org.eclipse.buckminster.cmdline (1.0.350.v20130717-0925) &quot;Buckminster Headless Launcher&quot; [Starting]<br>org.eclipse.buckminster.core (1.3.0.v20131003-1606) &quot;Buckminster Core&quot; [Starting]<br>org.eclipse.buckminster.download (1.1.0.v20130614-0838) &quot;Buckminster download cache&quot; [Starting]<br>org.eclipse.buckminster.executor (1.0.0.v20130317-0829) &quot;Buckminster Executor Plug-in&quot; [Starting]<br>org.eclipse.buckminster.fetcher (1.0.0.v20130317-0829) &quot;Buckminster Fetcher Plug-in&quot; [Starting]<br>org.eclipse.buckminster.generic (1.0.0.v20130317-0829) &quot;Buckminster Generic Plug-in&quot; [Resolved]<br>org.eclipse.buckminster.jarprocessor (1.0.0.v20130317-0829) &quot;Buckminster Jarprocessor&quot; [Resolved]<br>org.eclipse.buckminster.jdt (1.1.0.v20130317-0829) &quot;Buckminster JDT Plug-in&quot; [Starting]<br>org.eclipse.buckminster.junit (1.0.0.v20130317-0829) &quot;Buckminster JUnit Integration&quot; [Resolved]<br>org.eclipse.buckminster.osgi.filter (1.1.0.v20130317-0829) &quot;Buckminster OSGi Filter&quot; [Resolved]<br>org.eclipse.buckminster.pde (1.3.0.v20140311-2235) &quot;Buckminster PDE Plug-in&quot; [Starting]<br>org.eclipse.buckminster..runtime (1.3.0.v20130317-0829) &quot;Buckminster Runtime Plug-in&quot; [Starting]<br>org.eclipse.buckminster.sax (1.0.0.v20130317-0829) &quot;Buckminster SAX Parser utilities&quot; [Resolved]<br><br></div><div><b>Buckminister headless:</b><br>    Buckminster - Core Headless    1.6.0.v20131003-1606    org.eclipse.buckminster.core.headless.feature.feature.group    Eclipse Buckminster Project<br>  Buckminster - Headless PDE support    1.6.0.v20140311-2235    org.eclipse.buckminster.pde.headless.feature.feature.group    Eclipse Buckminster Project<br><br></div><div><b>Java:</b><br></div><div><br>[vagrant@ovn-local-dev-new-rhel-66 buckminster]$ java -version<br>java version &quot;1.8.0_45&quot;<br>Java(TM) SE Runtime Environment (build 1.8.0_45-b14)<br>Java HotSpot(TM) 64-Bit Server VM (build 25.45-b02, mixed mode)<br>[vagrant@ovn-local-dev-new-rhel-66 buckminster]$ <br><br></div><div><b>Javac:</b><br>[vagrant@ovn-local-dev-new-rhel-66 buckminster]$ javac -version<br>javac 1.8.0_45<br>[vagrant@ovn-local-dev-new-rhel-66 buckminster]$ <br><br></div><div><b>JAVA_HOME:</b><br></div><div>   is set to java8.<br><br></div><div>Not sure what&#39;s wrong with my setup. Any clues?<br><br></div><div>-Siva.<br></div><div><br></div><div><br><br></div><div class="gmail_extra"><br><div class="gmail_quote">On Wed, Jun 3, 2015 at 5:10 PM, Ed Willink <span dir="ltr">&lt;<a href="mailto:ed@xxxxxxxx.uk" target="_blank">ed@xxxxxxxx.uk</a>&gt;</span> wrote:<br><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">Hi<span class=""><br>
<br>
line 20: &#39;JavaSE-1.8&#39; is not a valid Execution Environment<br>
<br></span>
You are not using Java 8, either because it is not available, not configured or your version of Buckminster does not support it.<br>
<br>
    Regards<br>
<br>
        Ed Willink<div><div class="h5"><br>
<br>
<br>
On 03/06/2015 18:01, sivanarayana ganesh wrote:<br>
<blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">
<br>
Hi,<br>
<br>
I have been struggling to build my XText project with buckminister generated build file(build.ant). This is what I have done.<br>
   Env :  Eclipse Luna, Java 1.8<br>
<br>
   --&gt; Create new Xtext project, and created some grammar<br>
  ---&gt; Ran mwe workflows and xtext artifacts<br>
   --&gt; Create buckminister project<br>
   ---&gt; ant -f build.ant<br>
<br>
Errors:<br>
<br>
[java] Error: file /home/vagrant/workspace/com.visa.ovn.rules.ui/src-gen/com/visa/ovn/ui/contentassist/antlr/PartialRulesContentAssistParser.java, line 33: Syntax error, parameterized types are only available if source level is 1.5 or greater<br>
 [java] Warning: file /home/vagrant/workspace/com.visa.ovn.rules.ui/META-INF/MANIFEST.MF, line 20: &#39;JavaSE-1.8&#39; is not a valid Execution Environment<br>
<br>
Sorry if it is a basic question. Appreciate any help.<br>
<br>
Thanks.<br>
<br>
-Siva.<br>
<br>
<br>
<br>
<br>
</blockquote>
<br></div></div>
_______________________________________________<br>
buckminster-dev mailing list<br>
<a href="mailto:buckminster-dev@xxxxxxxx" target="_blank">buckminster-dev@xxxxxxxx</a><span class=""><br>
To change your delivery options, retrieve your password, or unsubscribe from this list, visit<br>
</span><a href="https://dev.eclipse.org/mailman/listinfo/buckminster-dev" target="_blank">https://dev.eclipse.org/mailman/listinfo/buckminster-dev</a><br>
</blockquote></div><br></div></div>
Re: [buckminster-dev] Fwd: Build XText with ant [message #1697424 is a reply to message #1697414] Wed, 03 June 2015 20:04 Go to previous message
Ed Willink is currently offline Ed WillinkFriend
Messages: 6037
Registered: July 2009
Senior Member
HI

Doesn't look like a Luna version of Buckminster. I would expect some
201405/6's.

You have at least your Eclipse configuration/installed JREs and launch
configuration to worry about.

Regards

Ed Wiillink


On 03/06/2015 18:30, sivanarayana ganesh wrote:
> Hi Ed,
>
> Not sure what wrong with my setup . Here is my configuration.
>
> IDE: Eclipse LUNA 4.4.2
>
> *Buckminister:*
>
> org.eclipse.buckminster.ant (1.2.360.v20130317-0829) "Buckminster Ant
> Plug-in" [Starting]
> org.eclipse.buckminster.cmdline (1.0.350.v20130717-0925) "Buckminster
> Headless Launcher" [Starting]
> org.eclipse.buckminster.core (1.3.0.v20131003-1606) "Buckminster Core"
> [Starting]
> org.eclipse.buckminster.download (1.1.0.v20130614-0838) "Buckminster
> download cache" [Starting]
> org.eclipse.buckminster.executor (1.0.0.v20130317-0829) "Buckminster
> Executor Plug-in" [Starting]
> org.eclipse.buckminster.fetcher (1.0.0.v20130317-0829) "Buckminster
> Fetcher Plug-in" [Starting]
> org.eclipse.buckminster.generic (1.0.0.v20130317-0829) "Buckminster
> Generic Plug-in" [Resolved]
> org.eclipse.buckminster.jarprocessor (1.0.0.v20130317-0829)
> "Buckminster Jarprocessor" [Resolved]
> org.eclipse.buckminster.jdt (1.1.0.v20130317-0829) "Buckminster JDT
> Plug-in" [Starting]
> org.eclipse.buckminster.junit (1.0.0.v20130317-0829) "Buckminster
> JUnit Integration" [Resolved]
> org.eclipse.buckminster.osgi.filter (1.1.0.v20130317-0829)
> "Buckminster OSGi Filter" [Resolved]
> org.eclipse.buckminster.pde (1.3.0.v20140311-2235) "Buckminster PDE
> Plug-in" [Starting]
> org.eclipse.buckminster.runtime (1.3.0.v20130317-0829) "Buckminster
> Runtime Plug-in" [Starting]
> org.eclipse.buckminster.sax (1.0.0.v20130317-0829) "Buckminster SAX
> Parser utilities" [Resolved]
>
> *Buckminister headless:*
> Buckminster - Core Headless 1.6.0.v20131003-1606
> org.eclipse.buckminster.core.headless.feature.feature.group Eclipse
> Buckminster Project
> Buckminster - Headless PDE support 1.6.0.v20140311-2235
> org.eclipse.buckminster.pde.headless.feature.feature.group Eclipse
> Buckminster Project
>
> *Java:*
>
> [vagrant@ovn-local-dev-new-rhel-66 buckminster]$ java -version
> java version "1.8.0_45"
> Java(TM) SE Runtime Environment (build 1.8.0_45-b14)
> Java HotSpot(TM) 64-Bit Server VM (build 25.45-b02, mixed mode)
> [vagrant@ovn-local-dev-new-rhel-66 buckminster]$
>
> *Javac:*
> [vagrant@ovn-local-dev-new-rhel-66 buckminster]$ javac -version
> javac 1.8.0_45
> [vagrant@ovn-local-dev-new-rhel-66 buckminster]$
>
> *JAVA_HOME:*
> is set to java8.
>
> Not sure what's wrong with my setup. Any clues?
>
> -Siva.
>
>
>
>
> On Wed, Jun 3, 2015 at 5:10 PM, Ed Willink <ed@xxxxxxxx.uk
> <mailto:ed@xxxxxxxx.uk>> wrote:
>
> Hi
>
> line 20: 'JavaSE-1.8' is not a valid Execution Environment
>
> You are not using Java 8, either because it is not available, not
> configured or your version of Buckminster does not support it.
>
> Regards
>
> Ed Willink
>
>
>
> On 03/06/2015 18:01, sivanarayana ganesh wrote:
>
>
> Hi,
>
> I have been struggling to build my XText project with
> buckminister generated build file(build.ant). This is what I
> have done.
> Env : Eclipse Luna, Java 1.8
>
> --> Create new Xtext project, and created some grammar
> ---> Ran mwe workflows and xtext artifacts
> --> Create buckminister project
> ---> ant -f build.ant
>
> Errors:
>
> [java] Error: file
> /home/vagrant/workspace/com.visa.ovn.rules.ui/src-gen/com/visa/ovn/ui/contentassist/antlr/PartialRulesContentAssistParser.java,
> line 33: Syntax error, parameterized types are only available
> if source level is 1.5 or greater
> [java] Warning: file
> /home/vagrant/workspace/com.visa.ovn.rules.ui/META-INF/MANIFEST.MF,
> line 20: 'JavaSE-1.8' is not a valid Execution Environment
>
> Sorry if it is a basic question. Appreciate any help.
>
> Thanks.
>
> -Siva.
>
>
>
>
>
> _______________________________________________
> buckminster-dev mailing list
> buckminster-dev@xxxxxxxx <mailto:buckminster-dev@xxxxxxxx>
> To change your delivery options, retrieve your password, or
> unsubscribe from this list, visit
> https://dev.eclipse.org/mailman/listinfo/buckminster-dev
>
>
Previous Topic:Fwd: Re: is git.auto.fetch implemented at all?
Next Topic:[buckminster-dev] Windows proxy issue
Goto Forum:
  


Current Time: Fri Sep 21 04:27:23 GMT 2018

Powered by FUDForum. Page generated in 0.01989 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top