Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Language IDEs » PHP Development Tools (PDT) » Indicating syntax error when it's none(Syntax validation not knowing correct PHP 5.6)
Indicating syntax error when it's none [message #1697061] Mon, 01 June 2015 09:32 Go to next message
Thomas Zuschneid is currently offline Thomas ZuschneidFriend
Messages: 2
Registered: June 2015
Junior Member
Hello,

I'm using Eclipse 4.4 PDT (upgraded from Kepler), coding for PHP 5.6 (correctly set in project settings),
On following code the IDE indicates a syntax error (unexpected ´[´) on line 4. But code is working perfectly.

1: class foo {
2: const ARR = ['a', 'b', 'c'];
3: static function bar($i) {
4: echo self::ARR[$i];
5: }
6: }
7: foo::bar(2);

Is there an error in syntax validation or may I do something to avoid this?
Re: Indicating syntax error when it's none [message #1697084 is a reply to message #1697061] Mon, 01 June 2015 13:21 Go to previous messageGo to next message
Dawid Pakula is currently offline Dawid PakulaFriend
Messages: 243
Registered: March 2013
Senior Member
This is a bug reported here: https://bugs.eclipse.org/bugs/show_bug.cgi?id=459420

Re: Indicating syntax error when it's none [message #1709639 is a reply to message #1697084] Tue, 29 September 2015 19:44 Go to previous messageGo to next message
Thomas Zuschneid is currently offline Thomas ZuschneidFriend
Messages: 2
Registered: June 2015
Junior Member
Hello Dawid,

thanks for the information.
According to the linked bug report, the bug has been fixed.
As it is still present in Mars, will there be an update or is it already available somewhere?

Best Regards
Thomas
Re: Indicating syntax error when it's none [message #1709640 is a reply to message #1709639] Tue, 29 September 2015 19:59 Go to previous message
Dawid Pakula is currently offline Dawid PakulaFriend
Messages: 243
Registered: March 2013
Senior Member
It's fixed in 3.6 and will be available at Friday (Mars.1) - https://projects.eclipse.org/projects/tools.pdt/releases/3.6

Note, PDT 3.6 require DLTK 5.3, also targeted for Mars.1. If you want it in older eclipse version use official p2 update sites or unofficial pex repository.


Previous Topic:Generation of getter and setter
Next Topic:External Tools - selected text to tool's stdin
Goto Forum:
  


Current Time: Wed Sep 19 08:36:47 GMT 2018

Powered by FUDForum. Page generated in 0.02824 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top