Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Sirius » a problem to select a Viewpoint
a problem to select a Viewpoint [message #1696581] Wed, 27 May 2015 11:22 Go to next message
eunjung park is currently offline eunjung parkFriend
Messages: 72
Registered: April 2015
Member
Hi,

I have a problem when select a viewpoint.
I could select basicfamily's viewpoint following tutorial, but my own model doesn't work. It shows empty viewpoint selection.
I added my design model in the project dependency property of my instance model.
I don't know why this happens.
Please help me.

Thanks.

Regards,
Eunjung Park
Re: a problem to select a Viewpoint [message #1696637 is a reply to message #1696581] Wed, 27 May 2015 15:06 Go to previous messageGo to next message
Esteban Dugueperoux is currently offline Esteban DugueperouxFriend
Messages: 472
Registered: July 2009
Senior Member
Hi eunjung,

Do you have your odesign registered through
"org.eclipse.sirius.componentization" extension point in your plugin.xml
and through "ViewpointRegistry.getInstance().registerFromPlugin()" API
through your bundle activator?

Best Regards.

Le 27/05/2015 13:22, eunjung park a écrit :
> Hi,
>
> I have a problem when select a viewpoint.
> I could select basicfamily's viewpoint following tutorial, but my own
> model doesn't work. It shows empty viewpoint selection.
> I added my design model in the project dependency property of my
> instance model.
> I don't know why this happens.
> Please help me.
>
> Thanks.
>
> Regards,
> Eunjung Park



--
Esteban Dugueperoux - Obeo

Need professional services for Sirius?
http://www.obeodesigner.com/sirius
Re: a problem to select a Viewpoint [message #1696651 is a reply to message #1696637] Wed, 27 May 2015 16:04 Go to previous messageGo to next message
eunjung park is currently offline eunjung parkFriend
Messages: 72
Registered: April 2015
Member
Hi Esteban,

Currently, I use Sirius 2.0.4, and I don't know what you are saying.
Could you let me know how to do it, or any post regarding to it?

Thank
Re: a problem to select a Viewpoint [message #1696653 is a reply to message #1696651] Wed, 27 May 2015 16:12 Go to previous messageGo to next message
eunjung park is currently offline eunjung parkFriend
Messages: 72
Registered: April 2015
Member
Additionally, I didn't deploy. I just do it similiar to the 4minute tutorial defining my own model.
In the workbench, I cannot select a viewpoint because of empty popup.
Re: a problem to select a Viewpoint [message #1696710 is a reply to message #1696653] Thu, 28 May 2015 07:15 Go to previous messageGo to next message
Esteban Dugueperoux is currently offline Esteban DugueperouxFriend
Messages: 472
Registered: July 2009
Senior Member
If you have your odesign in the same workspace as your modeling project
to test your Viewpoint, then you do dynamic development [1]. A
precondition to do dynamic development is to have your metamodel deployed.

[1]
https://www.eclipse.org/sirius/doc/specifier/general/Specifying_Viewpoints.html#dynamic

Best Regards.

Le 27/05/2015 18:12, eunjung park a écrit :
> Additionally, I didn't deploy. I just do it similiar to the 4minute
> tutorial defining my own model.
> In the workbench, I cannot select a viewpoint because of empty popup.



--
Esteban Dugueperoux - Obeo

Need professional services for Sirius?
http://www.obeodesigner.com/sirius
Re: a problem to select a Viewpoint [message #1696732 is a reply to message #1696710] Thu, 28 May 2015 09:35 Go to previous message
eunjung park is currently offline eunjung parkFriend
Messages: 72
Registered: April 2015
Member
Hi, Esteban,

Thank you so much.
I read the article and validation function part, then I tried to do again.
My problem was the file model exension. I didn't know the meaning of the field which means accessible file format of viewpoint.
Thanks to your help, I could get to know more about the Sirius.

Best Regards,
Eunjung Park
Previous Topic:a problem when selecting a viewpoint
Next Topic:Limit the number of nodes in container
Goto Forum:
  


Current Time: Wed Jan 27 17:54:12 GMT 2021

Powered by FUDForum. Page generated in 0.01908 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top