Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » Correct way of migration from old version to new one(2.7.3 to 2.8)
Correct way of migration from old version to new one [message #1695784] Tue, 19 May 2015 09:18 Go to next message
Alex Gor is currently offline Alex GorFriend
Messages: 157
Registered: November 2014
Location: Russia
Senior Member
Hello All

I have a tested application that based on version 2.7.3 of xtext. Some part of code is autogenerated by xtext. Configuration file like plugin.xml contains references to 2.7.3 plugins. How can I provide safety migration between two version 2.7.3 and 2.8.x? I would not like create new projects and moving manually my code to new project. Is there more safety way?

Thanks
Alexander
Re: Correct way of migration from old version to new one [message #1695790 is a reply to message #1695784] Tue, 19 May 2015 10:08 Go to previous messageGo to next message
Ed Willink is currently offline Ed WillinkFriend
Messages: 7091
Registered: July 2009
Senior Member
Hi

Xtext is not not bidirectionally compatible, new editor on old run-time/
on editor on new-run-time. However many permutations work.

If you want fuller compatibility have a look at
https://bugs.eclipse.org/bugs/show_bug.cgi?id=460978 and
org.eclipse.ocl.examples.build.utilities.BackportToXtext_2_3_1.java used
to enable Xtext 2.9 generated OCL editors to run on an Xtext 2.3.1 platform.

Since Xtext endeavours to follow Eclipse backward compatibility
guidelines, your plugins should specify a lower bound that you know to
work, e.g. 2.7.3 and an upper bound of the next major version (3.0.0) .

Regards

Ed Willink


On 19/05/2015 10:18, Alex Gor wrote:
> Hello All
>
> I have a tested application that based on version 2.7.3 of xtext. Some
> part of code is autogenerated by xtext. Configuration file like
> plugin.xml contains references to 2.7.3 plugins. How can I provide
> safety migration between two version 2.7.3 and 2.8.x? I would not like
> create new projects and moving manually my code to new project. Is
> there more safety way?
>
> Thanks
> Alexander
>
Re: Correct way of migration from old version to new one [message #1695811 is a reply to message #1695790] Tue, 19 May 2015 13:14 Go to previous messageGo to next message
Alex Gor is currently offline Alex GorFriend
Messages: 157
Registered: November 2014
Location: Russia
Senior Member
I see your answer. But practically can I do the following
For example
- I download and install new boundle of Eclipse+new release of Xtext.
- create new workspace
- change upper bound of xtext's plugins

then

import my project to new workspace

Does it help me?
Re: Correct way of migration from old version to new one [message #1696122 is a reply to message #1695811] Fri, 22 May 2015 08:23 Go to previous messageGo to next message
Alex Gor is currently offline Alex GorFriend
Messages: 157
Registered: November 2014
Location: Russia
Senior Member
I did steps that mentioned before. Compilation completed with success. But I cannot run appliccation due to following errors
org.osgi.framework.BundleException: Could not resolve module: com.psl.atom [149]
  Unresolved requirement: Require-Bundle: org.eclipse.xtext.xbase; bundle-version="[2.8.2,3.0.0)"; visibility:="reexport"; resolution:="optional"
  Unresolved requirement: Require-Bundle: org.eclipse.xtext.generator; bundle-version="[2.8.2,3.0.0)"; resolution:="optional"
  Unresolved requirement: Require-Bundle: org.eclipse.emf.codegen.ecore; resolution:="optional"
  Unresolved requirement: Require-Bundle: org.eclipse.emf.mwe2.launch; resolution:="optional"
  Unresolved requirement: Require-Bundle: org.eclipse.xtext.builder; bundle-version="[2.8.2,3.0.0)"
    -> Bundle-SymbolicName: org.eclipse.xtext.builder; bundle-version="2.8.2.v201504100559"; singleton:="true"
       org.eclipse.xtext.builder [43]
         Unresolved requirement: Require-Bundle: org.eclipse.xtext.ui; bundle-version="[2.8.0,3.0.0)"
           -> Bundle-SymbolicName: org.eclipse.xtext.ui; bundle-version="2.8.2.v201504100559"; singleton:="true"
              org.eclipse.xtext.ui [104]
                Unresolved requirement: Require-Bundle: org.eclipse.xtext.ide; bundle-version="[2.8.0,3.0.0)"


I checked required library org.eclipse.xtext.ide is located in plugins folder. What is nature of this issue?

[Updated on: Fri, 22 May 2015 09:09]

Report message to a moderator

Re: Correct way of migration from old version to new one [message #1696130 is a reply to message #1696122] Fri, 22 May 2015 09:12 Go to previous message
Sebastian Zarnekow is currently offline Sebastian ZarnekowFriend
Messages: 3109
Registered: July 2009
Senior Member
Please make sure that xtext.ide is also listed in your launch config.

Best,
Sebastian
--
Looking for professional support for Xtext, Xtend or Eclipse Modeling?
Find help at http://xtext.itemis.com or xtext(@)itemis.com
Blog: zarnekow.blogspot.com
Twitter: @szarnekow
Google+: https://www.google.com/+SebastianZarnekow
Previous Topic:Eclipse DSL 2.8.0 package and Oracle tools
Next Topic:From XSD to Xtext: xsd:any / arbitrary XML content
Goto Forum:
  


Current Time: Sat Apr 10 23:03:27 GMT 2021

Powered by FUDForum. Page generated in 0.01477 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top