Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF » [xcore] No difference with annotation use
[xcore] No difference with annotation use [message #1695390] Wed, 13 May 2015 23:42 Go to next message
Paul Roubekas is currently offline Paul RoubekasFriend
Messages: 207
Registered: March 2012
Location: Chattanooga, TN USA
Senior Member
While doing all the steps on this https://wiki.eclipse.org/Xcore#Specifying_an_Annotation wiki section I noticed that any base Impl class already has the extends "MinimalEObjectImpl.Container", annotation or not. What am I missing?

Oxygen 3a
Windows 10
Re: [xcore] No difference with annotation use [message #1695399 is a reply to message #1695390] Thu, 14 May 2015 05:31 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 30372
Registered: July 2009
Senior Member
Paul,

Yes, that's the default for Xcore-based GenModels. At some point I
decided that given that Xcore models are new, they could be initialized
to have improved defaults without affecting existing clients with
unexpected changes... But that leaves that example in the documentation
as not the best example.

On 14/05/2015 1:42 AM, Paul Roubekas wrote:
> While doing all the steps on this
> https://wiki.eclipse.org/Xcore#Specifying_an_Annotation wiki section I
> noticed that any base Impl class already has the extends
> "MinimalEObjectImpl.Container", annotation or not. What am I missing?
Previous Topic:GenModel fails on some ECore types
Next Topic:How to force EMF not to manipulate reference ids
Goto Forum:
  


Current Time: Sat Aug 24 07:42:55 GMT 2019

Powered by FUDForum. Page generated in 0.01937 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top