Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » M2T (model-to-text transformation) » xpand to xtend2 type system migration(xpand to xtend2 type system migration)
xpand to xtend2 type system migration [message #1695180] Tue, 12 May 2015 13:48 Go to next message
Babu M is currently offline Babu MFriend
Messages: 20
Registered: February 2012
Junior Member
Hi,

I am trying to get comfort with xtend2 and we are migrating a project from xpand to xtend2.

In xpand, we have 'type system' expression as follows:

{{{

┬źDEFINE Include_H FOR AUTOSAR::EcucDefs::Com┬╗

}}}

We would like to derieve the similar type-systems in xtend2 i.e. in .xtend templates. Could you please point me if already supported in xtend2 or should i need to write similar wrappers in xtend2?. Also, how easy i can do this. If the migration is required, any documentation is of great help.

Regards,
Hari
Re: xpand to xtend2 type system migration [message #1695216 is a reply to message #1695180] Tue, 12 May 2015 17:55 Go to previous messageGo to next message
Christian Dietrich is currently online Christian DietrichFriend
Messages: 12104
Registered: July 2009
Senior Member
Hi,

there is not reflective type system.
thus you need physical wrappers

are these wrappers for param defs or for param values?
if it is for param values:

artop can generate xtend wrapper classes as well) they can then be used by the generator.
the generator can be found here: https://www.artop.org/gitweb/?p=development/ecuc;a=tree;f=aal/examples;h=b67a74e48bd51cfdaeaaabb60d52135e7aa7b826;hb=HEAD
the generated code here: https://www.artop.org/gitweb/?p=development/ecuc;a=tree;f=aal/plugins/org.artop.ecuc.autosar421.accessors;h=769035652163d0abee9f6c6be5c17f5932e03db6;hb=HEAD
i dont know if it already ships them

you can then wrap ecucmoduleconfigvalues into one of it default occurrences


Need professional support for Xtext, Xpand, EMF?
Go to: https://xtext.itemis.com
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: xpand to xtend2 type system migration [message #1695286 is a reply to message #1695216] Wed, 13 May 2015 11:10 Go to previous messageGo to next message
Babu M is currently offline Babu MFriend
Messages: 20
Registered: February 2012
Junior Member
Hi Christian,

Thanks for update and it's really a good pointer for me to start with.

Currently, I am struggling to run the plugins from the links provided by you due to dependency issues. Any simple steps to work with these plugins / resolve dependency without any compilation issues?

OR

How can i replicate the same setup at my place that the developers are having at artop? OR can i get any ready made setup to simple import these plugins and run?. I am sure Artext will not suffice the purpose.
Re: xpand to xtend2 type system migration [message #1695293 is a reply to message #1695286] Wed, 13 May 2015 11:33 Go to previous messageGo to next message
Christian Dietrich is currently online Christian DietrichFriend
Messages: 12104
Registered: July 2009
Senior Member
Hi,

did you have a look if artop already contains these plugins? org.artop.ecuc.autosar421.accessors

if so you should be ablte to install them through eclipse update (p2)
(and add them to your target platform so that everybody gets it)


Need professional support for Xtext, Xpand, EMF?
Go to: https://xtext.itemis.com
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: xpand to xtend2 type system migration [message #1695296 is a reply to message #1695293] Wed, 13 May 2015 11:44 Go to previous messageGo to next message
Babu M is currently offline Babu MFriend
Messages: 20
Registered: February 2012
Junior Member
> did you have a look if artop already contains these plugins? org.artop.ecuc.autosar421.accessors

I have verified all variants of artop, 'org.artop.ecuc.autosar421.accessors' is not part of any variant.
Re: xpand to xtend2 type system migration [message #1695298 is a reply to message #1695296] Wed, 13 May 2015 11:52 Go to previous messageGo to next message
Christian Dietrich is currently online Christian DietrichFriend
Messages: 12104
Registered: July 2009
Senior Member
sure?


and simly using the sources for that plugin does not work? what is the error message you get?


Need professional support for Xtext, Xpand, EMF?
Go to: https://xtext.itemis.com
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: xpand to xtend2 type system migration [message #1695299 is a reply to message #1695296] Wed, 13 May 2015 11:52 Go to previous messageGo to next message
Christian Dietrich is currently online Christian DietrichFriend
Messages: 12104
Registered: July 2009
Senior Member
P.S: maybe that is something you should directly ask to artop

Need professional support for Xtext, Xpand, EMF?
Go to: https://xtext.itemis.com
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: xpand to xtend2 type system migration [message #1695301 is a reply to message #1695299] Wed, 13 May 2015 12:00 Go to previous messageGo to next message
Christian Dietrich is currently online Christian DietrichFriend
Messages: 12104
Registered: July 2009
Senior Member
p.p.s: i just talked to the itemis france guys that maintain that thing: it is in artop 4.5 nightly only

Need professional support for Xtext, Xpand, EMF?
Go to: https://xtext.itemis.com
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: xpand to xtend2 type system migration [message #1695315 is a reply to message #1695299] Wed, 13 May 2015 13:05 Go to previous messageGo to next message
Babu M is currently offline Babu MFriend
Messages: 20
Registered: February 2012
Junior Member

> and simly using the sources for that plugin does not work? what is the error message you get?

It will be the good option. to use this, 'org.artop.ecuc.autosar421.accessors' has dependency on 'org.artop.ecuc.gautosar.accessors.lib'.

and this lib plugin is missing IWrapper (import org.eclipse.sphinx.emf.util.IWrapper) interface. Which means, w.r.t. spinx installation, i have a version mis-match between the accessor plugins and the installation which i have locally.

As you suggested, i tried sending the mails and bouncing with following error message: Any help on which mail id i should send.

'sorry, no mailbox here by that name (#5.1.1) '
{{{
membership@artop.org (membership@artop.org)
development@artop.org (development@artop.org)
artext@artop.org (artext@artop.org)
}}}
Re: xpand to xtend2 type system migration [message #1695316 is a reply to message #1695315] Wed, 13 May 2015 13:07 Go to previous messageGo to next message
Babu M is currently offline Babu MFriend
Messages: 20
Registered: February 2012
Junior Member

> it is in artop 4.5 nightly only
Oh! then i am wondering if i can use this. If so, how can i?. Please help me with a valid artop mail id.

Thank you so much for your help.
Re: xpand to xtend2 type system migration [message #1695317 is a reply to message #1695316] Wed, 13 May 2015 13:12 Go to previous messageGo to next message
Christian Dietrich is currently online Christian DietrichFriend
Messages: 12104
Registered: July 2009
Senior Member
Sorry i cannot help you with that. Ask the artop contact person in your company

Need professional support for Xtext, Xpand, EMF?
Go to: https://xtext.itemis.com
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: xpand to xtend2 type system migration [message #1695321 is a reply to message #1695317] Wed, 13 May 2015 13:21 Go to previous message
Christian Dietrich is currently online Christian DietrichFriend
Messages: 12104
Registered: July 2009
Senior Member
Ps the nightly can be found in the buildserver but i have n link for that

Need professional support for Xtext, Xpand, EMF?
Go to: https://xtext.itemis.com
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Previous Topic:[acceleo] Unable to generate code
Next Topic:UML2C where to start
Goto Forum:
  


Current Time: Mon Jul 16 20:09:47 GMT 2018

Powered by FUDForum. Page generated in 0.02004 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top