Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » TMF (Xtext) » [xText] Unable to Generate xText Artifacts
[xText] Unable to Generate xText Artifacts [message #1694105] Thu, 30 April 2015 14:37 Go to next message
Junaid Mohiuddin is currently offline Junaid MohiuddinFriend
Messages: 11
Registered: April 2015
Junior Member
Hello ,

I am just want to Generate the xtext artifacts of my Grammar .But when i generate the Artifacts it will give me the following errors

[File] MyDsl.xtext
grammar org.xtext.example.mydsl.MyDsl with org.eclipse.xtext.common.Terminals

generate myDsl "//www.xtext.org/example/mydsl/MyDsl"

Model:
	greetings+=Greeting*;
	
Greeting:
	'Hello' name=ID '!';




Stacktrace
189  [main] INFO  lipse.emf.mwe.utils.StandaloneSetup  - Adding generated EPackage 'org.eclipse.xtext.xbase.XbasePackage'
364  [main] INFO  clipse.emf.mwe.utils.GenModelHelper  - Registered GenModel ' ://www.eclipse.org/Xtext/Xbase/XAnnotations' from 'platform:/resource/org.eclipse.xtext.xbase/model/Xbase.genmodel'
378  [main] INFO  clipse.emf.mwe.utils.GenModelHelper  - Registered GenModel ' ://www.eclipse.org/xtext/xbase/Xtype' from 'platform:/resource/org.eclipse.xtext.xbase/model/Xbase.genmodel'
388  [main] INFO  clipse.emf.mwe.utils.GenModelHelper  - Registered GenModel ' ://www.eclipse.org/xtext/xbase/Xbase' from 'platform:/resource/org.eclipse.xtext.xbase/model/Xbase.genmodel'
388  [main] INFO  clipse.emf.mwe.utils.GenModelHelper  - Registered GenModel ' ://www.eclipse.org/xtext/common/JavaVMTypes' from 'platform:/resource/org.eclipse.xtext.common.types/model/JavaVMTypes.genmodel'
752  [main] INFO  lipse.emf.mwe.utils.StandaloneSetup  - Adding generated EPackage 'org.eclipse.xtext.common.types.TypesPackage'
760  [main] INFO  ipse.emf.mwe.utils.DirectoryCleaner  - Cleaning C:\Users\jumo\workspaceXtext\org.xtext.example.mydsl\..\org.xtext.example.mydsl\src-gen
772  [main] INFO  ipse.emf.mwe.utils.DirectoryCleaner  - Cleaning C:\Users\jumo\workspaceXtext\org.xtext.example.mydsl\..\org.xtext.example.mydsl\model\generated
1543 [main] INFO  clipse.emf.mwe.utils.GenModelHelper  - Registered GenModel ' ://www.xtext.org/example/mydsl/MyDsl' from 'platform:/resource/org.xtext.example.mydsl/model/generated/MyDsl.genmodel'
2956 [main] INFO  text.generator.junit.Junit4Fragment  - generating Junit4 Test support classes
2969 [main] INFO  text.generator.junit.Junit4Fragment  - generating Compare Framework infrastructure
3044 [main] ERROR g.eclipse.xtext.generator.Generator  - java.io.FileNotFoundException: ..\org.xtext.example.mydsl.ui\META-INF\MANIFEST.MF (The system cannot find the path specified)
org.eclipse.emf.common.util.WrappedException: java.io.FileNotFoundException: ..\org.xtext.example.mydsl.ui\META-INF\MANIFEST.MF (The system cannot find the path specified)
	at org.eclipse.xtext.generator.Generator.mergeManifest(Generator.java:624)
	at org.eclipse.xtext.generator.Generator.generateManifestUi(Generator.java:666)
	at org.eclipse.xtext.generator.Generator.invokeInternal(Generator.java:184)
	at org.eclipse.emf.mwe.core.lib.AbstractWorkflowComponent.invoke(AbstractWorkflowComponent.java:126)
	at org.eclipse.emf.mwe.core.lib.Mwe2Bridge.invoke(Mwe2Bridge.java:34)
	at org.eclipse.emf.mwe.core.lib.AbstractWorkflowComponent.invoke(AbstractWorkflowComponent.java:201)
	at org.eclipse.emf.mwe2.runtime.workflow.AbstractCompositeWorkflowComponent.invoke(AbstractCompositeWorkflowComponent.java:35)
	at org.eclipse.emf.mwe2.runtime.workflow.Workflow.run(Workflow.java:19)
	at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:102)
	at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:62)
	at org.eclipse.emf.mwe2.launch.runtime.Mwe2Runner.run(Mwe2Runner.java:52)
	at org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.run(Mwe2Launcher.java:74)
	at org.eclipse.emf.mwe2.launch.runtime.Mwe2Launcher.main(Mwe2Launcher.java:35)
Caused by: java.io.FileNotFoundException: ..\org.xtext.example.mydsl.ui\META-INF\MANIFEST.MF (The system cannot find the path specified)
	at java.io.FileInputStream.open(Native Method)
	at java.io.FileInputStream.<init>(Unknown Source)
	at org.eclipse.xtext.generator.Generator.mergeManifest(Generator.java:610)
	... 12 more
3046 [main] INFO  .emf.mwe2.runtime.workflow.Workflow  - Done.



Anybody have an idea how to resolve this issue?

Re: [xText] Unable to Generate xText Artifacts [message #1694123 is a reply to message #1694105] Thu, 30 April 2015 17:46 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13885
Registered: July 2009
Senior Member
does this happen with a project created by the wizard? is the file there it complains about?

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: [xText] Unable to Generate xText Artifacts [message #1694288 is a reply to message #1694123] Mon, 04 May 2015 08:14 Go to previous messageGo to next message
Junaid Mohiuddin is currently offline Junaid MohiuddinFriend
Messages: 11
Registered: April 2015
Junior Member
Hi ,

Well as per my understanding when we Generate the Xtext Artifacts of the grammar it will generate the two projects with name "<project_name>.ui" and "<project_name>.tests". Unfortunately in my case it will not generate these project completely.

Regards,
Junaid Mohiiuddin
Re: [xText] Unable to Generate xText Artifacts [message #1694314 is a reply to message #1694288] Mon, 04 May 2015 11:53 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13885
Registered: July 2009
Senior Member
HI,

these project should be created by the wizard, not the generator


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: [xText] Unable to Generate xText Artifacts [message #1694316 is a reply to message #1694314] Mon, 04 May 2015 12:31 Go to previous messageGo to next message
Junaid Mohiuddin is currently offline Junaid MohiuddinFriend
Messages: 11
Registered: April 2015
Junior Member
Hi ,

Any idea why the wizard not creating these project completely ?

Regards,
Junaid Mohiuddin
Re: [xText] Unable to Generate xText Artifacts [message #1694317 is a reply to message #1694316] Mon, 04 May 2015 12:36 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13885
Registered: July 2009
Senior Member
nope. does the error log contain any hints?

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: [xText] Unable to Generate xText Artifacts [message #1694318 is a reply to message #1694317] Mon, 04 May 2015 12:38 Go to previous messageGo to next message
Junaid Mohiuddin is currently offline Junaid MohiuddinFriend
Messages: 11
Registered: April 2015
Junior Member
Hi ,

Well there is nothing in error log .I already paste the stacktrace above .

Regards,
Junaid Mohiuddin
Re: [xText] Unable to Generate xText Artifacts [message #1694322 is a reply to message #1694318] Mon, 04 May 2015 12:56 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13885
Registered: July 2009
Senior Member
i mean the error log of the project wizard.
(did you try a fresh workspace)
the error log can be found in the error log view


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: [xText] Unable to Generate xText Artifacts [message #1694323 is a reply to message #1694322] Mon, 04 May 2015 13:04 Go to previous messageGo to next message
Junaid Mohiuddin is currently offline Junaid MohiuddinFriend
Messages: 11
Registered: April 2015
Junior Member
Hi ,

The project Error logs show the following plugin related error

Message
eclipse.buildId=4.4.2.M20150204-1700
java.version=1.8.0_31
java.vendor=Oracle Corporation
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=en_US
Framework arguments: -product org.eclipse.epp.package.java.product
Command-line arguments: -os win32 -ws win32 -arch x86 -product org.eclipse.epp.package.java.product

org.eclipse.ui
Error
Mon May 04 15:00:22 CEST 2015
Plug-in 'org.eclipse.xtext.ui.shared' contributed an invalid Menu Extension (Path: 'org.eclipse.ui.projectConfigure' is invalid): org.eclipse.xtext.builder.action.RemoveXtextNatureAction


Re: [xText] Unable to Generate xText Artifacts [message #1694330 is a reply to message #1694323] Mon, 04 May 2015 13:51 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13885
Registered: July 2009
Senior Member
hmmm. maybe your install. is broken. did you try it with a freshly downloaded distro?

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: [xText] Unable to Generate xText Artifacts [message #1694333 is a reply to message #1694330] Mon, 04 May 2015 14:04 Go to previous messageGo to next message
Junaid Mohiuddin is currently offline Junaid MohiuddinFriend
Messages: 11
Registered: April 2015
Junior Member
I will try more than 3 time with new eclipse and new xtext plugin
Re: [xText] Unable to Generate xText Artifacts [message #1694345 is a reply to message #1694333] Mon, 04 May 2015 15:27 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13885
Registered: July 2009
Senior Member
hmmm very strange. did you try one of the prepackaged distros: https://www.eclipse.org/Xtext/download.html (Full Eclipse)

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: [xText] Unable to Generate xText Artifacts [message #1694488 is a reply to message #1694345] Tue, 05 May 2015 15:25 Go to previous messageGo to next message
Junaid Mohiuddin is currently offline Junaid MohiuddinFriend
Messages: 11
Registered: April 2015
Junior Member
Hi ,

I am also try with the one of the package distros.
Re: [xText] Unable to Generate xText Artifacts [message #1694490 is a reply to message #1694488] Tue, 05 May 2015 15:26 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13885
Registered: July 2009
Senior Member
did you double check that the wizard really creates only one project

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: [xText] Unable to Generate xText Artifacts [message #1694491 is a reply to message #1694490] Tue, 05 May 2015 15:28 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13885
Registered: July 2009
Senior Member
p.s: and where is your workspace located. maybe it is a windows paths thing

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: [xText] Unable to Generate xText Artifacts [message #1694838 is a reply to message #1694491] Fri, 08 May 2015 11:38 Go to previous messageGo to next message
Junaid Mohiuddin is currently offline Junaid MohiuddinFriend
Messages: 11
Registered: April 2015
Junior Member
Hi
My workspace path is "C:\Users\jumo\workspaceNewdsl".
Re: [xText] Unable to Generate xText Artifacts [message #1694839 is a reply to message #1694838] Fri, 08 May 2015 11:42 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13885
Registered: July 2009
Senior Member
no that should be be too long.

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: [xText] Unable to Generate xText Artifacts [message #1694853 is a reply to message #1694839] Fri, 08 May 2015 13:24 Go to previous messageGo to next message
Junaid Mohiuddin is currently offline Junaid MohiuddinFriend
Messages: 11
Registered: April 2015
Junior Member
Sorry ,did you mean that workspace path is too long "path is "C:\Users\jumo\workspaceNewdsl" ?
Re: [xText] Unable to Generate xText Artifacts [message #1694856 is a reply to message #1694853] Fri, 08 May 2015 14:01 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13885
Registered: July 2009
Senior Member
i meant it before but it is just fine. so i really have no idea what goes wrong.

Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: [xText] Unable to Generate xText Artifacts [message #1695000 is a reply to message #1694856] Mon, 11 May 2015 09:54 Go to previous messageGo to next message
Junaid Mohiuddin is currently offline Junaid MohiuddinFriend
Messages: 11
Registered: April 2015
Junior Member
Hi ,

I need to ask one question that when i try to generate the Xtext Artifact of the grammer file following are the project are auto-generated .As i inspect the auto-generated project "<project_name>.ui" is not generated completely.So is this an issue ?


  • <project_name>.edit
  • <project_name>.editor
  • <project_name>.tests
  • <project_name>.ui


[Updated on: Mon, 11 May 2015 09:54]

Report message to a moderator

Re: [xText] Unable to Generate xText Artifacts [message #1695004 is a reply to message #1695000] Mon, 11 May 2015 10:37 Go to previous messageGo to next message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13885
Registered: July 2009
Senior Member
Hi

With "autogenerate" you mean the wizard? or the workflow?
the wizard creates

<project_name>.ui
META-INF/MANIFEST.MF
(and others)


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Re: [xText] Unable to Generate xText Artifacts [message #1695011 is a reply to message #1695004] Mon, 11 May 2015 11:24 Go to previous messageGo to next message
Junaid Mohiuddin is currently offline Junaid MohiuddinFriend
Messages: 11
Registered: April 2015
Junior Member
HI
I mean that when i try to run the workflow file it will generate the <project_name>.ui but unfortunately it will not generate correctly .

Regards
Junaid Mohiuddin
Re: [xText] Unable to Generate xText Artifacts [message #1695016 is a reply to message #1695011] Mon, 11 May 2015 12:10 Go to previous message
Christian Dietrich is currently offline Christian DietrichFriend
Messages: 13885
Registered: July 2009
Senior Member
The basic workflow

1 create project via wizard
2 run the workflow

Should work fine. But 2 does Not create the project itself but contents only


Need professional support for Xtext, Xpand, EMF?
Go to: https://www.itemis.com/en/it-services/methods-and-tools/xtext
Twitter : @chrdietrich
Blog : https://www.dietrich-it.de
Previous Topic:Cannot generate artifacts using ANT
Next Topic:Getting all JvmTypes matching a wildcard import
Goto Forum:
  


Current Time: Mon Apr 19 09:48:28 GMT 2021

Powered by FUDForum. Page generated in 0.02456 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top