Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Eclipse won't start, jdk is incompatible
Eclipse won't start, jdk is incompatible [message #1692772] Fri, 17 April 2015 22:59 Go to next message
Jakub Fiuk is currently offline Jakub FiukFriend
Messages: 1
Registered: April 2015
Junior Member
Hello everyone
So, right now I'm starting my adventure with Java development and I'm having inconveniences just on the beginning.
Getting this error when trying to turn on the Eclipse, I've tried 64-bit, 32-bit, jdk for proper bit, like 4 different versions from 1.6u17 to the latest one and i'm helpless.

http://imgur.com/IfIKo8e

Also have edited the eclipse.ini file and now it looks like this:
-startup
plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
--launcher.library
plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.200.v20150204-1316
-product
org.eclipse.epp.package.java.product
--launcher.defaultAction
openFile
--launcher.XXMaxPermSize
256M
-showsplash
org.eclipse.platform
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
openFile
--launcher.appendVmargs
-vmargs
-Dosgi.requiredJavaVersion=1.6
-vm
C:\Program Files (x86)\Java\jdk1.7.0_79\jre\bin\javaw.exe

-Xms40m
-Xmx512m

Please help me to fix this issue, I'm really willing to start working on Eclipse as soon as possible.

[Updated on: Mon, 20 April 2015 15:45] by Moderator

Report message to a moderator

Re: Eclipse won't start, jdk is incompatible [message #1692804 is a reply to message #1692772] Sun, 19 April 2015 04:23 Go to previous messageGo to next message
David Wegener is currently offline David WegenerFriend
Messages: 1441
Registered: July 2009
Senior Member
On 04/18/2015 09:48 PM, Jakub Fiuk wrote:
> Hello everyone
> So, right now I'm starting my adventure with Java development and I'm
> having inconveniences just on the beginning.
> Getting this error when trying to turn on the Eclipse, I've tried
> 64-bit, 32-bit, jdk for proper bit, like 4 different versions from
> 1.6u17 to the latest one and i'm helpless.
>
> Quote:
>> i .i mgur . com/IfIKo8e.png
>
>
> Also have edited the eclipse.ini file and now it looks like this:
> Quote:
>> -startup
>> plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar
>> --launcher.library
>> plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.200.v20150204-1316
>>
>> -product
>> org.eclipse.epp.package.java.product
>> --launcher.defaultAction
>> openFile
>> --launcher.XXMaxPermSize
>> 256M
>> -showsplash
>> org.eclipse.platform
>> --launcher.XXMaxPermSize
>> 256m
>> --launcher.defaultAction
>> openFile
>> --launcher.appendVmargs
>> -vmargs
>> -Dosgi.requiredJavaVersion=1.6
>> -vm
>> C:\Program Files (x86)\Java\jdk1.7.0_79\jre\bin\javaw.exe
>>
>> -Xms40m
>> -Xmx512m
>
> Please help me to fix this issue, I'm really willing to start working on
> Eclipse as soon as possible.
The -vm entries in the eclipse.ini file have to appear prior to the
-vmargs line.
Re: Eclipse won't start, jdk is incompatible [message #1692927 is a reply to message #1692804] Mon, 20 April 2015 15:46 Go to previous message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3071
Registered: July 2009
Senior Member
Please read carefully the information at https://wiki.eclipse.org/Eclipse.ini - the format is very particular and you've got it wrong.
Previous Topic:not able to install eclipse
Next Topic:Eclipse C/C++ Static Library
Goto Forum:
  


Current Time: Mon Mar 08 12:09:02 GMT 2021

Powered by FUDForum. Page generated in 0.03286 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top