Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Glassfish 4 on Eclipse(times out - java.util.concurrent.TimeoutException)
Glassfish 4 on Eclipse [message #1690373] Fri, 27 March 2015 00:19 Go to next message
Julio Comfort is currently offline Julio ComfortFriend
Messages: 1
Registered: March 2015
Junior Member
I am having troubles getting a Glassfish server to actually start and stay running on an Eclpise (luna) install.

I have had Glassfish working fine in Netbeans.

I have created the server in Eclipse and I can start it but the progress bar gets to about 69% then stops and eventual give me an error:

"Unable to start server on time. java.util.concurrent.TimeoutException"

The strange thing is that while I am waiting for the error to come up I can go too localhost:8080 and the server is running and I can go to the admin console as well.

I have increased the timeouts (start was 240sec) as well but the same thing happens.

I have deleted and recreated the server in Eclipse.

I have deleted the cache files from domain1/osgi-cache as advised in other posts

I have setup a second domain (domain2) and tried to connect to that but get the same error?

I have tried Glassfish 3.1 and 4 and both give the same result.

I am use JDK 1.7 although I have tried 1.8 - same result

Maybe there is a setting I am not doing correctly

Any advice would be greatly appreciated.

I am on OSX 10.9.5 as well if that makes a difference.

Thanks
Re: Glassfish 4 on Eclipse [message #1693547 is a reply to message #1690373] Fri, 24 April 2015 23:45 Go to previous messageGo to next message
Erun Told is currently offline Erun ToldFriend
Messages: 3
Registered: April 2015
Junior Member
Hi everyone,

I am experiencing exactly the same issues on my macbook. The only thing that worked for me was going back to an old version of the GlassFish Tools (e.g. 7.3.2.20141114 from this update site: download.oracle.com/otn_software/oepe/12.1.3.1/luna/repository).

My specs are:
OS X Yosemite 10.10.3
Java 1.8.0_31
Glassfish 4.1
Eclipse Luna SR2 (4.4.2)

Any help on this would be really appreciated Smile

Best regards,
Erun
Re: Glassfish 4 on Eclipse [message #1693574 is a reply to message #1693547] Sat, 25 April 2015 13:50 Go to previous message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3798
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 04/24/2015 11:52 PM, Erun Told wrote:
> Hi everyone,
>
> I am experiencing exactly the same issues on my macbook. The only thing
> that worked for me was going back to an old version of the GlassFish
> Tools (e.g. 7.3.2.20141114 from this update site:
> download.oracle.com/otn_software/oepe/12.1.3.1/luna/repository).
> My specs are:
> OS X Yosemite 10.10.3
> Java 1.8.0_31
> Glassfish 4.1
> Eclipse Luna SR2 (4.4.2)
>
> Any help on this would be really appreciated :)
>
> Best regards,
> Erun

This questions really belongs in the Eclipse WTP (web tools platform) forum.
Previous Topic:Getting Error message while starting Eclipse.
Next Topic:Unable to run servlet on tomcat7 from eclipse luna (ubuntu 14.04)
Goto Forum:
  


Current Time: Wed Sep 30 23:22:12 GMT 2020

Powered by FUDForum. Page generated in 0.03287 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top