Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Eclipse Projects » Advanced Scripting Environment (EASE) » Obsolete Ecore generated package extensions in EASE UI
Obsolete Ecore generated package extensions in EASE UI [message #1690011] Sun, 21 December 2014 04:56
Nicolas Rouquette is currently offline Nicolas RouquetteFriend
Messages: 157
Registered: July 2009
Senior Member
I noticed that there's been a significant refactoring of the EASE Core plugins.

In particular, there is no longer the "ScriptUIGraph" but there are still ScriptUIGraph-related extensions
in ease.ui's plugin.xml: these should be deleted.


<extension point="org.eclipse.emf.ecore.generated_package">
<!-- @generated ScriptUIGraph -->
<package
uri="http://scriptuigraph/1.0"
class="org.eclipse.ease.ui.scriptuigraph.ScriptuigraphPackage"
genModel="model/ScriptUIGraph.genmodel"/>
</extension>

<extension point="org.eclipse.emf.edit.itemProviderAdapterFactories">
<!-- @generated ScriptUIGraph -->
<factory
uri="http://scriptuigraph/1.0"
class="org.eclipse.ease.ui.scriptuigraph.provider.ScriptuigraphItemProviderAdapterFactory"
supportedTypes=
"org.eclipse.emf.edit.provider.IEditingDomainItemProvider
org.eclipse.emf.edit.provider.IStructuredItemContentProvider
org.eclipse.emf.edit.provider.ITreeItemContentProvider
org.eclipse.emf.edit.provider.IItemLabelProvider
org.eclipse.emf.edit.provider.IItemPropertySource"/>
</extension>


- Nicolas.
Previous Topic:Corrupt Git repository?
Next Topic:Shouldn't the EcoreModule initialize its selectionModule?
Goto Forum:
  


Current Time: Sun Feb 18 01:51:06 GMT 2018

Powered by FUDForum. Page generated in 0.02427 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software