Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Compare » Problems with the Diff-Feature
Problems with the Diff-Feature [message #1689364] Mon, 23 March 2015 12:01 Go to next message
Simon BBBBBBB is currently offline Simon BBBBBBBFriend
Messages: 54
Registered: March 2015
Member
Hello there,

i am new to EMF-Compare and i use it to compare parts of my models. I have enountered a problem with the comparison where there are differences but the compare algorithm cant find them.

here are my two models

index.php/fa/21275/0/
index.php/fa/21276/0/

Here is the code i use:

IComparisonScope scope = new DefaultComparisonScope(sourceEPackage,
				deletedModelEPackage, null);
Comparison comparison = EMFCompare.builder().build().compare(scope);
List<Diff> differences = comparison.getDifferences();


After i have run the code the list is empty.

Any other changes are found and properly shown.

The model on picture 2 is contained in another element not shown in the screenshot. Is it possible that this causes the error?

I am using org.eclipse.emf.compare with version 3.0.2.201501201328

I would appreciate any help. Thank you.
Re: Problems with the Diff-Feature [message #1689468 is a reply to message #1689364] Mon, 23 March 2015 16:36 Go to previous messageGo to next message
Axel RICHARD is currently offline Axel RICHARDFriend
Messages: 35
Registered: September 2010
Location: France
Member
Hi Simon,

Unfortunately, EMF Compare doesn't support the comparison of EGenerics inside EType Parameters yet. So it is normal that you see no differences in your case.
You can raise an enhancement bug to describe what you need: https://bugs.eclipse.org/bugs/enter_bug.cgi?product=EMFCompare
If you're interested to contribute to EMF Compare and manage this case, you can follow the contributor guide: https://wiki.eclipse.org/EMF_Compare/Contributor_Guide

Regards,


Axel Richard
Obeo
Re: Problems with the Diff-Feature [message #1700260 is a reply to message #1689468] Wed, 01 July 2015 09:52 Go to previous messageGo to next message
Simon BBBBBBB is currently offline Simon BBBBBBBFriend
Messages: 54
Registered: March 2015
Member
i made an enchancement request but unortunatly no one responds. is there something wrong with it? https://bugs.eclipse.org/bugs/show_bug.cgi?id=467816
Re: Problems with the Diff-Feature [message #1700510 is a reply to message #1700260] Fri, 03 July 2015 07:20 Go to previous messageGo to next message
Laurent Goubet is currently offline Laurent GoubetFriend
Messages: 1857
Registered: July 2009
Senior Member
Simon,

There is nothing wrong with your enhancement request, just that we missed it among the rest of the active bugzilla entries. Then again, this particular issue is not a priority for the EMF Compare team as there are more pressing bugs to handle.

We are open to contributions though, and we look at contributed patches asap. So if this issue is important for you and you want to try and tackle it yourself, please do. You'll probably have to look in the direction of our org.eclipse.emf.compare.diff.FeatureFilter , since we probably filter out the differences on EGenericTypes.

Laurent Goubet
Obeo
Re: Problems with the Diff-Feature [message #1700784 is a reply to message #1700510] Tue, 07 July 2015 07:46 Go to previous message
Simon BBBBBBB is currently offline Simon BBBBBBBFriend
Messages: 54
Registered: March 2015
Member
Hello Laurent,

thank you for your reply. i will try to free up some time to look into the featurefilter.

Greetings
Previous Topic:Model Resolving step
Next Topic:Consider cross references for comparison
Goto Forum:
  


Current Time: Sat Jul 21 09:58:45 GMT 2018

Powered by FUDForum. Page generated in 0.02125 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top