Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » Exit Code 13 After eclipse.ini fix
Exit Code 13 After eclipse.ini fix [message #1688001] Fri, 20 March 2015 02:55 Go to next message
Zachary Landry is currently offline Zachary LandryFriend
Messages: 2
Registered: March 2015
Junior Member
Hey Guys,

I keep getting exit code 13 after I installed a new JDK for Android Studio. I have searched all over, and even "re-installed" if you can even call ti that, Eclipse to the latest version. Both eclipse and JDK are 32-bit. Here is my .ini file if that is any help, notice I added in the -vm and javaw.exe before -vmargs.

Quote:
-startup

plugins/org.eclipse.equinox.launcher_1.3.0.v20140415-2008.jar

--launcher.library

plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v20150204-1316

-product

org.eclipse.epp.package.java.product

--launcher.defaultAction

openFile

--launcher.XXMaxPermSize
256M

-showsplash

org.eclipse.platform

--launcher.XXMaxPermSize

256m

--launcher.defaultAction

openFile

-vm
C:\Program Files (x86)\Java\jdk1.8.0_40\bin\javaw.exe
--launcher.appendVmargs

-vmargs

-Dosgi.requiredJavaVersion=1.6

-Xms40m

-Xmx512m



The quicker someone can help me the better as I have Java homework due tomorrow afternoon.

Thanks all and have a good evening,
Zach
Re: Exit Code 13 After eclipse.ini fix [message #1688014 is a reply to message #1688001] Fri, 20 March 2015 03:21 Go to previous messageGo to next message
Nitin Dahyabhai is currently offline Nitin DahyabhaiFriend
Messages: 3991
Registered: July 2009
Senior Member

> plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.200.v20150204-1316

If that's not a typo, either the .ini is wrong for a 32-bit Eclipse, or it's actually still a 64-bit Eclipse.


Nitin Dahyabhai
Eclipse Web Tools Platform
Re: Exit Code 13 After eclipse.ini fix [message #1688033 is a reply to message #1688014] Fri, 20 March 2015 04:07 Go to previous message
Zachary Landry is currently offline Zachary LandryFriend
Messages: 2
Registered: March 2015
Junior Member
Hi Nitin,

Turns out I did in fact accidentally download 64-bit eclipse. I then copied the extracted files to my Program Files x86 folder, which convinced me there was no way I downloaded the 64-bit version.

Thank you very much!
Previous Topic:copy & paste don't work fine
Next Topic:Problem building a new C/C++ project
Goto Forum:
  


Current Time: Fri Feb 26 07:28:02 GMT 2021

Powered by FUDForum. Page generated in 0.02431 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top