Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » Jubula » Incomplete Test Data(How to find incomplete Test Data)
Incomplete Test Data [message #1681884] Tue, 17 March 2015 14:00 Go to next message
nicole h is currently offline nicole hFriend
Messages: 27
Registered: May 2013
Junior Member
Hi,

I made a TestCase which uses an Excel File as Data Source and everthing works fine but when I try to reuse this TestCase (in an other Testcase), Jubula tells me "Test Data for this node is incomplete".

Where I reuse the Testcase, I did exactly the same (used all the same parameters) but it won't work and I don't know how to find out which kind of TestData is missing as I am using the same TestCase and in one place it works and in the other place it doesn't?

One strange thing I observed:
Prior to restarting Jubula, I was able to run the TestSuite although the "Test Data for this node is incomplete" problem existed and the TestRun was successfull.... (So, for me it seem like all TestData are there? otherwise the Test could not have been succesfully?)

Any suggestions for me?

Thanks,

Re: Incomplete Test Data [message #1684109 is a reply to message #1681884] Wed, 18 March 2015 09:40 Go to previous messageGo to next message
Alexandra Schladebeck is currently offline Alexandra SchladebeckFriend
Messages: 1613
Registered: July 2009
Senior Member
Hi there Nicole,

It looks like you're running into an old problem whereby nodes with Excel data don't correctly reuse this data when they are reused.
The workaround is to not add the Excel data to the test case definition, but to add it where the test case is reused.

I'll try to find the bug, .

Best regards,
Alex
Re: Incomplete Test Data [message #1686501 is a reply to message #1684109] Thu, 19 March 2015 08:09 Go to previous messageGo to next message
nicole h is currently offline nicole hFriend
Messages: 27
Registered: May 2013
Junior Member
Hi Alex,

thanks for your reply, but I already implemented it the way you described it.

In the TestCase Specification, the "Data Source" is set to "Local Test Case" and for my Parameters I used variables (=var1, =var2, =var3,...) and where I reuse this TestCase, the Data Source is set to "Excel Data File" and the Parameters get a lcoked sign.

I also executed the TestCase again and it really works, Jubula uses also the right Excel files and executes all the TestCases....

Any other suggestions? As this is really annoying when all the testcases show these "red crosses" and tells me, TestData are missing but it is obviously not...


Thanks
Re: Incomplete Test Data [message #1686735 is a reply to message #1686501] Thu, 19 March 2015 10:24 Go to previous message
nicole h is currently offline nicole hFriend
Messages: 27
Registered: May 2013
Junior Member
HA! Solved it now Smile

I added a Path to an Excel File in the TestSpecification now and when I reuse the TestCase, I simply enter a new Path of the current Excel File!

Thanks
Previous Topic:Click on Text
Next Topic:set the parameter values outside from Jubula
Goto Forum:
  


Current Time: Sat Feb 24 14:19:31 GMT 2024

Powered by FUDForum. Page generated in 0.01438 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top