Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Newcomers » Newcomers » [Luna, m2e] Maven deps do not find version fields in POM(Uncertain if this is an Eclipse issue or a Maven issue)
[Luna, m2e] Maven deps do not find version fields in POM [message #1679264] Mon, 16 March 2015 14:41 Go to next message
Joseph Osako is currently offline Joseph OsakoFriend
Messages: 4
Registered: March 2015
Junior Member
I have a Maven project which, following a restart, has had a peculiar issue: it reports that there is no version field for one of the dependencies, even though the field is in fact populated. I have checked the pom.xml source, and confirmed that the field is in fact there and populated for all the dependencies. I am uncertain why m2e is saying otherwise. Is this a known issue, and if so, is there a specific fix for it?

The version of the m2e plugin is 1.5.1 . Here is the dependencies section of POM file in question:

	<dependencies>
		<dependency>
			<groupId>org.apache.camel</groupId>
			<artifactId>apache-camel</artifactId>
			<type>pom</type>
			<version>2.15.0</version>
		</dependency>
		<dependency>
			<groupId>org.slf4j</groupId>
			<artifactId>slf4j-parent</artifactId>
			<type>pom</type>
			<version>1.7.10</version>
		</dependency>
		<dependency>
			<groupId>org.apache.logging.log4j</groupId>
			<artifactId>log4j</artifactId>
			<type>pom</type>
			<version>2.2</version>
		</dependency>
		<dependency>
			<groupId>org.apache.mina</groupId>
			<artifactId>mina-parent</artifactId>
			<type>pom</type>
			<version>3.0.0-M2</version>
		</dependency>
	</dependencies>

[Updated on: Mon, 16 March 2015 14:45]

Report message to a moderator

Re: [Luna, m2e] Maven deps do not find version fields in POM [message #1680434 is a reply to message #1679264] Tue, 17 March 2015 01:02 Go to previous messageGo to next message
Russell Bateman is currently offline Russell BatemanFriend
Messages: 3798
Registered: July 2009
Location: Provo, Utah, USA
Senior Member

On 03/16/2015 08:41 AM, Joseph Osako wrote:
> I have a Maven project which, following a restart, has had a peculiar
> issue: it reports that there is no version field for one of the
> dependencies, even though the field is in fact populated. I have checked
> the pom.xml source, and confirmed that the field is in fact there and
> populated for all the dependencies. I am uncertain why m2e is saying
> otherwise. Is this a known issue, and if so, is there a specific fix for
> it?
>
> Here is the dependencyies section of POM file in question:
>
>
> <dependencies>
> <dependency>
> <groupId>org.apache.camel</groupId>
> <artifactId>apache-camel</artifactId>
> <type>pom</type>
> <version>2.15.0</version>
> </dependency>
> <dependency>
> <groupId>org.slf4j</groupId>
> <artifactId>slf4j-parent</artifactId>
> <type>pom</type>
> <version>1.7.10</version>
> </dependency>
> <dependency>
> <groupId>org.apache.logging.log4j</groupId>
> <artifactId>log4j</artifactId>
> <type>pom</type>
> <version>2.2</version>
> </dependency>
> <dependency>
> <groupId>org.apache.mina</groupId>
> <artifactId>mina-parent</artifactId>
> <type>pom</type>
> <version>3.0.0-M2</version>
> </dependency>
> </dependencies>

Actually, this question might not get a response here. It's not really
what this forum is for. I might have taken a look, but there isn't
anything like enough information.

You might get more help at stackoverflow.com, but I would include
particuars with this like whether there is a parent pom, which
dependency is the one complained about, what your dependency management
looks like, etc.
Re: [Luna, m2e] Maven deps do not find version fields in POM [message #1682391 is a reply to message #1680434] Tue, 17 March 2015 18:16 Go to previous message
Joseph Osako is currently offline Joseph OsakoFriend
Messages: 4
Registered: March 2015
Junior Member
Well, that's one of the things I wasn't certain about; I'll look at some other venues to discuss this, then. Thank you.
Previous Topic:RSE on dual eclipse
Next Topic:Fatal startup error in Display.applicationWillFinishLaunching
Goto Forum:
  


Current Time: Sat Mar 06 23:46:35 GMT 2021

Powered by FUDForum. Page generated in 0.03746 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top