Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » EMF "Technology" (Ecore Tools, EMFatic, etc)  » small bug in CDO
small bug in CDO [message #32405] Thu, 20 April 2006 21:54 Go to next message
Mark Geib is currently offline Mark GeibFriend
Messages: 432
Registered: July 2009
Senior Member
Eike,

Found a small bug in the new CDO.

In ClassInfoImpl.java you call getEAttributes() where you should call
getEAllAttributes() so that the super class attributes are returned also.

Mark.
Re: small bug in CDO [message #32475 is a reply to message #32405] Fri, 21 April 2006 11:45 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: merks.ca.ibm.com

This is a multi-part message in MIME format.
--------------090701040806040807000303
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 7bit

Mark,

You should report bugs using bugzilla. Here's a link that gets you most
of the way to the right place.

https://bugs.eclipse.org/bugs/enter_bug.cgi?product=EMFT

Use either CDO or Net4j as the components (whichever is most
appropriate) so it ends up on Eike's list.


Geib wrote:
> Eike,
>
> Found a small bug in the new CDO.
>
> In ClassInfoImpl.java you call getEAttributes() where you should call
> getEAllAttributes() so that the super class attributes are returned also.
>
> Mark.
>


--------------090701040806040807000303
Content-Type: text/html; charset=ISO-8859-15
Content-Transfer-Encoding: 8bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-15"
http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Mark,<br>
<br>
You should report bugs using bugzilla.
Re: small bug in CDO [message #32612 is a reply to message #32475] Fri, 21 April 2006 16:10 Go to previous messageGo to next message
Mark Geib is currently offline Mark GeibFriend
Messages: 432
Registered: July 2009
Senior Member
Done.
Re: small bug in CDO [message #32646 is a reply to message #32612] Sat, 22 April 2006 12:50 Go to previous messageGo to next message
Eclipse UserFriend
Originally posted by: stepper.sympedia.com

Mark,

As I also told you in your Email, I'll be able to look at this issue, when
I'm back in Berlin. That will be on Thursday.

Cheers
/Eike
Re: small bug in CDO [message #33006 is a reply to message #32612] Sun, 30 April 2006 06:30 Go to previous message
Eclipse UserFriend
Originally posted by: stepper.sympedia.de

Mark,

I fixed it. Thanks!

Cheers
/Eike
Re: small bug in CDO [message #575883 is a reply to message #32405] Fri, 21 April 2006 11:45 Go to previous message
Ed Merks is currently offline Ed MerksFriend
Messages: 33148
Registered: July 2009
Senior Member
This is a multi-part message in MIME format.
--------------090701040806040807000303
Content-Type: text/plain; charset=ISO-8859-15; format=flowed
Content-Transfer-Encoding: 7bit

Mark,

You should report bugs using bugzilla. Here's a link that gets you most
of the way to the right place.

https://bugs.eclipse.org/bugs/enter_bug.cgi?product=EMFT

Use either CDO or Net4j as the components (whichever is most
appropriate) so it ends up on Eike's list.


Geib wrote:
> Eike,
>
> Found a small bug in the new CDO.
>
> In ClassInfoImpl.java you call getEAttributes() where you should call
> getEAllAttributes() so that the super class attributes are returned also.
>
> Mark.
>


--------------090701040806040807000303
Content-Type: text/html; charset=ISO-8859-15
Content-Transfer-Encoding: 8bit

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<meta content="text/html;charset=ISO-8859-15"
http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
Mark,<br>
<br>
You should report bugs using bugzilla.


Ed Merks
Professional Support: https://www.macromodeling.com/
Re: small bug in CDO [message #576013 is a reply to message #32475] Fri, 21 April 2006 16:10 Go to previous message
Mark Geib is currently offline Mark GeibFriend
Messages: 432
Registered: July 2009
Senior Member
Done.
Re: small bug in CDO [message #576033 is a reply to message #32612] Sat, 22 April 2006 12:50 Go to previous message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6683
Registered: July 2009
Senior Member
Mark,

As I also told you in your Email, I'll be able to look at this issue, when
I'm back in Berlin. That will be on Thursday.

Cheers
/Eike


Re: small bug in CDO [message #576476 is a reply to message #32612] Sun, 30 April 2006 06:30 Go to previous message
Eike Stepper is currently offline Eike StepperFriend
Messages: 6683
Registered: July 2009
Senior Member
Mark,

I fixed it. Thanks!

Cheers
/Eike


Previous Topic:CDO performance issues
Next Topic:[Announce] EMFT JET is available
Goto Forum:
  


Current Time: Sun May 19 06:27:25 GMT 2024

Powered by FUDForum. Page generated in 0.04709 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top