Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Modeling » Graphiti » SWTBot test
SWTBot test [message #1670877] Fri, 13 March 2015 11:23 Go to next message
Krisztian Koncz is currently offline Krisztian KonczFriend
Messages: 31
Registered: September 2014
Location: Budapest
Member

Dear Michael.

I want to make some improvements in the Graphiti editor, but i have some problems. I have checked out the project to a fresh installed Luna, setted up an API BaseLine, installed SWTBot. I don't have any error in the projects, but I can't run the SWTBot tests. When I run the AllBotTests.launch configuration, I got the following error:

Exception in thread "Plug-in Tests Runner" java.lang.IllegalArgumentException: Bundle "org.eclipse.graphiti.bot.tests" not found. Possible causes include missing dependencies, too restrictive version ranges, or a non-matching required execution environment.
	at org.eclipse.pde.internal.junit.runtime.RemotePluginTestRunner.getClassLoader(RemotePluginTestRunner.java:77)
	at org.eclipse.pde.internal.junit.runtime.RemotePluginTestRunner.getTestClassLoader(RemotePluginTestRunner.java:71)
	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.loadClass(RemoteTestRunner.java:685)
	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.loadClasses(RemoteTestRunner.java:421)
	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:444)
	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:675)
	at org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:382)
	at org.eclipse.pde.internal.junit.runtime.RemotePluginTestRunner.main(RemotePluginTestRunner.java:62)
	at org.eclipse.pde.internal.junit.runtime.PlatformUITestHarness$1.run(PlatformUITestHarness.java:47)
	at java.lang.Thread.run(Thread.java:745)


Do you have any idea about this?
Thank yout in advance,
KrisztiƔn
Re: SWTBot test [message #1679446 is a reply to message #1670877] Mon, 16 March 2015 16:16 Go to previous messageGo to next message
Michael Wenz is currently offline Michael WenzFriend
Messages: 1899
Registered: July 2009
Location: Walldorf, Germany
Senior Member
Krisztian,

strange. I just tried to start the Bot tests locally on my machine and also
get a strange error, but something different (Jetty seems to have a package
import for a too new javax.servlet ). When I switch the run configuration to
use my JDK 7 it works.

I will need to check that in more depth...

Maybe you could also try to use JDK 7 for running the tests. Does that help
for you as well?

Michael
Re: SWTBot test [message #1681346 is a reply to message #1679446] Tue, 17 March 2015 09:20 Go to previous message
Krisztian Koncz is currently offline Krisztian KonczFriend
Messages: 31
Registered: September 2014
Location: Budapest
Member

Sorry Michael, that was my fault... There was a whitespace character in the path of the local git repository.. Everything work fine, all tests are green Smile

Thanks
Previous Topic:Set background color in text editor lines (PDE)
Next Topic:Disable a connection
Goto Forum:
  


Current Time: Fri Nov 16 11:21:37 GMT 2018

Powered by FUDForum. Page generated in 0.02309 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top