Skip to main content


Eclipse Community Forums
Forum Search:

Search      Help    Register    Login    Home
Home » Archived » BIRT » Eclipse BIRT Report(Unable to see BIRT Report in Web Viewer)
icon3.gif  Eclipse BIRT Report [message #1649770] Wed, 04 March 2015 13:55 Go to next message
kshirod mishra is currently offline kshirod mishraFriend
Messages: 50
Registered: March 2015
Member
Dear Team,

I am using Eclipse BIRT for generating BIRT report. I have copied the web viewer in webapps folder of Tomcat. Then i changed the Web Viewer example to BIRT. When i clicked the BIRT from Tomcat's List of applications. It is working fine .But when i am trying to run my designed report from web viewer , i am getting error as "The report file : EmployeeTest_report does not exist or contains errors." I have added commons loging jar file in WEB-INF folder of BIRT. My report is running fine in Eclipse but it is not working in Web-Viewer. I am using below mentioned versions of applications.Logs has been attached for your quick references.Please help me solving this issue, i will be ever grateful to you.

Below are the URLs that i have tried in Webviewer.

localhost:8084/WebViewerExample/run?__report=EmployeeTest_report

localhost:8084/WebViewerExample/frameset?__report=EmployeeTest_report



Eclipse BIRT: Version-4.4.1
Tomcat:7.0



Thanks & Regards:
kshirod Mishra
Re: Eclipse BIRT Report [message #1649869 is a reply to message #1649770] Wed, 04 March 2015 14:53 Go to previous messageGo to next message
Eric Rizzo is currently offline Eric RizzoFriend
Messages: 3070
Registered: July 2009
Senior Member
Moving this to the BIRT forum. In the future please ask BIRT-related questions there.
Re: Eclipse BIRT Report [message #1650574 is a reply to message #1649869] Wed, 04 March 2015 22:37 Go to previous messageGo to next message
Jesse Freeman is currently offline Jesse FreemanFriend
Messages: 184
Registered: January 2015
Senior Member
Where did you place your report design?
In your URL, you are not including the .rptdesign file extension of the report design. Try adding this to the URL and see if that makes a difference.
Re: Eclipse BIRT Report [message #1667922 is a reply to message #1650574] Thu, 12 March 2015 08:47 Go to previous messageGo to next message
kshirod mishra is currently offline kshirod mishraFriend
Messages: 50
Registered: March 2015
Member
Thanks a lot Jesse Freeman. This is got resolved.....
Re: Eclipse BIRT Report [message #1668684 is a reply to message #1667922] Thu, 12 March 2015 15:50 Go to previous messageGo to next message
Jesse Freeman is currently offline Jesse FreemanFriend
Messages: 184
Registered: January 2015
Senior Member
Thanks for updating the thread.
I'm glad to hear you were able to resolve the issue.
Re: Eclipse BIRT Report [message #1678237 is a reply to message #1668684] Mon, 16 March 2015 05:48 Go to previous messageGo to next message
kshirod mishra is currently offline kshirod mishraFriend
Messages: 50
Registered: March 2015
Member
Hi Jesse,

Could you help me for the below issue. I will be very much grateful to you.

My problem is :- I have created one report using ECLIPSE BIRT by creating one dynamic WEB PROJECT. After that i have tried to create a WAR file by right clicking on my project folder.After the creation of war file, i tried to cross check whether my WAR file contains all the folders, sub folders and report also. Bu there is no report file (.rptdesign exxtenxion )found inside my WAR file. Please help me how to sort it out. I have tried also to google but there is no proper answer i got .

My Objective is to create a WAR file from my BIRT Report and deploy it inside "Tomcat Web Application Manager", so that i will click on my application tomcat should able to render my report in web browser. I need an urgent help for the same so that i will be grateful to you.Please help me how to proceed step by step.

Eclipse BIRT Version: 4.4.1
Tomcat: 7.0.55



Thanks & Regards:
kshirod Mishra
Re: Eclipse BIRT Report [message #1679075 is a reply to message #1649869] Mon, 16 March 2015 13:06 Go to previous message
kshirod mishra is currently offline kshirod mishraFriend
Messages: 50
Registered: March 2015
Member
Hi Eric,

I have posted one issue in BIRT forum but nobody has come forward to help me. Could you please help me in getting my issue resolved. I have also created one ticket in Bugzila. Please find the ticket no below and help me in solving my issue. It will be grate ful to you.

Bug 462198


Thanks & Regards:
kshirod Mishra
Previous Topic:Errors occurred when generating the report document
Next Topic:Pass a value to pie chart and then change itself
Goto Forum:
  


Current Time: Sun Jul 14 03:00:17 GMT 2024

Powered by FUDForum. Page generated in 0.04030 seconds
.:: Contact :: Home ::.

Powered by: FUDforum 3.0.2.
Copyright ©2001-2010 FUDforum Bulletin Board Software

Back to the top